Welcome to PriusChat

We'd love to have you join our community and participate in the conversation! Sign up for FREE today.

Sign Up

Bluetooth Phone Disconnects

Discussion in 'Prius c Main Forum' started by kkim, Apr 13, 2012.

Social Buttons

  1. kkim

    kkim Active Member

    Joined:
    Jan 27, 2007
    Messages:
    381
    Likes Received:
    121
    Location:
    kauai, hawaii
    Your Vehicle Year:
    2012 Prius c
    Model:
    III
    This is in a Pc III.

    Trying to figure out if it's a phone problem or a BT problem with the c. My wife's phone keeps disconnecting (actually not connecting at startup) even though it has been setup and used successfully over a period of time. I was having the same problem after we initially bought the car, so I deleted all connections and devices and set up her phone from scratch and seemed to connect successfully and has worked without problems for the last few weeks. This morning, she tells me the phone is not connecting in the car again. :mad:

    Anyone suffering the same problem? I am open to suggestions as to it being a setup error and how to fix it, but am more looking for experiences from others having similar problems.

    I'm going to have her take the car back to the dealer tomorrow and have them setup her phone connection for her to rule out setup error.
  2. j_benj

    j_benj Prius C Fan

    Joined:
    Apr 10, 2012
    Messages:
    125
    Likes Received:
    11
    Location:
    Jersey
    Your Vehicle Year:
    2012 Prius c
    Model:
    Three
    I noticed this morning that my iPhone 4S did not automatically connect when I started the car. I had to hit the phone button and manually press connect on the touchscreen. I was auto-connecting the last few days.
  3. jdcollins5

    jdcollins5 Senior Member

    Joined:
    Aug 30, 2009
    Messages:
    4,443
    Likes Received:
    930
    Location:
    Wilmington, NC
    Your Vehicle Year:
    2010 Prius
    Model:
    III
    I have a 2010 Gen III and not a c but have recently had a similar problem with a new phone I just got at work about 2-3 months ago. I never had an issue with an earlier LG phone from Verizon. I have now switched to a Pantech Hotshot phone and am now having similar issues with it radomly not connecting at startup.

    I have finally narrowed mine down to the fact that if I turn Bluetooth off on the phone and then back on and then manually reconnect from the Nav it will connect. I now get to have the fun of going back to Verizon and/or Pantech and see how much fingerpointing I get before someone finally fixes it.

    Mine is definitely in the phone and not the Nav. Even though the c has an upgraded Nav system I would expect the Bluetooth to work similarly.
  4. kkim

    kkim Active Member

    Joined:
    Jan 27, 2007
    Messages:
    381
    Likes Received:
    121
    Location:
    kauai, hawaii
    Your Vehicle Year:
    2012 Prius c
    Model:
    III


    This is interesting (actually ironic) that the phone I'm having problems with is an old Verizon LG 8350.
  5. managerman

    managerman Prius c and Prius v Nerd

    Joined:
    Mar 12, 2012
    Messages:
    228
    Likes Received:
    96
    Location:
    Columbus, OH
    Your Vehicle Year:
    2012 Prius c
    Model:
    Three
    Yep...same issue with Iphone 4S. It does not connect on startup about 1 out of 4 times.

    -M
  6. j_benj

    j_benj Prius C Fan

    Joined:
    Apr 10, 2012
    Messages:
    125
    Likes Received:
    11
    Location:
    Jersey
    Your Vehicle Year:
    2012 Prius c
    Model:
    Three
    I'm going to get in the habit of hitting the phone button on my stereo just to force it to connect every time. Annoying but at least I'll always have it working until some kind of software update comes out.
  7. kkim

    kkim Active Member

    Joined:
    Jan 27, 2007
    Messages:
    381
    Likes Received:
    121
    Location:
    kauai, hawaii
    Your Vehicle Year:
    2012 Prius c
    Model:
    III
    What is more puzzling is this the same phone she was using in the 07 Prius which had bluetooth (but no nav) and once it was set up in that car, back when we first purchased it, I never had to play with it to get it to connect. Seems they might have taken a step backward with regards to BT connectivity.

    My salesman called back after he had talked to some BT savy techs. They are suggesting, as you have done, to see if the phone will reconnect by initiating it w/ the mode button on the steering wheel. I'll have to try that tonight.

    Another thing I'd noticed when setting up the Bluetooth link was that the signal strength itself was showing pretty low in the car display. Wonder if that might be an issue.
  8. crebble

    crebble Member

    Joined:
    Mar 16, 2012
    Messages:
    176
    Likes Received:
    44
    Location:
    Shohola PA
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A
    My iPhone 4 glitches sometimes as well and won't connect. It also doesn't connect to my Escort Live! BT. I reboot the phone and all is well. My iPhone has always had glitchy BT and I had similar problems with my Infiniti.

    The problem seems to happen most when I forget to start The Entune app before plugging it in.
  9. jon_lancaster_toyota

    jon_lancaster_toyota Nate Riesen

    Joined:
    Apr 29, 2009
    Messages:
    120
    Likes Received:
    67
    Location:
    Madison, WI
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A
    Kkim, pressing mode on the steering wheel will just turn the radio on, nothing will be I initialized.
    Run over to Toyota.com - Connect and see if your phone's connectivity has been tested. My guess is that it hasn't and this exercise will be a waste, but give it a try. JDCOLLONS do e same please. And Jd, if u go back to Verizon, aske them to let you try and connect another pantech phone of the same model. Let's verify that the problem persists with a different device.

    IPHONE users, I've been suggesting at you deactivate wifi on your iphone and see if that solves e problem. Do so regardless of weather you're connected to a wifi network. Let's see of there's some sort of interference.

    ALL users could try a cell phone restart when this problem happens. Restart the phone and wait for it to connect to the cellular network, them start the car.
    1 person likes this.
  10. kkim

    kkim Active Member

    Joined:
    Jan 27, 2007
    Messages:
    381
    Likes Received:
    121
    Location:
    kauai, hawaii
    Your Vehicle Year:
    2012 Prius c
    Model:
    III
    Nate,

    You are right, it says my phone has not been tested for compatibility, but I have successfully paired the phone and it's been working for weeks. Are you telling me even through I can get to work, it is acceptable for it to up and quit connecting one day just because compatibility has not been tested by Toyota?

    Also, the phone has worked fine with other Toyota BT radios in the past.

    This BT phone connect business sure sounds buggy. I've never had a problem with phones not connecting after the initial setup with aftermarket BT radios. How hard can it be if they can get it right?

    Thanks for your input and help. :)
  11. j_benj

    j_benj Prius C Fan

    Joined:
    Apr 10, 2012
    Messages:
    125
    Likes Received:
    11
    Location:
    Jersey
    Your Vehicle Year:
    2012 Prius c
    Model:
    Three


    I have disabled my wifi on my 4S and will see how it goes while I'm out running errands in a bit!
  12. jdcollins5

    jdcollins5 Senior Member

    Joined:
    Aug 30, 2009
    Messages:
    4,443
    Likes Received:
    930
    Location:
    Wilmington, NC
    Your Vehicle Year:
    2010 Prius
    Model:
    III


    Nate,

    I went to Toyota Connect and verified that my phone connectivity has been tested.

    I started out restarting my phone and this would fix the problem every time. Then I thought about the restart may just be restarting the Bluetooth so I tried just restarting Bluetooth without restarting the entire phone and this also worked. Turning the phone Bluetooth off and then back on is less time consuming than restarting the phone.

    I will see if Verizon will let me try another phone. The problem is that in my case the connection issue is random and will take some time and I do not know if Verizon will let me keep another phone for any length of time.

    Dwight
  13. crebble

    crebble Member

    Joined:
    Mar 16, 2012
    Messages:
    176
    Likes Received:
    44
    Location:
    Shohola PA
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A


    Really think this is an iOS problem. I've had this exact issue with multiple BT devices since iOS 4. I used to have a shortcut to BT so I could reset it quickly but iOS 5.1 broke shortcuts.
  14. R11

    R11 New Member

    Joined:
    Feb 8, 2012
    Messages:
    101
    Likes Received:
    16
    Location:
    Portland, OR
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A
    I don't have a a bluetooth phone but I used to have a bluetooth mouse for my laptop and it caused me all kinds of grief. I finally threw it in a drawer, bought a wireless USB mouse and said goodbye to the hassles. BT just seems to have such a picky connect protocol..


    ron
  15. jon_lancaster_toyota

    jon_lancaster_toyota Nate Riesen

    Joined:
    Apr 29, 2009
    Messages:
    120
    Likes Received:
    67
    Location:
    Madison, WI
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A


    Is your phone is designed to broadcast a wifi hot spot?
    Is it always broadcasting?
  16. jon_lancaster_toyota

    jon_lancaster_toyota Nate Riesen

    Joined:
    Apr 29, 2009
    Messages:
    120
    Likes Received:
    67
    Location:
    Madison, WI
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A
    Jnenj: is your iphone equipped To broadcast a wifi hot spot?

    Wifi interferes with Bluetooth, and I wonder if that's causing these problems. The connection with the entune head units is pretty serious. There are 3+ different profiles connected at one given time, (voice, music, data phone book, playback control). A moderate amount of interference could cause problems.

    Can anyone verify that things improved by disabling your wifi before you start the car?
  17. jdcollins5

    jdcollins5 Senior Member

    Joined:
    Aug 30, 2009
    Messages:
    4,443
    Likes Received:
    930
    Location:
    Wilmington, NC
    Your Vehicle Year:
    2010 Prius
    Model:
    III


    Not that I know of.




    It is configured for Auto Pair Handsfree like my other phone and should be broadcasting every so often.

    It works 9 times out of 10.
  18. jon_lancaster_toyota

    jon_lancaster_toyota Nate Riesen

    Joined:
    Apr 29, 2009
    Messages:
    120
    Likes Received:
    67
    Location:
    Madison, WI
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A
    Have any iPhone users tried to turn off the wifi on their phones? If so, has it remedied the slow connection at start-up or shown better connect ability?
  19. j_benj

    j_benj Prius C Fan

    Joined:
    Apr 10, 2012
    Messages:
    125
    Likes Received:
    11
    Location:
    Jersey
    Your Vehicle Year:
    2012 Prius c
    Model:
    Three
    No my personal hotspot is not turned on (no tethering allowed on my data plan).

    I have tried turning WIFI off and it seems to still not auto connect 1 out of 5 times or so.

    I've gotten into the habit of pressing the phone button next to the CD slot after starting the car just to make sure. If its not connected, pressing that button will force a connection. Gets the job done :)
  20. jon_lancaster_toyota

    jon_lancaster_toyota Nate Riesen

    Joined:
    Apr 29, 2009
    Messages:
    120
    Likes Received:
    67
    Location:
    Madison, WI
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A
    I'm sorry, I'm out of ideas until I can see it again in person and understand what's happening. In person....I mean my messing around with it as I demo the car. Sorry.
Similar Threads: Bluetooth Phone
Forum Title Date
Gen III 2010+ Prius Audio and Electronics 2014 Prius 3, Bluetooth and Iphone 5s Aug 15, 2014
Prius c Main Forum iPhone 5 c & Prius C Bluetooth Aug 8, 2014
Gen III 2010+ Prius Main Forum Looking for a GPS with hands free Bluetooth for iPhone. Jul 13, 2014
Gen III 2010+ Prius Care, Maintenance and Troubles Bluetooth and Phone calls May 6, 2014
Gen III 2010+ Prius Audio and Electronics Bluetooth audio from iphone on prius 2010 model Apr 18, 2014