Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Sign Up

No EV Indicator

Discussion in 'Gen II Prius Accessories & Modifications' started by blown240, May 20, 2011.

Social Buttons

  1. blown240

    blown240 New Member

    Joined:
    Apr 28, 2011
    Messages:
    53
    Likes Received:
    8
    Location:
    SoCal
    Your Vehicle Year:
    2005 Prius
    Model:
    N/A
    I just installed a DIY EV switch from misc stuff I had laying around the garage. Basically just a wire from the ECU to a momentary switch then to ground. It works great and acts just like it should, but I get no EV indicator on the dash. Could it be that mine is burnt out, or maybe it was never there? Its an 05 Pkg 3.

    THANKS!
  2. brick

    brick Active Member

    Joined:
    Dec 10, 2006
    Messages:
    1,079
    Likes Received:
    61
    Location:
    Upstate NY
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A
    We didn't get the indicator in North America. I know I harp on the ScanGauge a lot, but that's the only way I know of to get an indicator.
  3. blown240

    blown240 New Member

    Joined:
    Apr 28, 2011
    Messages:
    53
    Likes Received:
    8
    Location:
    SoCal
    Your Vehicle Year:
    2005 Prius
    Model:
    N/A
    Well I guess thats why it didnt turn on!

    Thanks!
  4. trigga

    trigga New Member

    Joined:
    Jan 15, 2011
    Messages:
    17
    Likes Received:
    0
    Location:
    SC
    Your Vehicle Year:
    2005 Prius
    Model:
    N/A
    Im doing the same thing right now, I was wondering that too. But I also had a question. Do I or should I disconnect the 12v battery before I unplug the H14 connector?
  5. blown240

    blown240 New Member

    Joined:
    Apr 28, 2011
    Messages:
    53
    Likes Received:
    8
    Location:
    SoCal
    Your Vehicle Year:
    2005 Prius
    Model:
    N/A
    I didnt unplug it. I had no issues at all.
  6. trigga

    trigga New Member

    Joined:
    Jan 15, 2011
    Messages:
    17
    Likes Received:
    0
    Location:
    SC
    Your Vehicle Year:
    2005 Prius
    Model:
    N/A
    Ok, thanks. Ill be finishing up with my install tomorrow. I hope it goes as planned.
  7. trigga

    trigga New Member

    Joined:
    Jan 15, 2011
    Messages:
    17
    Likes Received:
    0
    Location:
    SC
    Your Vehicle Year:
    2005 Prius
    Model:
    N/A
    I got it put in and its working great!
  8. Corwyn

    Corwyn Energy Curmudgeon

    Joined:
    Mar 6, 2011
    Messages:
    2,105
    Likes Received:
    614
    Location:
    Maine
    Your Vehicle Year:
    2007 Prius
    Model:
    II


    Better change your .sig then. :):):)
  9. trigga

    trigga New Member

    Joined:
    Jan 15, 2011
    Messages:
    17
    Likes Received:
    0
    Location:
    SC
    Your Vehicle Year:
    2005 Prius
    Model:
    N/A


    Thats better. Now I just need better tint.
Similar Threads: Indicator
Forum Title Date
Toyota Prius Plug-in Mobile Charge Level indicator Yesterday at 1:18 PM
Prius c Care, Maintenance and Troubleshooting My Slip Indicator Light turned on today Monday at 2:07 PM
Toyota Prius Plug-in Hybrid indicator light is red and the power is red also Jul 22, 2014
Gen II Prius Care, Maintenance and Troubleshooting VSC Indicator light Jun 21, 2014
Prius c Care, Maintenance and Troubleshooting ABS, Brake System & Slip Indicator is on the Dash! Any Ideas what is wrong??? Jun 10, 2014