No EV Indicator

Discussion in 'Gen 2 Prius Accessories & Modifications' started by blown240, May 20, 2011.

  1. blown240

    blown240 Junior Member

    Joined:
    Apr 28, 2011
    53
    8
    0
    SoCal
    Vehicle:
    2005 Prius
    Model:
    N/A
    I just installed a DIY EV switch from misc stuff I had laying around the garage. Basically just a wire from the ECU to a momentary switch then to ground. It works great and acts just like it should, but I get no EV indicator on the dash. Could it be that mine is burnt out, or maybe it was never there? Its an 05 Pkg 3.

    THANKS!
     
  2. brick

    brick Active Member

    Joined:
    Dec 10, 2006
    1,087
    72
    0
    Upstate NY
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    We didn't get the indicator in North America. I know I harp on the ScanGauge a lot, but that's the only way I know of to get an indicator.
     
  3. blown240

    blown240 Junior Member

    Joined:
    Apr 28, 2011
    53
    8
    0
    SoCal
    Vehicle:
    2005 Prius
    Model:
    N/A
    Well I guess thats why it didnt turn on!

    Thanks!
     
  4. trigga

    trigga New Member

    Joined:
    Jan 15, 2011
    17
    0
    0
    SC
    Vehicle:
    2005 Prius
    Model:
    N/A
    Im doing the same thing right now, I was wondering that too. But I also had a question. Do I or should I disconnect the 12v battery before I unplug the H14 connector?
     
  5. blown240

    blown240 Junior Member

    Joined:
    Apr 28, 2011
    53
    8
    0
    SoCal
    Vehicle:
    2005 Prius
    Model:
    N/A
    I didnt unplug it. I had no issues at all.
     
  6. trigga

    trigga New Member

    Joined:
    Jan 15, 2011
    17
    0
    0
    SC
    Vehicle:
    2005 Prius
    Model:
    N/A
    Ok, thanks. Ill be finishing up with my install tomorrow. I hope it goes as planned.
     
  7. trigga

    trigga New Member

    Joined:
    Jan 15, 2011
    17
    0
    0
    SC
    Vehicle:
    2005 Prius
    Model:
    N/A
    I got it put in and its working great!
     
  8. Corwyn

    Corwyn Energy Curmudgeon

    Joined:
    Mar 6, 2011
    2,168
    648
    23
    Maine
    Vehicle:
    2007 Prius
    Model:
    II
    Better change your .sig then. :):):)
     
  9. trigga

    trigga New Member

    Joined:
    Jan 15, 2011
    17
    0
    0
    SC
    Vehicle:
    2005 Prius
    Model:
    N/A
    Thats better. Now I just need better tint.