Ottonavi HU: How to change your startup logo

Discussion in 'Gen III 2010+ Prius Audio and Electronics' started by Bulle, Jan 22, 2012.

  1. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    Here's how to change your startup logo on the Ottonavi.

    1) create a logo.bmp file in 800x480 in 24 bit format
    2) drop it in the root of your original sd card
    3) turn on the unit; the logo will get installed and removed from the sd card

    That's it! Enjoy!
    Note that the previous logo will be gone for good.
    There might be a way to recover it but I didn't know how and I didn't care.

    Here are a few logos I tried:

    gf.jpg
    A picture of one my girlfriends wearing one my T-shirts in front of one of my Prii...

    toyota.jpg
    A slick Toyota 3D logo to mystify your dealer when you go for service...

    bulle.jpg
    My own favorite right now...
     
    3 people like this.
  2. dehhh

    dehhh Junior Member

    Joined:
    Nov 21, 2011
    59
    10
    TC
    Vehicle:
    2011 Prius
    Model:
    Three
    I have been wondering how to do this.

    Thanks for finding this!
     
  3. teiresias

    teiresias Junior Member

    Joined:
    Oct 26, 2011
    60
    2
    Hampton, VA
    Vehicle:
    2011 Prius
    Model:
    Two
    Is this on the newest unit or on the unit before that?
     
  4. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    On the newest.
    But I'm pretty sure it will work on the previous one too.
     
  5. clayfree

    clayfree Junior Member

    Joined:
    May 12, 2008
    69
    14
    Frisco, Texas
    Vehicle:
    2011 Prius
    Model:
    Two
    Thanks Bulle! Worked like a charm. Here's a version I made if anyone wants it.

    [​IMG]
     
    montyzuma68, lasounds and Bulle like this.
  6. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    OMG!
    Very very nice!
    Love it.
    Thanks!
     
  7. ewagner0099

    ewagner0099 New Member

    Joined:
    Jun 1, 2012
    5
    0
    Birmingham, Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    ----USA ONLY----
    What is the root directory that you put the logo in?
     
  8. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    The lop level folder of the microSD card. Use a PC or something to copy the file over.
    And if you haven't done so yet, make a backup copy of the SD card too.
     
  9. EdyJun

    EdyJun Junior Member

    Joined:
    Oct 28, 2011
    60
    1
    Los Angeles
    Vehicle:
    2010 Prius
    Model:
    II
    Anyone know if this will work with the Rosen DS-TY1070-P11?
     
  10. JohnCleary

    JohnCleary Junior Member

    Joined:
    Feb 12, 2012
    15
    0
    SoCal
    Vehicle:
    2010 Prius
    Model:
    II
     
  11. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    If you have used the original file then something else is wrong.
    Try with a different logo file.
    Or may be you did not use the original SD card.
    If you use a different SD card make sure it's in the FAT format; not FAT32.
    Once the logo is installed, you can replace it with a FAT32 sd card.
    (this is because the firmware that loads the logo only reads FAT...)
     
  12. greenmymac

    greenmymac Junior Member

    Joined:
    Jul 25, 2010
    33
    2
    Tulsa
    Vehicle:
    2010 Prius
    Model:
    II
    Can this be done with the 2012 ?
     
  13. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    This is for the Ottonavi unit and may be some other Chinese HUs.
    I would be very surprised if this works on the stock factory units.
     
  14. JohnCleary

    JohnCleary Junior Member

    Joined:
    Feb 12, 2012
    15
    0
    SoCal
    Vehicle:
    2010 Prius
    Model:
    II
    I put the logo.bmp on the original 4GB card, which is Fat32, and it transferred ok.
    The card that did not work is 16GB Fat32.
     
  15. Vincent Leong

    Vincent Leong New Member

    Joined:
    Apr 7, 2013
    4
    0
    Melaka
    Vehicle:
    2012 Prius c
    Model:
    Plug-in Base
    Bulle, can an animated boot screen be installed in our HU?
     
  16. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    Not that I know.
    Too bad they did not implemented gif animated file or something else...
     
  17. Vincent Leong

    Vincent Leong New Member

    Joined:
    Apr 7, 2013
    4
    0
    Melaka
    Vehicle:
    2012 Prius c
    Model:
    Plug-in Base
  18. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    On the other hand, may be it's possible to run something BEFORE manager.exe so that it will look like an animated logo after the initial logo...
    For example, we can code our own manager.exe which would run an animated logo and then call the old manager.exe.
    That should work.
     
  19. Vincent Leong

    Vincent Leong New Member

    Joined:
    Apr 7, 2013
    4
    0
    Melaka
    Vehicle:
    2012 Prius c
    Model:
    Plug-in Base
    Have u try it? since u r more expert in this, y not u try 1st then u show us the step by step how to do.....

    (y)
     
  20. Bulle

    Bulle Member

    Joined:
    Nov 5, 2011
    319
    39
    Canada
    Vehicle:
    2011 Prius
    Model:
    N/A
    lol
    Did not try it out yet.
    Need time!
    But if I do, I will tell everyone on this forum.