'04 prius (212K miles) Red triangle, ABS, VSC & Check ENG lights on

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Juan Carlos Valle, Jul 10, 2019.

  1. Juan Carlos Valle

    Juan Carlos Valle New Member

    Joined:
    Jul 9, 2019
    12
    5
    0
    Location:
    Miami, Fl. USA
    Vehicle:
    2004 Prius
    Model:
    N/A
    Hi Guys,

    My 2004 Prius has 212K miles (second owner). I started my car 2 days ago, and I drove it for 5min without problem, I parked my car in front of my house (left car running) to get my dog, when I got back to the car, all lights were on: red triangle, check engine, ABS, VSC, (!) & stability control off. Then I drove my car to my parking spot, I knew something bad had happened to my car.

    Yesterday I spent all my day googling what the problem(s):

    Checked gas cap(totally fine)
    Checked engine oil fluid level (added half qt)
    Checked inverter cooling pump, I guess it's working, it makes waves inside tank
    Checked and cleaned hybrid fan, it wasn't that dusty. I can't confirm if fan works
    Checked 12V battery (running 14.2v, not running [vehicle signal check mode] 11.5) still not sure if the problem is the 12v battery.

    I disconnected the battery to clear all dashboard lights (it worked); and also, the car started with no problem; 3 minutes later, engine went off, all lights on and I couldn't put car in reverse nor drive. I'm trying to avoid taking my car to the dealer, it's a 2004 car with 212K miles on it, I feel like if I take it to those sharks, they are going to eat me alive, I'm just trying to check few things first.

    QUESTION - if 12v battery is 12.0v or less I must replace it right away or it means should replace it soon?

    After I cleaned hybrid fan, once again I disconnected the battery to clear all dashboard lights (it worked); and also, the car started with no problem; 3 minutes later, engine went off, all lights on and I couldn't put car in reverse nor drive, THIS TIME I SMELLED SOME GAS AND ENGINE MISFIRING AND I DO RECALL HAVING LACK OF ACCELARATION, so at this point I'm going to change all spark plugs


    ANOTHER QUESTION - if the problem I'm having is really a bad spark plug, you guys think I'll have all these problems starting the car and all warning lights on?



    Thank you all. I think I read all forums in here.



    ANY IDEAS?

    IMG_2465.jpg IMG_2464.jpg
     
  2. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    2,563
    879
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    Those dash lights mean error code is stored in memory.... Once you know the error codes, you'll know where to look for the problem... You can read those error by going to an auto parts store and they'll do it for free... You can also use a phone app like Dr. Prius via a bluetooth OBD2 code reader, (see What OBD2 to buy? at Hybrid battery diagnostic and repair tool for Toyota and Lexus ) which will read battery subcodes that most auto parts stores can't read. Or... you can go full on professional and buy a mini-VCI cable and use Toyota Techstream software...
     
    Juan Carlos Valle likes this.
  3. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    80,830
    34,796
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    welcome!

    if the 12v is 12 or less at the jump point or battery after it has been off for 4 hours, you should replace it. if the car is starting, you have time to look around for the best deal.

    but reading your situation, if you are planning to repair the car and keep it, i would replace the battery now, wait for the lights to come back and read the codes. and they will be the right codes
     
    Juan Carlos Valle likes this.
  4. Juan Carlos Valle

    Juan Carlos Valle New Member

    Joined:
    Jul 9, 2019
    12
    5
    0
    Location:
    Miami, Fl. USA
    Vehicle:
    2004 Prius
    Model:
    N/A
    Hi Bisco,

    thank you for your help!

    Yes, I'm planning to keep the car, my car is in mint condition, I took it to the dealer for a regular oil change and tires' rotation on last May and everything was OK (see attach). I'm going to try to start it and take it to my nearest auto part, so they can read the codes, and hopefully it's just a new 12v battery.

    When I press brake pedal to start it, volts drop from 11.8 to 11.3v 11.1v. FORGOT TO MENTION, all this happened after my car was sitting for 8 days since I was out of town.

    Once again THANK YOU!!
     

    Attached Files:

    bisco likes this.
  5. Juan Carlos Valle

    Juan Carlos Valle New Member

    Joined:
    Jul 9, 2019
    12
    5
    0
    Location:
    Miami, Fl. USA
    Vehicle:
    2004 Prius
    Model:
    N/A
    Hi!

    I going to try to take my car to my nearest auto part, I don't know if I can drive it with all those warning lights on, if not I going to buy one of the code reader Dr. Prius recommends (Carista). I don't need my car this week, so I have time to do one step at a time, as I mentioned I'm trying to avoid going to the dealer this time.

    Thank you!!!
     
    PriusCamper likes this.
Loading...