2007 brief MFD failure (no DICE)

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by MegansPrius, Dec 24, 2006.

  1. MegansPrius

    MegansPrius GoogleMeister, AKA bongokitty

    Joined:
    Nov 19, 2006
    2,437
    26
    0
    Location:
    Chicago, IL
    Vehicle:
    2007 Prius
    Model:
    II
    We were driving from Chicago to Kansas yesterday and had just plugged an ipod mini into the aux jack when the MFD began displaying strangely:
    1. The audio went away and the audio screen displayed "Audio off"
    2. The climate screen displayed "Check connection to air conditioner"
    3. The energy screen displayed no arrows moving in any direction at all
    4. The consumption screen showed our milage jumping from ~40 mpg to 90 mpg.
    We were on the highway, traveling at about 70mph in 32 degree weather. We kept on driving, flicking between the screens, trying to figure out what was going on. The consumption screen did keep updating, and we logged about 15 minutes at 90 mpg.

    We then pulled off. Turned the car on and off, and the screens came back ok. Everything was working fine. And we drove the remaining 11 hours of our trip without incident and at an expected mileage of 42 mpg.

    But has anybody else had this happen? Or does anyone have any idea why this happened? Should we be at all concerned?

    2007 Prius, package 3, no mods of any kind.
     
  2. MegansPrius

    MegansPrius GoogleMeister, AKA bongokitty

    Joined:
    Nov 19, 2006
    2,437
    26
    0
    Location:
    Chicago, IL
    Vehicle:
    2007 Prius
    Model:
    II
    After getting a half hour on a computer and reading the boards we seem to have experienced a classic MFD failure. Should I be contacting Toyato to get the MFD unit replaced before it fails completely? And is this the first MFD failure in a 2007?

    Again: 2007, pkg 3, no mods, 3000 miles
     
  3. galaxee

    galaxee mostly benevolent

    Joined:
    Mar 14, 2005
    9,810
    437
    0
    Location:
    MD
    Vehicle:
    2005 Prius
    it's not the "dreaded mfd failure" unless it stays in that suspended animation mode. play with it some, see if the ipod connection is indeed the cause. if it does seem to be connected to the ipod being connected, try someone else's ipod, a different kind of ipod, something like that.
     
  4. DanMan32

    DanMan32 Senior Member

    Joined:
    Aug 27, 2004
    3,799
    25
    0
    Location:
    Tampa Bay, FL
    If you had an IPOD adapter that let you control the IPOD from the MFD/steering wheel, then that could be improperly connected, causing the problem. If you are using the aux jack in the center console, I doubt that would be the problem, since that is an audio only connection, no control signals.

    Sounds like a loose AVC network connection somewhere. Unless Toyota is coming up with another bad batch of MFDs again. The original MFD issue was limited to early 2004 MY. If one has a 2004 and can toggle between energy/consumption screen using the INFO button on the steering wheel (as I do), then you have the fixed version.
     
  5. MegansPrius

    MegansPrius GoogleMeister, AKA bongokitty

    Joined:
    Nov 19, 2006
    2,437
    26
    0
    Location:
    Chicago, IL
    Vehicle:
    2007 Prius
    Model:
    II
    <div class='quotetop'>QUOTE(DanMan32 @ Dec 29 2006, 12:25 AM) [snapback]367950[/snapback]</div>
    Thanks galaxee and DanMan32 for your responses. We made it back from Kansas to Chicago with no more occurances. The ipod is connected with a standard aux cable in the center console and has been used regularly since we got the car in mid-November. Both a 60gb ipod and an ipod nano have been plugged and unplugged numerous times. The Prius is a 2007 and the info button on the steering wheel toggles energy/consumption.

    The one time the error occurred, it lasted about 15 minutes (until we pulled off and turned the car on and off). For the moment and since we have most of our 36000 mile warrenty remaining, I guess the best thing to do is wait and see if it happens again.
     
  6. galaxee

    galaxee mostly benevolent

    Joined:
    Mar 14, 2005
    9,810
    437
    0
    Location:
    MD
    Vehicle:
    2005 Prius
    well, what it comes down to is that if you take it to the dealership and they don't see the problem, they're gonna shrug their shoulders and tell you to bring it back if/when it happens again.

    the hard thing for techs about intermittent problems is actually seeing the problem happen.
     
Loading...