2008 Prius - sks unlock and horn going off

Discussion in 'Gen 2 Prius Main Forum' started by Vct, Nov 27, 2012.

  1. Vct

    Vct New Member

    Joined:
    Oct 19, 2011
    9
    1
    0
    Location:
    Dallas
    Vehicle:
    2008 Prius
    Model:
    Four
    I have a 2008 prius. Only the stock factory alarm is there. Additional Dealer installed alarm is NOT installed I repeat NOT installed. Only have the Smart key system (SKS) that locks and unlocks the car. Lately every time I am within range of the car the horn goes off (usually within 4 or 5 feet). As soon as I unlock the car everything is fine.

    If I lock and unlock the car instantly everything is fine. Only after the alarm is armed ( takes about a minute or so) and I try to unlock the car, the horn goes off.

    Any suggestions greatly appreciated. Have a three month old and he wakes up every time the horn sounds off. Getting annoying lately.

    Steps taken so far:

    1) Since the car is five years old, I decided the change the 12v battery even though everything was fine. So battery is not an issue.

    2) Changed batteries on both SKS Fobs. Problem still not solved.

    3) Checked "stuck" panic button on both fobs. Problem still not solved.
     
  2. cwerdna

    cwerdna Senior Member

    Joined:
    Sep 4, 2005
    12,539
    2,104
    1
    Location:
    SF Bay Area, CA
    Vehicle:
    2006 Prius
    Beats me, but please run the test at Weird stuff happening? MPGs dropping? Test The Battery | PriusChat after the car has sat MANY hours or overnight. Please tell us the 3 values (not just 1). Don't go changing the battery first until you tell us the values...

    If you have HIDs, you can avoid unnecessary cycles on the lights by toggling between off and parking light positions.

    Weird stuff can start happening w/a low or bad 12 volt. Don't waste $ on having a dealer "test" the 12 volt (07 Prius Dead - Any Guesses? | PriusChat). If you're on you're original 12 volt, it's likely near or at end of life now.

    Another possibility is a stuck panic button on the key fob.
     
  3. PriusGuy32

    PriusGuy32 Prius Driver Extraordinaire

    Joined:
    Sep 10, 2012
    1,329
    438
    0
    Location:
    Harrison Township, Michigan
    Vehicle:
    2015 Prius
    Model:
    Four
    It almost sounds like your panic button on your key FOB is sticking.

    Whens the last time you replaced the battery in the FOB?
     
  4. Vct

    Vct New Member

    Joined:
    Oct 19, 2011
    9
    1
    0
    Location:
    Dallas
    Vehicle:
    2008 Prius
    Model:
    Four
    FOB is fine and I changed the FOB battery six months ago. Panic button is not sticking either.
     
  5. PriusGuy32

    PriusGuy32 Prius Driver Extraordinaire

    Joined:
    Sep 10, 2012
    1,329
    438
    0
    Location:
    Harrison Township, Michigan
    Vehicle:
    2015 Prius
    Model:
    Four
    Then definitely heed cwerds advice.
     
  6. Vct

    Vct New Member

    Joined:
    Oct 19, 2011
    9
    1
    0
    Location:
    Dallas
    Vehicle:
    2008 Prius
    Model:
    Four

    Took it to the dealer. Since the car is five years old, I decided to change the battery anyways. Was hoping that would solve the problem. Did not. $stealer did a diagnostics and has quoted $1400 to replace the entire electrical unit. Cordially refused the repair and walked away.
     
  7. prj

    prj Member

    Joined:
    Nov 4, 2011
    41
    30
    0
    Location:
    OH
    Vehicle:
    2011 Prius
    Model:
    II
    Do you have two fobs? Try using the other one and see if that fixes it.
     
    PriusGuy32 likes this.
  8. Vct

    Vct New Member

    Joined:
    Oct 19, 2011
    9
    1
    0
    Location:
    Dallas
    Vehicle:
    2008 Prius
    Model:
    Four
    Nope. That did not do it.
     
  9. nh7o

    nh7o Off grid since 1980

    Joined:
    Dec 10, 2011
    1,686
    326
    0
    Location:
    Hawaii
    Vehicle:
    2009 Prius
    Model:
    II
    When you say "goes off" do you mean that it is continuous, or that it beep beep beeps? And which horn is it, the low and high pitched horns at the front of the car which also beep from the steering wheel, or the security horn that is in the back of the engine compartment? Do the headlights and taillights also flash at the same time? Does the light inside the car turn on?

    Here are some words from the manual:
    Far fetched, but if the 12V connection is intermittent, it could cause something like what you describe. Check that everything is tight back there, ground connection and all. Also, I wonder if all of your door locks are OK. Lock the car with the fob, then take the fob far away and come back and make sure that all the doors really do lock.
     
  10. Vct

    Vct New Member

    Joined:
    Oct 19, 2011
    9
    1
    0
    Location:
    Dallas
    Vehicle:
    2008 Prius
    Model:
    Four
    When I say the horn "goes off" - I mean exactly that .. Loud as hell and not beeps/chirps. also the headlights and taillights flash continuously. I am going to check the connections of the battery + all door locks and get back to you.
     
  11. Vct

    Vct New Member

    Joined:
    Oct 19, 2011
    9
    1
    0
    Location:
    Dallas
    Vehicle:
    2008 Prius
    Model:
    Four
     
  12. nh7o

    nh7o Off grid since 1980

    Joined:
    Dec 10, 2011
    1,686
    326
    0
    Location:
    Hawaii
    Vehicle:
    2009 Prius
    Model:
    II
    OK. So the car is going into full "Alarm Sounding State" for some reason. Manual:
    So either one of those above is a source of a signal that is not correct, or the frightful byzantine Main Body ECU is at fault, as your dealer suggests. The only way to proceed is to poke around with the schematic and a DVM. As a workaround, it might be possible to find the "HORN" signal output wire from the Body ECU, which goes to the horns, and cut it. There is another wire direct from the steering wheel that also does the horn, so only the alarm function would be lost. Here is the Body ECU in all its glory:
    http://techno-fandom.org/~hobbit/cars/bodyecu/
     
  13. bluebossa4

    bluebossa4 Junior Member

    Joined:
    Aug 26, 2016
    6
    1
    0
    Location:
    Austin, TX
    Vehicle:
    2006 Prius
    Model:
    N/A
    The OP has pretty much described my currently problem perfectly.

    Anyone having a similar issue? Any updates, results , or advice?
     
  14. ctr

    ctr New Member

    Joined:
    May 22, 2020
    1
    0
    0
    Location:
    Houston
    Vehicle:
    2006 Prius
    Model:
    N/A
    Having the same issue as well. Any updates, results, or advice?
     
  15. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    87,555
    38,973
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
  16. richard203

    richard203 Junior Member

    Joined:
    Jan 23, 2019
    99
    21
    0
    Location:
    SF
    Vehicle:
    2008 Prius
    Model:
    ----USA----
    so my problem i got is when i touch the door to unlock sks, the alarm goes off later i realize it hooked up to an aftermarket alarm i unplug it and everything ok.
     
Loading...