2010 Prius: Engine/Battery Rattling, Pulsing at Cold Start/Low Speeds

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by colin.m.davison, Jun 6, 2018.

  1. colin.m.davison

    colin.m.davison New Member

    Joined:
    Jun 6, 2018
    1
    0
    0
    Location:
    Chicago, IL
    Vehicle:
    2010 Prius
    Model:
    II
    Another symptom was smelling sulfur in the cabin. The issue happened on/off for several months before we took it to Toyota. The issue turned out to be an EGR valve. This is covered as part of a recall by Toyota, so take it to your local Toyota dealer and they should fix the issue for free!

     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    85,493
    37,686
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    welcome!

    cool, did they clean or replace it?
     
    m.wynn likes this.
  3. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    9,598
    12,996
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    Welcome to Prius Chat (y).

    Since you are recommending something, can you provide some background:

    • Miles on your Prius?
    • When did you notice the issue?
    • Did it display a dash light ?
    • Did you have to pay a diagnostic fee?
    • Is the only thing they did was to replace the egr valve?
    • Did they replace the egr cooler?
    • If not, have you considered cleaning that?
    • Does your Prius consume any oil?
    Those are just some questions ;).

    Look forward to additional details from your experience (y).
     
    m.wynn likes this.
Loading...