Accelerator (throttle?) issues, 150k miles

Discussion in 'Prius v Care, Maintenance and Troubleshooting' started by Rick F, Jun 28, 2022.

  1. Rick F

    Rick F New Member

    Joined:
    Jun 28, 2022
    9
    1
    0
    Location:
    91784
    Vehicle:
    2012 Prius v wagon
    Model:
    V
    In park while flooring the accelerator pedal the engine revs to a mid rpm then decelerates while accelerator is floored. Little to no power while driving. 150k miles, past few months noticed engine would stick at an rpm after my foot would lift off of the accelerator. Recently used fuel additive to clear carbon from engine. Could I have damaged the injectors. This rev issue happened coincidentally after an oil change. This is my wifes car so I dont drive it as much as she does and didnt catch this until today. MPG is at 26 average since oil change. No engine idiot lights are on.
     
    #1 Rick F, Jun 28, 2022
    Last edited: Jun 28, 2022
  2. CR94

    CR94 Senior Member

    Joined:
    Dec 2, 2014
    1,929
    777
    0
    Location:
    Northwestern S.C.
    Vehicle:
    2011 Prius
    Model:
    Two
    That's normal.
     
    Rick F likes this.
  3. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    17,299
    11,758
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    I agree with CR94, that part is nothing out of the ordinary. The car is totally throttle-by-wire anyway; the go pedal only tells the power management control ECU how much go you want, the ECU decides how much to give you electrically and how much from the engine, and passes the latter number to the ECM, which decides what to do with the throttle.

    The simplest way for it to behave while flooring the pedal in park would be to do nothing at all. But the engineers figured people would want it to do something, so they programmed the ECU to say "oh, driver's flooring the pedal in park, run up the rpms a little".
     
    Rick F and CR94 like this.
  4. Rick F

    Rick F New Member

    Joined:
    Jun 28, 2022
    9
    1
    0
    Location:
    91784
    Vehicle:
    2012 Prius v wagon
    Model:
    V
    Yeah I realized that later about being in park. Brought the car to our mechanic and he cant find anything wrong no codes. Suggesting we bring it to Toyota for trouble shooting. So car seems to have power but we are getting 26 mpg for some reason now. Wife says the "shifting" high revs longer than normal, acts weird when the car is hot.
     
Loading...