Airbag light

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by disc, Apr 3, 2015.

  1. disc

    disc New Member

    Joined:
    Apr 3, 2015
    17
    1
    0
    Location:
    UK
    Vehicle:
    2011 Prius
    Model:
    N/A
    new to priuschat, need some help please, airbag light has come on my dash, i have a creader code reader and cleared the faults, but airbag light still remains on, recheck error code and none, all cleared, not sure why the light is not resetting, any help will do, thanks
     
  2. Easy Rider 2

    Easy Rider 2 Senior Member

    Joined:
    Aug 5, 2014
    1,584
    257
    0
    Location:
    Ocala, FL
    Vehicle:
    2013 Prius c
    Model:
    Three
    Does it say "passenger air bag OFF".
    If so, that's normal when nobody is sitting on the passengers seat.
    The airbag lights in these models lately are different and bugs the crap out of some owners.
     
  3. disc

    disc New Member

    Joined:
    Apr 3, 2015
    17
    1
    0
    Location:
    UK
    Vehicle:
    2011 Prius
    Model:
    N/A
    airbag light in the speedo, reset codes but still airbag light remains, UK car if it makes a difference
     
  4. Easy Rider 2

    Easy Rider 2 Senior Member

    Joined:
    Aug 5, 2014
    1,584
    257
    0
    Location:
    Ocala, FL
    Vehicle:
    2013 Prius c
    Model:
    Three
    Does an airbag CODE also come back ?
    I think you need dealer service either way.........unless maybe that is an "airbag off" light.
    I don't have your model.
    Other answers should be forthcoming.
     
  5. disc

    disc New Member

    Joined:
    Apr 3, 2015
    17
    1
    0
    Location:
    UK
    Vehicle:
    2011 Prius
    Model:
    N/A
    codes are cleared by creader, it is the airbag light next to car speed, i have 10th anniversary prius, 2011
     
  6. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    19,400
    12,952
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Getting a warning light and using some device to clear the codes without reading them is like getting a telegram that tells you exactly what's wrong, and throwing it away without reading it.

    If the light comes back, other PriusChatters are better able to help if you read the associated code(s), and post them here, before throwing that information away.

    -Chap
     
  7. disc

    disc New Member

    Joined:
    Apr 3, 2015
    17
    1
    0
    Location:
    UK
    Vehicle:
    2011 Prius
    Model:
    N/A
    Passenger side airbag connector was loose, reconnected and code cleared, airbag light still on
     
  8. mmmodem

    mmmodem Senior Taste Tester

    Joined:
    Nov 17, 2011
    2,732
    1,701
    0
    Location:
    Bay Area, CA
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    What is the code?
     
  9. disc

    disc New Member

    Joined:
    Apr 3, 2015
    17
    1
    0
    Location:
    UK
    Vehicle:
    2011 Prius
    Model:
    N/A
    code - B1906 - Open in p/t squib ( p seat side ), circuit/open in p/t squib ( lh ) circuit, fault is cleared buy airbag lights remains on
     
  10. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    19,400
    12,952
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Did the A/B light ever go out, even for a moment, when you cleared the code?

    If not, perhaps your creader's code clear feature isn't quite right for the A/B ECU. You might glance in the service manual on techinfo.toyota.com for a clearing sequence specific to that ECU that might not require a reader device. (In my car, airbag codes can be cleared with a special sequence of jumper pulses on the TS and AB pins of the DLC3 connector, but your generation is probably different.)

    If it really did go out and then came back, it's possible there was more to the squib circuit problem than what you have so far fixed....

    -Chap
     
  11. disc

    disc New Member

    Joined:
    Apr 3, 2015
    17
    1
    0
    Location:
    UK
    Vehicle:
    2011 Prius
    Model:
    N/A
    thanks guys, light never went off, on all the time when clearing faults, i cannot understand it, faults have cleared but light still on, can it be the speedo itself being faulty
     
    #11 disc, Apr 3, 2015
    Last edited: Apr 4, 2015
  12. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    19,400
    12,952
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV


    As I mentioned one post ago, there are several computers cooperating to run your car; the airbag computer is separate from the others. I have a Gen 1 so details are likely to vary, but for my airbag computer there is a special sequence to clear its codes, not the same as the generic command that your creader may be sending to clear codes in other computers. Since your airbag light does not go dark even for a moment, this seems a possible explanation.



    For my Gen 1, airbag codes can be cleared with a Prius-specific scan tool, or without any scan tool by using a couple jumper wires at the diagnostic connector and grounding them a certain number of times. I'm skipping the details because they are probably different for your generation, but you will certainly find them in the service manual at techinfo.toyota.com.

    -Chap
     
    #12 ChapmanF, Apr 3, 2015
    Last edited: Apr 3, 2015
  13. disc

    disc New Member

    Joined:
    Apr 3, 2015
    17
    1
    0
    Location:
    UK
    Vehicle:
    2011 Prius
    Model:
    N/A
    thanks for the info, will look at service manual, any other help will do
     
  14. disc

    disc New Member

    Joined:
    Apr 3, 2015
    17
    1
    0
    Location:
    UK
    Vehicle:
    2011 Prius
    Model:
    N/A
    unable to find any docs regrading reset, any help will do, links
     
  15. Planet Awesum

    Planet Awesum Junior Member

    Joined:
    Jul 23, 2015
    24
    32
    0
    Location:
    Portland, Oregon
    Vehicle:
    2014 Prius
    Model:
    Two
    My airbag light went off when I reattached plug above steering column underneath the panel. There are two large one/ one small. One of them wasn't fully engaged after combination meter repair. Maybe this will help you.
     
    Tom Markham likes this.
Loading...