Alarm with Brake Light, ABS, VSC and amber warning lights

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by NorthStar, Jul 26, 2005.

  1. NorthStar

    NorthStar Junior Member

    Joined:
    Jan 6, 2004
    56
    2
    0
    Location:
    Minnetonka, MN
    During heavy rainfall I drove through a large puddle on the street - quite a bit of water. Later that same day - I started getting an alarm - as soon as the driver's door is opened - a long continuous beep. The alarm continues when starting the car - and even when simply touching the brake pedal. I am getting the red BRAKE LIGHT, the amber waming symbol, ABS, and VSC lights. The owner's manual says not to drive it and call the dealer. I'm thinking something just got wet when driving in all that water.

    I still have regenerative brakes but at slow speed the car braked in a very jerky manner.

    I'll call the dealer, but any ideas, thoughts, solutions, anyone?
     
  2. DanMan32

    DanMan32 Senior Member

    Joined:
    Aug 27, 2004
    3,799
    23
    0
    Location:
    Tampa Bay, FL
    The wheel speed sensors are inductive, and it could be that their getting wet is causing them to not work properly.
    Or, their wiring got wet, which the dealer should dry out to prevent corroding, not to mention that where the water may have seeped may take a very long time to dry.
     
  3. korikelly

    korikelly Junior Member

    Joined:
    Jun 12, 2008
    3
    0
    0
    Location:
    Medford, OR
    Vehicle:
    2008 Prius
    the very same thing happened to me just now. Ran through a large puddle last night (it was dark, couldn't avoid), and now the same symptoms as above. Nearest dealer is 45 minutes away. Can anyone tell me what ended up being the problem here?
     
  4. greengecko

    greengecko Junior Member

    Joined:
    Sep 5, 2004
    25
    1
    0
    Location:
    Syracuse, NY
    Vehicle:
    2004 Prius
    Model:
    N/A
Loading...