Anyone install aftermarket HID's on their 2010 prius?

Discussion in 'Gen 3 Prius Accessories and Modifications' started by Rez90, Dec 20, 2010.

  1. Rez90

    Rez90 New Member

    Joined:
    Dec 20, 2010
    2
    0
    0
    Location:
    Jersey
    Vehicle:
    2010 Prius
    Model:
    III
    My mom purchased a 2010 prius III in sept. One thing she didn't get that she really wanted was HID's in the car.

    I purchased a set of aftermarket HID's and attempted to install them tonight. I have installed many of these kits but the one obvious hump was the fact that the prius doesn't have a conventional battery to hook up the positive wire and relay.

    I spoke to the vendor before ordering these and asked if i needed the relay. he said i didn't.

    welllllllll.............after installation no dice. no worky. I bypassed the relay......installed with the relay (not connected of course) but regardless....the HID kit would not work.

    Has anyone installed aftermarket HID's? is there something i need to know that i'm missing? Is there a spot i can hook a positive wire up under the hood?

    Any info/advice is greatly appreciated. Thanks:D
     
  2. Paradox

    Paradox Prius Enthusiast / Moderator
    Staff Member

    Joined:
    Sep 22, 2005
    29,111
    8,582
    201
    Location:
    USA
    Vehicle:
    2014 Prius v wagon
    Model:
    Five
  3. JimboPalmer

    JimboPalmer Tsar of all the Rushers

    Joined:
    Apr 14, 2009
    12,124
    6,464
    2
    Location:
    Greenwood MS USA
    Vehicle:
    2012 Prius v wagon
    Model:
    Three
    It is worth noting that no aftermarket HID lights are legal on public roads in the USA.
     
  4. andino

    andino Senior Member

    Joined:
    Jul 15, 2009
    746
    546
    0
    Location:
    San Jose, CA
    Vehicle:
    2010 Prius
    Model:
    III
    You have to connect the relay to the terminal in the fuse box. There's a 12V connection that runs to the battery in the rear of the car so you can you jump start if necessary.
     
  5. Turnin' Heads

    Turnin' Heads New Member

    Joined:
    Dec 19, 2010
    4
    0
    0
    Location:
    Scott AFB, IL
    Vehicle:
    2010 Prius
    Model:
    IV
    I installed 8000K in my '10. Mine had the digital "plug and play" ballast. I had no problems and it works great! Not sure of the relay you're talking about.
     
  6. wick1ert

    wick1ert Senior Member

    Joined:
    Dec 3, 2009
    1,311
    183
    2
    Location:
    Delawhere
    Vehicle:
    2010 Prius
    Model:
    III
    Did the 2 wires that connect into the plug for the light come with a plug end, or just two wires sticking out? If it's just wires sticking out, did you try to swap them and see if that worked? I had that problem in an older car of mine at one time.

    One thing to do next time, is test it out before you assemble everything in the car. In other words, just dis-connect the plug and try to get it to work first. Makes it easier if you can't get it to work or need to troubleshoot.
     
  7. Saphteemon

    Saphteemon Junior Member

    Joined:
    Nov 20, 2010
    36
    2
    0
    Location:
    Orange County
    Vehicle:
    2010 Prius
    Model:
    III
    i just installed the ddm plug and play kit.....H11, 6K, 35watt slim ballast.........
    i picked it up at their huntington beach store.....35 bucks plus tax.....
    works great.....:D:D:D
     
  8. Saphteemon

    Saphteemon Junior Member

    Joined:
    Nov 20, 2010
    36
    2
    0
    Location:
    Orange County
    Vehicle:
    2010 Prius
    Model:
    III
    just installed my second set of hid in the pc foglights.....

    i also change my parking lights to led.....so now this is what she looks like......

    [​IMG][​IMG]
    [​IMG]
    [​IMG]
     
  9. LulzChicken

    LulzChicken Prius Enthusiast

    Joined:
    Jul 19, 2009
    791
    134
    0
    Location:
    Alabama
    Vehicle:
    2010 Prius
    Model:
    II
    Looks sick!!! I went with 5000K- those pics make me want 6000K. Oh well.
     
    1 person likes this.
  10. seal2cc

    seal2cc New Member

    Joined:
    Dec 1, 2010
    52
    2
    0
    Location:
    Virginia
    Vehicle:
    2010 Prius
    Model:
    IV
    I have 6k in mind...from HIDExtra and I ordered 5k, the 6k was not as bright as I want. Haven't installed yet, we'll see.

    BTW bif sale at HIDExtra.com 'til 1/2 I think.

    Merry Christmas! (Prius-tmas?)
     
  11. lupicia01

    lupicia01 New Member

    Joined:
    Dec 25, 2010
    6
    0
    0
    Location:
    San Jose
    Vehicle:
    2010 Prius
    Model:
    II
    I just bought ddm 55watt 6000k hid kit! Hope they're goood!
     
  12. andino

    andino Senior Member

    Joined:
    Jul 15, 2009
    746
    546
    0
    Location:
    San Jose, CA
    Vehicle:
    2010 Prius
    Model:
    III
    ^^ I"m running their 55w 5000k kit in my car. Having some issues with it playing nice with my relay and the bulb colors matching. Hope you don't have the same issue. I'm going to down to their shop tomorrow hopefully and swap the kit for a different one. I think its a igniter issue which is causing everything else to go out of wack.
     
  13. CivicSky

    CivicSky Member

    Joined:
    Jun 4, 2010
    138
    61
    0
    Location:
    San Deigo
    Vehicle:
    2010 Prius
    Model:
    II
    I also got a set of DDM 35W 5K HID lights with relay harness connected to the (+) inside the fuse box. They have been working great to me, plus those are lifetime warranty!
     
  14. blur510

    blur510 New Member

    Joined:
    May 22, 2010
    14
    0
    0
    Location:
    San Diego
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    I'm in SD too any chance I can see how the 5k kit looks? Can I see your install? thanks
     
  15. bagwell

    bagwell Active Member

    Joined:
    Sep 14, 2005
    580
    43
    0
    Location:
    the woodlands, tx
    Vehicle:
    2010 Prius
    Model:
    II
  16. isteve74

    isteve74 New Member

    Joined:
    Jan 8, 2011
    13
    2
    0
    Location:
    Fullerton, ca
    Vehicle:
    2010 Prius
    Model:
    II
    I have 55w 5000k. Plug in Play and NO problem .. You will love them.
     
  17. FlossAngeles

    FlossAngeles New Member

    Joined:
    Jan 8, 2011
    25
    0
    0
    Location:
    City of Angels
    Vehicle:
    2010 Prius
    Model:
    IV
    Is this true? If so, I may refrain from putting some HIDs on mine. :(
     
  18. JimboPalmer

    JimboPalmer Tsar of all the Rushers

    Joined:
    Apr 14, 2009
    12,124
    6,464
    2
    Location:
    Greenwood MS USA
    Vehicle:
    2012 Prius v wagon
    Model:
    Three
  19. almypal26

    almypal26 Member

    Joined:
    Jun 29, 2010
    101
    1
    0
    Location:
    So Cal
    Vehicle:
    2010 Prius
    Model:
    III
    Does the 6k have a bluish hue to it? or is it pure white (5K)? Where did you purchase the HIDs? Thanks:confused:


     
  20. jdimetal

    jdimetal New Member

    Joined:
    Jan 15, 2011
    52
    7
    0
    Location:
    Fredericksburg, VA
    Vehicle:
    2010 Prius
    Model:
    II
    Looking for some instructions or a good write up with pics on installing one of these plug and play kits.
     
Loading...