Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doesn't

Discussion in 'Gen 2 Prius Audio and Electronics' started by ace, May 5, 2008.

  1. ace

    ace A mini-tank with snow tires

    Joined:
    May 4, 2008
    34
    1
    0
    Location:
    Ames, Iowa 50010
    Vehicle:
    2008 Prius
    Model:
    N/A
    Hello,

    2008 Prius forgets the bluetooth settings to connect to the bluetooth phone that I already have registered. It remembers for 1 minute after I shut off the car, then I must reconnect or re register manually every time I turn the car on. :confused: (I am getting good at that though :) Interesting note: I do not have to enter the bluetooth passkey again, so it hasn't totally forgotten.

    I have tried this with both a Samsung A900 Sprint (RAZR look-a-like) cellphone and a Motorola Q Verizon smartphone. Anyone else been successfull with the A900 or the Motorola Q and any year Prius? It should connect automatically when I get near the Prius. Are either of those phones on a list of phones that work or do not work?

    I can't think of anything else to try? Anyone have any suggestions? Is there a way to update bluetooth firmware on the Prius?

    Here is what I have checked and double-checked:
    1. When I touch the screen to Select a Phone the phone is listed after I connect, but if I recycle the car power there are no phones listed under the "Select a Phone" menu on the Prius touch screen.
    2. Both the A900 and Q remember the Prius which is named Hands Free
    3. On the Prius, I have Auto-Connect selected.
    4. Both the Q and A900 are set with Bluetooth on all the time. They both autoconnect to my other BT headsets.
    5. I updated the A900 to the latest firmware with no luck.
    6. Once I connect the A900 or the Q to the Prius (Register) they both work great, but it is not convenient to reconnect every time I power off the Prius.
    Interesting bug: I changed the default name of the Prius from Hands Free to Eds Prius and the passcode from 1111 to 0000 and the Prius does not remember those changes. Has anyone else been able to change the name of the Bluetooth on the Prius?

    I have read other posts and others have used the A900 with older model Prius and they seem to work fine.

    Any similar problems with any other cell phones and how they resolved it?


    Thanks,

    Ed.
     
  2. CTScallopR

    CTScallopR New Member

    Joined:
    Feb 18, 2008
    4
    0
    0
    Location:
    Connecticut
    Vehicle:
    2008 Prius
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    I had a similar problem with my 08 Prius. My bluetooth worked for the first month I had the car, then it started not auto-connecting. I went through the same process of re-connecting manually. Then it stopped working all together. My phone was old, so I ordered a new phone thinking that was the problem. Then the real headache has began, my phone icon on the info screen has vanished, that's right, gone. The guys at my dealership say they have never seen this before, and it looks like they are going to replace my entire center module.

    Looks like there may be some serious glitches in some of the new modules.
     
  3. ace

    ace A mini-tank with snow tires

    Joined:
    May 4, 2008
    34
    1
    0
    Location:
    Ames, Iowa 50010
    Vehicle:
    2008 Prius
    Model:
    N/A
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    I wonder if this is only happening on the 2008 models?

    Thanks for the reply. I called the dealer today, they said bring it in. I can't think of anything else to try, so I guess I will bring it in. They will give me a loaner car for the day, but I'm sure it will get lousy mpg.

    I did try another phone with my 2008 Prius. My oldest son has a new Sprint MOGUL cellphone with Bluetooth and I connected his easily to the Prius, and it did the same thing. The Prius forgets the MOGUL after about a minute. So that is 3 different bluetooth phones now that I have tried and none of them auto-connect. The Samsung SPH-A900, the Motorola Q, and the Mogul .
     
  4. ceric

    ceric New Member

    Joined:
    Oct 30, 2004
    1,114
    52
    0
    Location:
    Fremont, CA
    Vehicle:
    2005 Prius
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    ace,
    I believe the BT unit on your Prius is broken.
    I have connected 3 phones with my 2005 Prius.
    They all worked as expected.
     
  5. Joekc

    Joekc Member

    Joined:
    Nov 12, 2007
    265
    16
    8
    Vehicle:
    2008 Prius
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    I have a 2008 Prius (pkg 5) and I've had three different bluetooth phones, LG envy, Motorola Razr, Blackberry Pearl connected through it with no problems. The only annoyance is that when my wife and I use the car, we have to dive deep into menus to switch phones. Also, I can't figure out how to delete my old phone. Maybe someone knows that.

    Otherwise, I'm guessing you have some sort of technical issue. My 2008 is fine with bluetooth.
     
  6. Fred Wacksman

    Fred Wacksman New Member

    Joined:
    Apr 30, 2008
    91
    0
    0
    Location:
    Mason,Ohio
    Vehicle:
    2008 Prius
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    I found this site,toyota.letstalk.com, and it was really helpful. I was told my phone(LGvx8300) couldn't transfer names to the book, by both Verizon and my dealer. Not true, but the site gives different instructions than the manual, and it works great. I think it covers both autos and providers, but you need to try the different links.
    But, you may have a defective module !!!!!!
    Fred
     
  7. bbald123

    bbald123 Thermodynamics Law Enforcement

    Joined:
    Nov 13, 2007
    386
    269
    0
    Location:
    Harrisburg, PA
    Vehicle:
    2016 Prius
    Model:
    Four
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    My Q works fine with my 2008. Sometimes, connection can take up to 90 secs after both sides (car and phone) are up and running.
     
  8. Scott_R

    Scott_R Member

    Joined:
    Jul 20, 2006
    386
    12
    0
    Location:
    Long Island
    Vehicle:
    2012 Prius
    Model:
    Four
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    My Samsung T329 autoconnects perfectly with my 08 Prius, but my Razr V3 will not autoconnect, no matter the settings on either phone or car (it doesn't matter if I delete other phone profiles from the car).
     
  9. ace

    ace A mini-tank with snow tires

    Joined:
    May 4, 2008
    34
    1
    0
    Location:
    Ames, Iowa 50010
    Vehicle:
    2008 Prius
    Model:
    N/A
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    Update:

    You were correct. The modele was defective.

    I took it into the dealer and they spent an afternoon trying to auto-connect a couple of phones. They were able to delete the phones from my Prius, so I know that is possible.

    The dealer ordered a new computer module which took a week to get the part plus several hours to install. And only a specially trained electronics technician was able to install it, which was fine with me. It works great now. It auto connects every time just the way it is supposed to. I have a new LG Muziq phone now, since I lost my A900. But the Motorola Q autoconnects now too.

    Also, I am able to transfer all my contacts to the Prius phonebook, which I could not do previously, but maybe that was because the A900 wouldn't transfer and the Muziq will. That is a nifty feature if anyone hasn't tried it. It transfers all contacts at one time from the cell phone contact phonebook to the Prius phonebook.

    The Dealer said this was the first time they had this problem, so it must be rare.

    Only one issue remains. When I had one phone it auto-connects everytime, but if I have two phone profiles in the Prius it does not auto-connect. I think it gets confused which one is trying to connect. So I'll probably just remove the 2nd cell phone and only use one.

    Also, I think the new module might have fixed an issue with the CD/AM/FM. Before when I turned off the car and turned it back on it didn't remember if the CD or radio was on, it was always off. But now it remembers if I left the CD on or the radio on, it will be on when I turn on the car. So that is nice too.
     
  10. ace

    ace A mini-tank with snow tires

    Joined:
    May 4, 2008
    34
    1
    0
    Location:
    Ames, Iowa 50010
    Vehicle:
    2008 Prius
    Model:
    N/A
    Re: Bluetooth auto-connect fails on both Samsung A900 and Motorola Q. Connect works, autoconnect doe

    I found out that it does Auto-connect even if you have two phone profiles, but only to the phone that you had selected last, and you need to have the auto-connect button enabled. No need to get rid of one of the profiles.
     
Loading...