Car dies when I shift into gear (red triangle of death)

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Omer4, Jun 28, 2022.

  1. Omer4

    Omer4 New Member

    Joined:
    Jun 28, 2022
    3
    0
    0
    Location:
    Pakistan
    Vehicle:
    2008 Prius
    Model:
    II
    Prius 2008 gen2. New member here. My car shows red triangle alongside abs check engine light and traction control error. Suspected a 12v battery error. Checked its health using system diagnostic check and it showed 11.9v which is low. However when I start the car it drops down to 11.1-11.2 even though it usually increases after starting. Three days ago i recharged my battery and it worked alright however now the issue is back. The car goes free when shifting into forward gear. Is the 12v battery faulty or anything else? Any help will be appreciated. Thanks
     

    Attached Files:

  2. JC91006

    JC91006 Senior Member

    Joined:
    Nov 10, 2013
    15,826
    8,082
    0
    Location:
    Los Angeles, CA
    Vehicle:
    2008 Prius
    Model:
    II
    The battery is low but it should charge itself when the car is on. If the car is not charging the battery when it's on (around 14.1v), then the DC to DC converter is bad.

    You can pick up a used inverter (in the USA) for next to nothing, nobody wants them cause they rarely fail.
     
    Omer4 likes this.
  3. Omer4

    Omer4 New Member

    Joined:
    Jun 28, 2022
    3
    0
    0
    Location:
    Pakistan
    Vehicle:
    2008 Prius
    Model:
    II
    thanks for the suggestion. Will definitely look into it. Rightnow i started the car to check battery level again and now it has fallen down to 9.5v (before a break start). When i try to turn my car on completely the infotainment tv doesn't even turn on now. Providing an update since this is very very odd for me
     

    Attached Files:

  4. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    4,835
    4,086
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    Welcome to PriusChat!!
    There are DTCs (codes) stored in the ECUs (computers), use a OBD2 adapter or scanner to retrieve them, then post them here for advice.
    How old is the 12v battery, and how many hours per week are you driving the vehicle?

    FYI : you're moderated until you've posted 5 times.
     
    Omer4 likes this.
  5. Omer4

    Omer4 New Member

    Joined:
    Jun 28, 2022
    3
    0
    0
    Location:
    Pakistan
    Vehicle:
    2008 Prius
    Model:
    II
    i dont own one and the mechanic shop is closed rightnow. Will let you know as soon as the shop opens in the morning.

    the 12v battery is nearly 6 months old. My car is in use nearly 2 hours a day 6 days a week if not more. However i did go to a hill station this week (6+6 hours drive total) and the issue first arrived there. Recharging the battery made the issue go away but now its back again. Thanks for helping me out
     
  6. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    4,835
    4,086
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    If not a parasitic drain or bad inverter coolant pump, then it sounds like you could have a failing 12v battery, did it come with a warranty?
    Using a voltmeter, check the voltage at the 12v battery, and again at the jump points under the front hood, they should be closely related.

    Confirm that all of the 12v battery connections are good, including the 12v ground strap from the negative terminal that attaches at the body.
    Curious if the AC works, or cuts out at times?

    When was the inverter coolant pump last replaced, and how many miles are on the vehicle?
     
Loading...