Carplay hijacks the audio system

Discussion in 'Gen 4 Prius Audio and Electronics' started by tomguild, Apr 9, 2022.

  1. tomguild

    tomguild smugmobile owner

    Joined:
    Jul 18, 2009
    28
    10
    0
    Location:
    Raleigh NC
    Vehicle:
    2021 Prius
    Model:
    LE
    I've had my 2021 Prius for about a year; very happy with it overall. I am using the CarPlay2air adaptor with my iphone 11. It connects wirelessly about 75-80% of the time with no issues. The other 25-30% of the time I just unplug and replug the adaptor and it syncs. Carplay is pretty cool, most of the time.

    But here's the one annoyance. If I'm using the radio or any other part of the OEM sound system, and then open an app on my phone (while connected to the car), Carplay seems to take over the radio, and even if there's no audio associated with the iPhone app, my sound system goes silent.

    At that point I have to go into the audio settings and change the system back to the radio; several screens and menus to navigate. This gets old pretty fast.

    Anyone else have this problem? Any ideas on how to fix it? (Other than turning carplay off?)
     
  2. AzWxGuy

    AzWxGuy Weather Guy

    Joined:
    May 22, 2011
    873
    427
    0
    Location:
    Tucson, AZ
    Vehicle:
    2021 Prius
    Model:
    Limited
    That's all I needed to see to finalize my Apple/Android vacillations. I'm not entirely devoid of Apple products though. I still have a 7th generation Nano that I plug in to the vehicle USB and it works wonderfully for music and podcasts. It won't show me the album covers though, which I might be able to see with an iPhone. No great loss.
     
  3. MIkeDr

    MIkeDr Active Member

    Joined:
    Sep 16, 2020
    205
    117
    0
    Location:
    Seattle, WA
    Vehicle:
    2020 Prius
    Model:
    XLE AWD-e
    Hmm. I don’t have this problem. I listen to the radio while using CarPlay. When a navigation prompt comes along, it plays instead of the radio, and then goes back to the radio.
     
  4. eow

    eow Member

    Joined:
    Oct 23, 2021
    142
    81
    0
    Location:
    Winnipeg, Canada
    Vehicle:
    2022 Prius Prime
    Model:
    Base
    Likewise, I do not have the issue you are experiencing. But I use a CarLink Mini that connects 199% of the time and does not drop calls(after an update).

    It may be a CarPlayAir2 issue. Check for updates.


    iPhone ?
     
  5. thomassster

    thomassster Member

    Joined:
    Nov 2, 2015
    214
    69
    0
    Location:
    Colorado, US
    Vehicle:
    2019 Prius
    Model:
    XLE AWD-e
    I have an aftermarket pioneer and experience similar symptoms. It’s most likely the handling of CarPlay since many apps utilize sound so even if there is no sound initially, the app most likely has configuration to utilize the audio if needed.
     
Loading...