1. Attachments are working again! Check out this thread for more details and to report any other bugs.

Front ABS Sensor Wiring Colors?

Discussion in 'Gen 3 Prius Technical Discussion' started by SB6, May 13, 2023.

  1. SB6

    SB6 Member

    Joined:
    Jan 27, 2019
    314
    69
    0
    Location:
    Texas
    Vehicle:
    2010 Prius
    Model:
    II
    I'm seeing black and white on the sensor side, and blue and pink (red?) on the wire harness side. What should connect to what?

    PXL_20230513_173253514.jpg
     
  2. Eddie25

    Eddie25 Active Member

    Joined:
    Dec 31, 2018
    321
    122
    0
    Location:
    IL
    Vehicle:
    2011 Prius
    Model:
    III
    According to my wiring diagram, for the front right Pink is POS and Blue is NEG.

    Can't say what your sensor is for sure, but for the rear sensors white is POS and black is NEG, so that'd be my guess.
     
    SB6 likes this.
  3. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    23,222
    15,051
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    The white and black for the front sensors aren't shown in the wiring diagram, because that pigtail is just considered part of the sensor, and the first connector shown in the diagram is the one (A34) where that connects to the blue (−) and pink (+) wires from the ECU.

    You could assume the undocumented black/white wiring of the sensor itself has the same polarity as the rear sensors (where it's documented) ... but that would definitely be an assumption.

    I've never checked whether the left and right front sensor are the same part number. The connectors do look like the same shape in the wiring diagram. If the sensors are the same, you could go look on the other side, where − would be whatever connects to the green wire, and + to the red one.
     
  4. SB6

    SB6 Member

    Joined:
    Jan 27, 2019
    314
    69
    0
    Location:
    Texas
    Vehicle:
    2010 Prius
    Model:
    II
    These are magnetic sensors that work by sensing the small voltage induced by the wheel turning, correct? The sensors are not actually powered? In which case, what's the worst that could happen if I hooked them up with reversed polarity?

    I tried hooking up my multimeter to the bare wire on the sensor end, and turning the wheel by hand with the front of the car in the air. I seemed to have been getting a negative voltage with the multimeter positive hooked to white, and the multimeter negative hooked to the black. But I don't know if could trust those readings, or if they were just from the multimeter/leads being jostled around
     
  5. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    23,222
    15,051
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    I believe in this generation they are powered Hall sensors.
     
  6. Eddie25

    Eddie25 Active Member

    Joined:
    Dec 31, 2018
    321
    122
    0
    Location:
    IL
    Vehicle:
    2011 Prius
    Model:
    III
    So + from the ECU would have power, and - would be signal wire and closest to ground?
     
  7. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    23,222
    15,051
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Well, it's only a two-wire circuit, so whatever current is flowing must flow through both, and the ECU could read the 'signal' off either one. That's a detail not shown in the wiring diagram or repair manual, and probably not necessary to know.

    The diagram does already show the polarity of the blue (−) and pink (+) wires from the ECU. A meter could confirm if you want to be sure that's right. But I'm not sure that helps you if what you need is the polarity of the black/white wires of your sensor's broken-off pigtail.

    Have you checked whether the left and right sensors are the same part number?
     
  8. SB6

    SB6 Member

    Joined:
    Jan 27, 2019
    314
    69
    0
    Location:
    Texas
    Vehicle:
    2010 Prius
    Model:
    II
    parts.toyota.com shows the front right speed sensor as 89542-47030, and front left as 89543-47030, so there is a difference in the last digit of the first bit. I would imagine the polarity would be the same between the two, though... But I have not yet had the chance to take a look at my front left sensor, as I believe it would require removing the fender liner
     
  9. SB6

    SB6 Member

    Joined:
    Jan 27, 2019
    314
    69
    0
    Location:
    Texas
    Vehicle:
    2010 Prius
    Model:
    II
    For anyone that stumbles upon this post looking for the answer, it's black to blue, white to red.
     
    Mr. F likes this.