Inverter Pump / 12v battery issues

Discussion in 'Newbie Forum' started by Mavis5mcc, Aug 25, 2021.

  1. Mavis5mcc

    Mavis5mcc New Member

    Joined:
    Aug 22, 2021
    1
    0
    0
    Location:
    Oakland CA
    Vehicle:
    2007 Prius
    Model:
    One
    Hello Prius friends!

    My 2007 Prius’ inverter water pump failed about 2 months ago and my friend’s dad mistakenly diagnosed it as a bad 12v battery and replaced that. A couple weeks later, I had the codes read and discovered it was actually the inverter water pump that was failing and had that replaced (Professionally this time!) After driving fine for a couple weeks, I tried to turn the car on one morning and the battery was dead. I jumped and charged it and now the voltage is reading ~11.6v with headlights off and ~10.6v with headlights on. The car is not showing any codes!

    Clearly I need a new battery but I’m wondering if it is possible that my inverter is failing? Or if driving with the failing inverter water pump for a couple weeks killed my brand new battery… Is there a way to see if the inverter is bad?

    Thanks!!!
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    94,611
    42,889
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    welcome!
    measure the voltage with the car on, should be around 14.if that is fine, it may just be a defective battery and under warranty.
    it has nothing to do with the inverter fluid pump. how did you charge it?
     
Loading...