1. Attachments are working again! Check out this thread for more details and to report any other bugs.

I've checked my car with TechStream and found codes as below

Discussion in 'Gen 3 Prius Main Forum' started by htcmember, Jun 19, 2022.

  1. htcmember

    htcmember Junior Member

    Joined:
    May 20, 2022
    40
    15
    0
    Location:
    California
    Vehicle:
    2010 Prius
    Model:
    III
    20220617_185130.jpg Hi All,
    Do you have any advises on which maintenance parts that I need to perform? I can drive w/O any issue until now but love to put my hands into fix any problem that I can do myself.

    Thanks a lot,
    Riley
     

    Attached Files:

  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    107,401
    48,776
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    how many miles on her?

    does she burn any oil?

    have you cleaned the egr circuit?

    did you click on the snowflakes for sub codes?
     
  3. htcmember

    htcmember Junior Member

    Joined:
    May 20, 2022
    40
    15
    0
    Location:
    California
    Vehicle:
    2010 Prius
    Model:
    III
    Hi @bisco
    Please find my quick responses below...

    Riley: I forgot to capture the screen to share, will do it soon and ask for advises on it.

    Thank you very much and Happy Fatherday,
    Riley
     
    bisco likes this.
  4. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    10,654
    4,321
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    For starters your screen shots are really hard to read... Hopefully if you have to post more you can get all the info into one image so it's not so confusing.

    Secondly, as the years go by a car will pick up an occasisonal DTC that's not of any more significance than a one time glitch. So first step is to record all these codes and clear them all and drive around for a while that see what comes back.

    Once you know what continues to be a problem you can do a Google search on that error code with keyword "priuschat" and read all the info on how to complete the diagnoses and repair.
     
    htcmember likes this.
  5. htcmember

    htcmember Junior Member

    Joined:
    May 20, 2022
    40
    15
    0
    Location:
    California
    Vehicle:
    2010 Prius
    Model:
    III
    Hi @PriusCamper ,

    Thanks for your suggestions, will do and update here for more advises and helps. Thanks for your advises and appreciate your time to do so!

    Thanks
    Riley
     
  6. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    22,764
    14,799
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    C1202 is an issue with the level sensor for the brake fluid. If the fluid isn't low, the level sensor or wiring has an issue.

    Some maintenance procedures involve temporarily unplugging that connector (it's a two-pole connector just under the edge of the cowl, just outboard of the brake fluid reservoir). Could be worth a quick check to see if maybe the last person to do that forgot to reconnect it.

    C1252 indicates the brake pressure pump has had an excessively long run time. (One normal run of the pump usually takes a few seconds. The threshold to trigger C1252 is nearly three minutes.) What have you been noticing about the sounds of the pump?

    The U0073 indicates the skid ECU isn't reliably communicating with some of its remote sensors, like the yaw rate and acceleration sensor or the steering angle sensor. The troubleshooting for those communication problems can require some attention to detail (and the manual and wiring diagram). It's the kind of code you might not worry much about if you clear it and it stays away.

    The B2784 refers to the antenna coil built into the power switch. It's used when your smartkey wireless functionality isn't working and you have to start the car by holding the fob against the power button. If that antenna doesn't work, you could have an unhappy moment if you're ever in that situation.

    I'm not sure what's a good way to test that (follow the repair manual, I guess). There is a chicken dance to disable smartkey, and then you would need to hold the fob against the button to start. But I don't remember if the dance involves pushing the button.

    If it does, and the antenna's not working, you could probably do the dance to turn smartkey off easily enough, and then confirm you had a problem, and then, umm, not be able to do the dance to turn smartkey back on. That would be an unhappy moment.

    Again, you might see if this code was a fluke and stays away after clearing.
     
    PriusCamper likes this.
  7. htcmember

    htcmember Junior Member

    Joined:
    May 20, 2022
    40
    15
    0
    Location:
    California
    Vehicle:
    2010 Prius
    Model:
    III
    Hi @ChapmanF,
    Really appreciate your advises in very details and how to as well.

    Let me try to do these maintenance steps if it could be fixed and do a clear codes after all to double check

    Thanks again and have a good day,

    Riley

    SM-F916U1 ?
     
  8. htcmember

    htcmember Junior Member

    Joined:
    May 20, 2022
    40
    15
    0
    Location:
    California
    Vehicle:
    2010 Prius
    Model:
    III
    Hi @ChapmanF ,

    back to the above issues, after my recent trip, i've tried to check again and only B2784 existed.

    Btw, here is the history of my car symptom: my fob battery was dead 1 time before i've replaced a new battery and I needed to use the hold-fob-to-power-button method to start it that time. Then, no issue with my new remote battery until now.

    I've tried to look into the same topic and found some pictures related but not any manual on how to fix it. Do you still keep a copy of that to share?

    I will try to check and fix it asap. After all my DIY works on my 2010 prius, I even love her more and would fix all issue to her may have before me (with the ex-owner) :D
     

    Attached Files: