mileage didn't reset after gas fillup

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by fintonissimo, Aug 14, 2013.

  1. fintonissimo

    fintonissimo Member

    Joined:
    Sep 17, 2009
    111
    8
    21
    Location:
    Chicagoland
    Vehicle:
    2008 Prius
    Model:
    N/A
    Hi all, I have never had this happen, but when I filled up with gas today the mileage in the display didn't reset to back to zero after I turned the car back on and drove away. Is this indicative of a problem, or is it just a fluke? Has anybody else ever experienced this?
     
  2. xpcman

    xpcman Senior Member

    Joined:
    Jun 11, 2009
    1,302
    294
    0
    Location:
    California - SF Bay area
    Vehicle:
    2008 Prius
    Don't you have to push a button to set it back to zero?
     
  3. boppo

    boppo Active Member

    Joined:
    Mar 11, 2009
    799
    138
    0
    Location:
    Owego, NY
    Vehicle:
    2006 Prius
    Model:
    II
    Mine has a reset button.
     
  4. fintonissimo

    fintonissimo Member

    Joined:
    Sep 17, 2009
    111
    8
    21
    Location:
    Chicagoland
    Vehicle:
    2008 Prius
    Model:
    N/A
    This is a 2008 Prius, the mileage for each tank automatically resets back to zero after you fill the tank up and start the car without pushing the reset button. If you push the reset button, it also resets the avg. MPG, which I prefer not to do. Anyway, since the mileage didn't reset on its own this time, I'm wondering if something is wrong.
     
  5. vskid3

    vskid3 Active Member

    Joined:
    Jun 23, 2013
    773
    228
    0
    Location:
    Texas
    Vehicle:
    2005 Prius
    How much gas did you add? It might not have been enough for the car to realize that the tank is now full.
     
  6. fintonissimo

    fintonissimo Member

    Joined:
    Sep 17, 2009
    111
    8
    21
    Location:
    Chicagoland
    Vehicle:
    2008 Prius
    Model:
    N/A
    I was down to one pip, filled up with 9.6 gallons. So, I'm still wondering...
     
  7. KK6PD

    KK6PD _ . _ . / _ _ . _

    Joined:
    Mar 24, 2008
    4,003
    941
    118
    Location:
    Los Angeles Foothills
    Vehicle:
    Other Hybrid
    Model:
    N/A
    Apparently not "Always".
    I make sure I manually hit Reset. I see it reset.
    It's like holding the Power button down just a little longer to make sure the car actually turns off!
    Safe, dependable, works every time!
     
  8. fintonissimo

    fintonissimo Member

    Joined:
    Sep 17, 2009
    111
    8
    21
    Location:
    Chicagoland
    Vehicle:
    2008 Prius
    Model:
    N/A
    You're missing my point, though. I don't care to reset it. I'm only concerned because it is supposed to reset on its own and it didn't this time. This is the first time in almost 100 K miles that the mileage didn't reset to 0 after filling up.
     
  9. uart

    uart Senior Member

    Joined:
    Sep 7, 2009
    4,215
    1,196
    0
    Location:
    Australia
    Vehicle:
    2005 Prius
    Can anyone clarify which Gen2 year models do auto-reset the mileage which don't. Mine is a 2005 model and definitely auto-resets, but I was under the impression that 2006 or later models were manual reset so that you had the option of doing "lifetime" (or multitank) averages. I'm sure that several people here have told me this. Perhaps this behavior is an option that you can set somewhere?
     
  10. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    101,126
    45,849
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    when i had my '08, sometimes it would reset automatically, and sometimes it wouldn't. and i always filled from around two pips. not sure why, but i doubt anything is wrong. i bet if you ask the dealer, they will be clueless as usual. i'm not even sure if there is anything in the manual about it.
     
  11. fintonissimo

    fintonissimo Member

    Joined:
    Sep 17, 2009
    111
    8
    21
    Location:
    Chicagoland
    Vehicle:
    2008 Prius
    Model:
    N/A
    Ok, now the plot thickens...after my first post on Aug. 14th, I drove the car for 500 miles and had one pip remaining. Therefore, Thursday night Aug. 22 I decided to get gas. MFD indicated my average mileage as 53.8 MPG over the past 2 tank fillups.

    I started to pump the gas but it shut off early, I had only put in about 4.5 gallons! I know it isn't a good idea to top off the tank, but I honestly didn't think it could be full; so I tried to put a little more in. I gave a couple more squeezes, and put in .4 gallons more. Assuming the gas pump might be malfunctioning, I moved to a different pump. I started the car up, and this time the mileage did reset automatically to 0. At the other pump, I gave only one squeeze, and it immediately shut off, not allowing me to put in any more gas. However, the gas gauge was indicating only 8 pips, not full!

    I then drove about 35 miles, and noticed the gas gauge had gone down to 7 pips. I found a gas station and this time I was able to fill the tank to the point that it registered as full. The mileage did reset again to 0. With the 3 fillups, I was only able to put in a total of 8.5 gallons into the tank...yet, when I started, I was down to one pip and had driven 500 miles. My past experience has been that when I'm down to one pip I can usually put about 10 gallons into the tank. Only in the winter does it shrink to the point that I can only put 8 gallons in.

    So, now I have some questions/concerns:

    1) Are the two issues related? (tank first not resetting to 0 and now having trouble filling it up all the way)
    2) Why did the gas pump shut off with the tank only registering 8 pips? You would think it would shut off only if it was registering as completely full.
    3) Wondering if this (problems with filling up the tank) is going to be a continual problem now, and if so, what to do about it.

    I'm well aware of the shrinking bladder syndrome with this car, but what stands out to me is odd is that the tank wasn't full, only at 8 pips, but I couldn't fill it up all the way until I drove it 35 miles and went down to 7 pips. Also, I would expect that after having driven about 500 miles that it would not be filled after only 8.5 gallons in the summertime.

    Thoughts/insights?
     
  12. fintonissimo

    fintonissimo Member

    Joined:
    Sep 17, 2009
    111
    8
    21
    Location:
    Chicagoland
    Vehicle:
    2008 Prius
    Model:
    N/A
    Nobody has any thoughts on this? Isn't it odd to not be able to fill up the tank when it is only indicating 8 pips?!
     
  13. Whiteyprius

    Whiteyprius Active Member

    Joined:
    Feb 24, 2008
    389
    104
    0
    Location:
    North Carolina, USA
    Vehicle:
    2017 Prius
    Model:
    Two
    I have a 2008 - with a mind of it's own! For now, i'd consider it a fluke and not worry. The gas gauge & auto reset can sometimes be a mystery - and over sensitive auto cutoff pumps can really confuse the poor thing!

    Q10 ? 2
     
  14. Jamesb93612

    Jamesb93612 Member

    Joined:
    Mar 19, 2013
    133
    69
    0
    Location:
    Clovis, Ca
    Vehicle:
    2008 Prius
    Model:
    N/A
    I've only had one time where my '08 didn't reset automatically. I have however, had multiple times where the pump shuts off prematurely. I know it is not full. After driving 500 miles a week for the last 2 years, I have memorized which pumps work best along my route.
     
  15. wjtracy

    wjtracy Senior Member

    Joined:
    Sep 19, 2006
    11,203
    3,551
    1
    Location:
    Northern VA (NoVA)
    Vehicle:
    Other Hybrid
    Model:
    N/A
    I seem to recall some fuel gauge recalibration steps you may want to try.
    My 2006 needs manual reset...news to me some Gen2 did not need this.
    I have had a few strange fill-up events but if it goes back to normal I forget about it.

    PS- nice job on the 500 mile tank my record is 485 maybe you have better gasoline
     
  16. Britprius

    Britprius Senior Member

    Joined:
    Jun 14, 2010
    5,194
    1,899
    0
    Location:
    Herefordshire England
    Vehicle:
    2008 Prius
    I have a UK 2008 (no bladder) this always rests the millage on that tank when I fill up. I usually run 5 tanks (3,000 miles) before resetting the average mpg and that roughly aligns with the four seasons allowing me to check millage variation with temperature.

    John (Britprius)
     
  17. Coolride17

    Coolride17 Junior Member

    Joined:
    Jul 10, 2013
    55
    19
    0
    Vehicle:
    2005 Prius
    Mine does when it wants too.
     
Loading...