1. Attachments are working again! Check out this thread for more details and to report any other bugs.

Need help - Navigation blank & Audio dead

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Limaren, Jun 14, 2023.

  1. Limaren

    Limaren Junior Member

    Joined:
    Nov 4, 2017
    6
    2
    0
    Location:
    florida
    Vehicle:
    2008 Prius
    Model:
    Touring
    I discovered my navigation screen is completely blank, my radio not working and all the hands-free audio for phone calls is dead. I checked almost all the engine fuses (including the RAD-1 & AMP-2) as well as the ECU-IG No.2 under the dash. All working. Is there anything else I can do to try to fix this myself.

    I did find I had a rodent problem under the hood last November which may be part of a “Hybrid System” warning I get requiring a reset every once in awhile (another factor may be having had a Dorman battery rather than a Toyota one). However, the rodent problem occurred over 7 months ago.

    Any suggestions on what to try next?
     
  2. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    7,379
    1,281
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    Do your steering wheel buttons all function can you turn the air conditioning up and down move the temperature turn on the radio and change the station no matter what the screen says from the buttons move the mode from AM/FM 1 and 2 etc turn the rear defrosters and what have you on does that all work from the steering wheel If no start looking at your clock spring. It's behind your steering wheel
     
  3. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    107,422
    48,783
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    Start by pulling the codes for the hybrid system to see where you’re at.

    then pull the hu and check the wiring
     
  4. Limaren

    Limaren Junior Member

    Joined:
    Nov 4, 2017
    6
    2
    0
    Location:
    florida
    Vehicle:
    2008 Prius
    Model:
    Touring
    The buttons on the steering wheel — AC temp & display — work. No audio at all, so not sure if those controls work. Thanks for the troubleshooting tip.