New 12v, new hybrid and NOW red triangle, check engine, red brake light and ac stops

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by PairofJacks, Aug 9, 2017.

  1. PairofJacks

    PairofJacks New Member

    Joined:
    Apr 21, 2017
    6
    1
    0
    Location:
    Salt Lake City
    Vehicle:
    2006 Prius
    Model:
    ----USA----
    At the end of May of this year I had the hybrid battery replaced on my 2006 Prius along with the 12v battery. All was fine until this morning. I drive 45 miles to work and this morning after driving 40 miles the red triangle and check engine lights came on. It still drove fine the rest of the way to work and almost all the way home this evening. When driving home this evening the air conditioner stopped blowing cold air and the VSC light and red brake lights came on. I know....get the codes. I will but I'd like to find out what this new problem might be. Inverter coolant pump? When the red brake light comes on does that mean my brakes are engaging?
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    95,365
    43,230
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    might be the brake actuator, how many miles on her?

    you can check the pump by looking in the reservoir for movement.

    is it a new toyota hybrid battery?
     
  3. JC91006

    JC91006 Senior Member

    Joined:
    Nov 10, 2013
    15,118
    7,760
    0
    Location:
    Los Angeles, CA
    Vehicle:
    2010 Prius
    Model:
    V
    Yes you most likely have an inverter pump failure. Try not to drive it long distances, especially in the hot afternoon
     
  4. windstrings

    windstrings Certified Prius Breeder

    Joined:
    Sep 11, 2005
    6,278
    372
    0
    Location:
    Central Texas
    Vehicle:
    2010 Prius
    Model:
    IV
    While the car is running, take the cap off the inverter pump resorvoir "the fluid is pink/red", you should see fluid moving and flowing in the inverter pump is working.

    Not a heavy flow per se, but it does flow and is easy to see.
     
  5. Planet Awesum

    Planet Awesum Junior Member

    Joined:
    Jul 23, 2015
    24
    32
    0
    Location:
    Portland, Oregon
    Vehicle:
    2014 Prius
    Model:
    Two
    I did this and it worked, after having the red triangle on dash and touch screen . I had just replaced the combination meter.

    "04-09 Prius procedure. Disable SMART KEY (button that says KEY under steering column), and insert key fob transponder into slot in dash. With foot on brake, push power button and hold the power button in for 30 seconds. Release power button and try to restart."
     
Loading...