No dash info (speedo, PRNDB, odometer) but car runs

Discussion in 'Gen 2 Prius Technical Discussion' started by alpinewhite, Jul 22, 2012.

  1. alpinewhite

    alpinewhite Junior Member

    Joined:
    Jun 19, 2012
    21
    1
    0
    Location:
    Orange County, California
    Vehicle:
    2004 Prius
    Model:
    N/A
    Hi guys,

    This is an intermittent problem. When I power on the car in preparation to drive, there is no info on the dash (green letters and numbers). Car is driveable, though. MFD works, though. As I was driving, I noticed the following:

    Doesn't work:
    ---------------
    - Everything on the dash panel with "Ready", speedometer, gas level, A/C on/off, Cruise on/off, etc
    - Mileage since last fill-up on MFD is blank
    - MPG info on MFD is blank
    - MPG graph on Consumption screen on MFD is blank. Regenerated watts is present, though.
    - Reverse beep doesn't beep
    - Cruise control doesn't work

    Works:
    --------
    - Car runs as normal otherwise.
    - Power windows all ok
    - ICE comes on and off ok
    - Radio works fine
    - Climate control all fine

    I cannot find the pattern for the intermittence. It doesn't appear to be temperature-related. It would work sometimes after having not worked prior to shutdown.

    Thanks in advance.
     
  2. cwerdna

    cwerdna Senior Member

    Joined:
    Sep 4, 2005
    12,544
    2,119
    1
    Location:
    SF Bay Area, CA
    Vehicle:
    2006 Prius
  3. alpinewhite

    alpinewhite Junior Member

    Joined:
    Jun 19, 2012
    21
    1
    0
    Location:
    Orange County, California
    Vehicle:
    2004 Prius
    Model:
    N/A
    Thanks for the links, cwerdna. I've updated my location info.

    I didn't have to 3-second press my Power button to shut down.

    Looking the links you've sent, it appears that a cold solder joint is partially to blame.
     
  4. cwerdna

    cwerdna Senior Member

    Joined:
    Sep 4, 2005
    12,544
    2,119
    1
    Location:
    SF Bay Area, CA
    Vehicle:
    2006 Prius
    pEEF can fix the problem that Luscious Garage describes. See T-SB-0172-09 Combination Meter - Intermittent Display | PriusChat. I believe Luscious actually contracts w/pEEf to do the repair of the boar itself since they know each other.

    Unfortunately, both of them are up here in Nor Cal. Maybe you can remove your board and send it up to him?
     
  5. champion510

    champion510 Junior Member

    Joined:
    Feb 28, 2013
    23
    11
    0
    Vehicle:
    2007 Prius
    Model:
    Two
    I have the same problem. In fact, I have tried to contact PeEf about this on this forum as well as his email.. but he hasn't responded yet.
    I wonder if he is still providing these services.
    I live very close to berk and san fran but just don't feel like I want to spend $500+ on it.
    No disrespect to Luscious and services that they provide.
     
  6. cwerdna

    cwerdna Senior Member

    Joined:
    Sep 4, 2005
    12,544
    2,119
    1
    Location:
    SF Bay Area, CA
    Vehicle:
    2006 Prius
  7. JF125

    JF125 Junior Member

    Joined:
    Jan 8, 2013
    4
    0
    0
    Vehicle:
    2006 Prius
    Model:
    Two
    Back awhile ago it took a week or so to get in touch but once everything got in motion we shipped the board and he repaired it - got it back in two days and have never had a problem with it since. Really glad I went through him and not Toyota as to their tendency to cause other problems while fixing something. Price was right too.
     
  8. CrazyLee

    CrazyLee Member

    Joined:
    Aug 3, 2014
    152
    24
    0
    Location:
    Muskegon, MI USA
    Vehicle:
    2004 Prius
    Model:
    II
Loading...