1. Swayde96

    Swayde96 Junior Member

    Joined:
    Oct 17, 2020
    7
    0
    0
    Location:
    Roopville
    Vehicle:
    2010 Prius
    Model:
    II
    I have been battling this code for a while now on my 2010. I cleaned the entire EGR system and replaced every gasket. Those didn’t work so I replaced the EGR valve, code went away after that for about two weeks (700 miles) and then just came back. What are all the potential causes?


    iPhone ?
     
  2. wheezyglider

    wheezyglider Active Member

    Joined:
    Mar 12, 2011
    247
    176
    0
    Location:
    SF Bay Area
    Vehicle:
    2010 Prius
    Model:
    Five
    Here's what the repair manual shows as potential causes.

    upload_2021-7-16_10-31-36.png

    It's pretty much what you just worked on. Sometimes people don't realize they need to clean the EGR cooler and they stop at the EGR valve and the EGR pipe. Sometimes people clean the intake manifold but miss the tiny EGR openings that feed each cylinder. You pretty sure you got those?
     
  3. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    14,683
    10,317
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    Here's another thread where a mystifying P0401 finally got tracked down.

    In that case, it was a problem in the valve, which I think you have eliminated by replacing the valve. So I don't suggest that you will find the same ultimate cause as in that other thread, but you might find some use in the techniques used to chase it down.
     
  4. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    6,395
    2,679
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    Did you do much cleaning when you replaced your EGR? Seems like you didn't do enough cleaning?
     
  5. amarino

    amarino Member

    Joined:
    Mar 13, 2018
    53
    49
    60
    Location:
    CA
    Vehicle:
    2015 Prius
    Model:
    Two
    When you replaced the EGR valve was it a newer part revision / kit? Or where did you get the "new" valve from? I believe there was a newer part and it also needed a software update to go with it. This video mentions that as well.
     
Loading...