P0A0F and P0121 with engine NO START.

Discussion in 'Gen 2 Prius Main Forum' started by PapaWill, Feb 21, 2021.

  1. PapaWill

    PapaWill Member

    Joined:
    Jan 11, 2019
    121
    22
    0
    Location:
    Maui, Hawaii
    Vehicle:
    2007 Prius
    Model:
    II
    '07 with 145k miles went into fail safe last week and we cannot figure out how to fix. So far we have fuel pressure, air intake is clean, and we have ignition. We have searched the circuits for open and or shorts and have found none. We have tried 2 different throttle bodies ( used) and have had no success. We have gotten the car to start a couple of times and the engine will run at high or low rpms alternately, and then just shuts down. Any help would be appreciated. Thank YOU in advance.
     
  2. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    6,443
    3,358
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    What is the INF code for the P0A0F? Have you looked at the freeze frame data (FFD) for the P0A0F?
     
  3. PapaWill

    PapaWill Member

    Joined:
    Jan 11, 2019
    121
    22
    0
    Location:
    Maui, Hawaii
    Vehicle:
    2007 Prius
    Model:
    II
    PA0AF/205 info code.... along with P0121. I have been through all the manuals for this and am still stumped! Using TS but not sure how to do freeze frame data and post it here... I will explore this on TS and see what I come up with. Thank YOU!
     
    #4 PapaWill, Feb 22, 2021
    Last edited: Feb 22, 2021
  4. SFO

    SFO Senior Member

    Joined:
    Feb 7, 2017
    4,861
    4,091
    0
    Location:
    Northern California
    Vehicle:
    2007 Prius
    Model:
    N/A
    Clicking on the flower, cloud, or snowflake should bring up the freeze frame data

    [​IMG]


    Are you sure the engine was igniting, and not just spinning in an attempt to start?
    You went step-by-step for each of the reported DTCs above?

    I've never used the following link, but it should contain *everything* you need : Service Manuals - Google Drive

    It would be great if someone could extract the manuals from Gdrive and back them up on http://mega.nz/ as well.

    Have you cleaned the MAF/butterfly/throttle body, and then disconnected the 12v for a period of time?

    Have you tried using starting fluid to keep the engine running, which would allow you to force charge the HV battery as well?
     
  5. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    6,443
    3,358
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    The repair manual for P0121 says that if you have P0121 and other codes, go to the relevant DTC chart for the other code(s) before resolving the P01021.

    For the P0A0F/205 it says (among other things) the affected areas are:
    • ECM
    • SFI (Electronic Fuel Injection (EFI), Sequential Injection) system
    DTC P0A0F/204 ENGINE FAILED TO START DTC P0A0F/205 ...
     
  6. PapaWill

    PapaWill Member

    Joined:
    Jan 11, 2019
    121
    22
    0
    Location:
    Maui, Hawaii
    Vehicle:
    2007 Prius
    Model:
    II
    OK thanks for teaching me how to bring up freeze frame data... I know how to click on the cloud to find the su-codes, I just did not put it together that the IS the necessary freeze frame data. I will get more data and out it here. I do not believe there are any other relevant codes, but will post if I find more... One question: by changing out the ECM, does that imply just plug and play? Is there any learning the new ( used) ECM must go through? And If I am correct, the ECM is on the far right side below the lower glove box. Thank YOU!
     
  7. PapaWill

    PapaWill Member

    Joined:
    Jan 11, 2019
    121
    22
    0
    Location:
    Maui, Hawaii
    Vehicle:
    2007 Prius
    Model:
    II
    The problem got fixed today... IT was the ECM! Darn, I never thought I would get this one out of my hair, err ahh, what's left of it! This was the last thing we had to try before just thinking about the junk yard, but she started like she's supposed to start and NO CODES! Celebration time. Thank YOU ALL!
     
    Todd Allan McIntyre and SFO like this.
  8. Figster10

    Figster10 Member

    Joined:
    Jan 19, 2019
    193
    57
    0
    Location:
    Sacramento
    Vehicle:
    2007 Prius
    Model:
    Two
    Were you able to plug and play? Is the ecm located by the glove box?

    Posted via the PriusChat mobile app.
     
  9. mr_guy_mann

    mr_guy_mann Senior Member

    Joined:
    Sep 3, 2020
    2,142
    845
    0
    Location:
    NJ-USA
    Vehicle:
    2006 Prius
    Model:
    Four
    The engine ecu (which is plug & play) is located "in front of" the lower glove box, to the right of the A/C housing, next to the hybrid control ecu.

    Posted via the PriusChat mobile app.
     
    Figster10 likes this.
  10. Figster10

    Figster10 Member

    Joined:
    Jan 19, 2019
    193
    57
    0
    Location:
    Sacramento
    Vehicle:
    2007 Prius
    Model:
    Two
    Wi swap it out tomorrow. Have replaced hybrid battery, engine, fuel pump aka fuel tank and still nothing. Hopefully this does the trick
    Posted via the PriusChat mobile app.
     
  11. Figster10

    Figster10 Member

    Joined:
    Jan 19, 2019
    193
    57
    0
    Location:
    Sacramento
    Vehicle:
    2007 Prius
    Model:
    Two
    Yeah I saw a video where it's at and that sucker is a pain to remove lol. We've checked for clogged cat, replaced engine, fuel pump, hybrid battery and it still sputters at idle in driveway. I've noticed the engine has hardcodes for engine no start that just wont go away when deleting almost has no effect on deleting it. P3190, 204
    Posted via the PriusChat mobile app.
     
  12. Figster10

    Figster10 Member

    Joined:
    Jan 19, 2019
    193
    57
    0
    Location:
    Sacramento
    Vehicle:
    2007 Prius
    Model:
    Two
    Correction: P0a0f, 204
    Posted via the PriusChat mobile app.
     
    A.J. Tarnas likes this.
  13. A.J. Tarnas

    A.J. Tarnas Junior Member

    Joined:
    Sep 29, 2020
    20
    5
    0
    Location:
    29 Palms, CA
    Vehicle:
    2007 Prius
    Model:
    N/A
    you gotta update us! did the new ECM work?
     
    SFO likes this.
Loading...