steering wheel buttons inop...

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by finman, Jun 23, 2009.

  1. finman

    finman Senior Member

    Joined:
    Apr 9, 2004
    1,287
    107
    0
    Location:
    Albany, OR
    Vehicle:
    2014 Nissan LEAF
    2004 buttons on the lower right of the steering wheel are inop when in the straight ahead position. Meaning, when driving straight, the 'recirc' and both defrost buttons do not work. When turned slightly left OR right, they work. Kinda annoying to wait to "turn" in order to make these work, ha, ha. any fix known? I'm assuming the contact(s) that turn with the steering wheel are not contacting when in that straight ahead position...but only for the above mentioned button cluster. How does one access that area to replace/fix? Thanks for any help!

    Curt
     
  2. finman

    finman Senior Member

    Joined:
    Apr 9, 2004
    1,287
    107
    0
    Location:
    Albany, OR
    Vehicle:
    2014 Nissan LEAF
    (bump)...
    No one but me has these steering wheel buttons inop? I can't be THAT special! Any help is appreciated.
     
  3. Patrick Wong

    Patrick Wong DIY Enthusiast

    Joined:
    Mar 8, 2008
    18,156
    6,206
    0
    Location:
    Green Valley, AZ
    Vehicle:
    2015 Prius
    Model:
    Two
    Hi Curt,

    I haven't heard other reports of this problem. Maybe the spiral cable has an intermittent connection. If you plan to DIY then you will have to remove at least the driver's airbag. Maybe you will have to remove the steering wheel and the turn signal switch assembly that includes the spiral cable.

    Suggest you download repair manual info at techinfo.toyota.com to obtain the full procedure on how to do this without having the airbag blow up in your face. Good luck.
     
  4. northwichita

    Joined:
    Sep 24, 2006
    481
    99
    29
    Location:
    Wichita KS
    Vehicle:
    2004 Prius

    My 04 with around 148 k has the exact problem, right side buttons work only when the wheel is turned at least 60 degrees ; it developed this problem about a year ago, not significant enough for me to fix. I've taken a few steering wheels off and never found it easy to do. One thought, wonder if some electrical cleaner sprayed in just the right spot might help.
     
  5. finman

    finman Senior Member

    Joined:
    Apr 9, 2004
    1,287
    107
    0
    Location:
    Albany, OR
    Vehicle:
    2014 Nissan LEAF
    Okay, thanks all for the suggestions. I'll see what I can come up with for a fix. 'Tis true, not a big deal to not use those buttons...but I'm one that HAS to fix even the little things!
     
  6. priusron

    priusron New Member

    Joined:
    Feb 6, 2007
    8
    0
    0
    Did you ever get your buttons to work, if so, how.

    Ron
     
  7. finman

    finman Senior Member

    Joined:
    Apr 9, 2004
    1,287
    107
    0
    Location:
    Albany, OR
    Vehicle:
    2014 Nissan LEAF
    nope, haven't tackled it yet. I may try the electrical spray and see what happens. I really don't want to remove the steering wheel...nor do i want to pay the dealer to fix. I'll get to it someday.
     
  8. alanh

    alanh Active Member

    Joined:
    May 22, 2007
    1,174
    94
    0
    Location:
    Phoenix, AZ
    Vehicle:
    2007 Prius
    I doubt the cleaner will help, unfortunately. If it's only inoperative when the wheel is turned to certain angles, it's almost 100% certain it's the spiral cable. Replacement requires removing the steering wheel.
     
  9. Doxtream

    Doxtream Junior Member

    Joined:
    Jan 6, 2005
    13
    0
    0
    Location:
    Lodi, Ca
    I'm having the same problem, n addition the info button also doesn't work.. I use the info all the time and it bugs me it doesn't work.
     
Loading...