Sticky gas tank membrane

Discussion in 'Gen 2 Prius Technical Discussion' started by Roger3125, Mar 8, 2009.

  1. Roger3125

    Roger3125 New Member

    Joined:
    Jan 8, 2006
    199
    0
    0
    Location:
    Orange County, So Calif
    I found my 06 Prius with four bars, I added $10 of gas and the number of bars remained the same. Later that day to be certain the gas guage was working properly I filled the tank and still it showed four bars.

    I planned to bring it in to the dealer to be checked out but hours later while still driving on the same trip sudeenly it showed a full tank.

    Is something wrong or this the nature of the membrane? Is it something I should have checked by the dealer?

    Thanks for any advice.
     
  2. dapastaguy

    dapastaguy Junior Member

    Joined:
    Jul 31, 2008
    45
    1
    4
    Location:
    Sumter, SC
    Vehicle:
    2008 Prius
    Usually takes mine awhile to get to full but certainly not as long as you describe, maybe a mile or so. I would take it in for sure
     
  3. Patrick Wong

    Patrick Wong DIY Enthusiast

    Joined:
    Mar 8, 2008
    18,115
    6,120
    0
    Location:
    Green Valley, AZ
    Vehicle:
    2015 Prius
    Model:
    Two
    Hi Roger,

    Looks like you added >4 gallons initially, then a smaller amount subsequently. I've noticed once in a while, if I add a relatively small amount of fuel, that the fuel gauge does not register that.

    If you want you could have the gauge checked out, but its likely the tech will report NTF (no trouble found.)
     
  4. qbee42

    qbee42 My other car is a boat

    Joined:
    Mar 2, 2006
    18,058
    3,036
    7
    Location:
    Northern Michigan
    Vehicle:
    2006 Prius
    It's not the fuel tank bladder, it's the way the fuel gauge works. Adding small amounts of gas does not trigger an immediate response. If you had filled it all at once, it would have reset right away.

    Tom
     
  5. jayman

    jayman Senior Member

    Joined:
    Oct 21, 2004
    13,439
    626
    0
    Location:
    Winnipeg Manitoba
    Vehicle:
    2004 Prius
    Only time I had an issue was when the gauge remained "stuck" on 1/3. Under warranty, got a new cluster and something on the tank as well
     
  6. David Beale

    David Beale Senior Member

    Joined:
    Jul 24, 2006
    5,963
    1,940
    0
    Location:
    Edmonton Alberta
    Vehicle:
    2012 Prius
    Pearl can work that way once in a while. It's the gauge, not the bladder. The gauge is operated by a microprocessor, and can be reluctant to respond immediately. It's normal for this car. It ignores small changes, just in case it was due to sloshing or parking on inclines. If it sees the change persisting over time (start/stop cycles as well as elapsed time) then it advances the gauge reading. Pearl has even left one pip off when I fill up until the next day, that is, the gauge advances to all but the top pip, until the next day. Then she illuminates the top one as well.
    She's just teasing us. ;)
     
Loading...