1. Attachments are working again! Check out this thread for more details and to report any other bugs.

Terrible engine knock, misfire codes and P0441 code after headgasket replacement.

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by JordanSmith, Jan 11, 2023.

  1. JordanSmith

    JordanSmith New Member

    Joined:
    Dec 26, 2022
    6
    0
    0
    Location:
    Maine
    Vehicle:
    2012 Prius
    Model:
    One
    After doing a head gasket replacement on my 2012 Prius, I started the car and my engine is knocking pretty bad and im getting engine misfire codes and the P0441 code. I've cleaned the EGR components, I've checked my purge selanoid valve, MAP and MAF sensors, checked my hoses and wiring. None of my pistons were bent. I followed a Toyota manual the whole way through the repair. Maybe my crankshaft is trashed? Does anyone have any ideas?
     
  2. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    10,662
    4,323
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    A bent rod is what most mechanics will suspect... But it's too early to make that conclusion... Still lots of things to double check...
     
  3. Bill Norton

    Bill Norton Senior Member

    Joined:
    Dec 15, 2012
    1,796
    588
    0
    Location:
    MONW, Ks.
    Vehicle:
    2010 Prius
    Model:
    Five
    How did you determine this?
    How far did you tear down this engine while out of the car?
     
  4. JordanSmith

    JordanSmith New Member

    Joined:
    Dec 26, 2022
    6
    0
    0
    Location:
    Maine
    Vehicle:
    2012 Prius
    Model:
    One
    I tore down the engine all the way down to the head gasket and I cranked the engine over to check if all my pistons came up to the correct height, and they all did, none of them sat any lower than the other. One problem I did see while inspecting the pistons, was that on the top of piston one, it had some tiny dings scattered over it. I should mention too, I drove this vehicle with a bad head gasket for a little while, so I'm not sure what kind of extra damage I might have caused.
     
  5. JordanSmith

    JordanSmith New Member

    Joined:
    Dec 26, 2022
    6
    0
    0
    Location:
    Maine
    Vehicle:
    2012 Prius
    Model:
    One
    Well what would you check?
     
  6. tankyuong

    tankyuong Senior Member

    Joined:
    Nov 9, 2012
    1,555
    659
    0
    Location:
    Central MO
    Vehicle:
    2012 Prius c
    Model:
    II
    usually takes a while for engine to smooth out after install
     
  7. Mendel Leisk

    Mendel Leisk Patron saint of newly poured sidewalks

    Joined:
    Oct 17, 2010
    54,135
    37,931
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    What's the miles. If the head gasket and EGR cleaning was left too long, could be the damper between engine and transaxle: it's stressed whenever the engine's trying to compress coolant.
     
    JordanSmith and Bill Norton like this.
  8. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    10,662
    4,323
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    Some helpful folks have added some things to check on here... I'd add double checking to make sure everything is plugged back in / reconnected.

    It's really about how long these symptoms last after the work is done. If these are initial problems, there's plenty of posts on here about how similar symptoms quickly resolve after a few re-boots of the system via disconnecting the 12v.

    If the symptoms don't go away maybe a compression test would be a worthwhile next step...
     
    JordanSmith and Mendel Leisk like this.
  9. MikeDee

    MikeDee Senior Member

    Joined:
    May 9, 2013
    1,529
    580
    0
    Location:
    San Francisco Bay Area
    Vehicle:
    2017 Prius Prime
    Model:
    Prime Plus
    Maybe you didn't set the timing gears right so the timing is off?


    iPhone ? Pro
     
  10. nicoj36

    nicoj36 Active Member

    Joined:
    Oct 15, 2013
    493
    155
    0
    Vehicle:
    2010 Prius
    Model:
    II
    Try BG hybrid repair kit
     
    JordanSmith likes this.
  11. 2010moneypit?

    2010moneypit? Active Member

    Joined:
    Oct 26, 2021
    314
    121
    0
    Location:
    Beaumont ca
    Vehicle:
    2010 Prius
    Model:
    V
    Everyone above made really good points. P0441 is related to an evap leak (fuel vapor system).
    This code would not make your engine knock. What misfire code are you getting? This helps with diagnostics.
    If you were getting any misfire code P03** that will set the engine off Balance and the dampener will make a sound like an engine knock.

    What misfire code did you get?
    How long did you let it run for?
     
  12. JordanSmith

    JordanSmith New Member

    Joined:
    Dec 26, 2022
    6
    0
    0
    Location:
    Maine
    Vehicle:
    2012 Prius
    Model:
    One
    A little over 200,000 miles, and that is some good insight, I never thought of that.
     
  13. JordanSmith

    JordanSmith New Member

    Joined:
    Dec 26, 2022
    6
    0
    0
    Location:
    Maine
    Vehicle:
    2012 Prius
    Model:
    One
    I double checked my timing and when I cranked my engine over it eventually ended back up on top dead center with the timing marks in the right places and the camshaft lobes were at manual specifications. I was thinking there may be too much slack in the chain? But the tensioner is released.
     
  14. JordanSmith

    JordanSmith New Member

    Joined:
    Dec 26, 2022
    6
    0
    0
    Location:
    Maine
    Vehicle:
    2012 Prius
    Model:
    One
    I am getting a misfire code for every cylinder and I'm getting a random/multiple cylinder misfire code. I started it up quite a few times after replacing and trying new things and the longest I let it go was for almost a minute but it sounded so horrible that I shut it down because I didn't want to mess anything else up. And I tried shifting into neutral and drive and gave it some gas, it sounded different but not better, almost like clattering metal in the engine and it sounded like it was loosing power at times.
     
  15. Melthias

    Melthias Junior Member

    Joined:
    Jan 28, 2023
    55
    21
    0
    Location:
    Southern Maine
    Vehicle:
    2012 Prius
    Model:
    Three
    Was this ever resolved?