The Most Poorly Ran Website by a Large Company on the Planet is Toyota.com/owners

Discussion in 'Gen 2 Prius Main Forum' started by MilkyWay, Sep 4, 2018.

  1. MilkyWay

    MilkyWay Active Member

    Joined:
    Feb 20, 2013
    731
    299
    23
    Location:
    MI
    Vehicle:
    2007 Prius
    Model:
    II
    I constantly am on the prowl for Priuses and the concept of checking recent maintenance through toyota.com/owners is brilliant. Amazing actually. Has saved me a million times at auctions when I check the VIN and it says it was just recently at the dealership quoted for bad hybrid battery....Or to see lots of expensive repairs done over the years is a great bonus.

    That being said, 80% of the time the website doesn't even work. I check it about 5 times a week and no less than 4 out of 5 times I get this message:

    Capture.PNG
     
    m.wynn likes this.
  2. bat4255

    bat4255 2016 Prius v #2 and 2008 Gen II #2

    Joined:
    Nov 8, 2007
    577
    196
    0
    Location:
    Dodge Co. Wisconsin
    Vehicle:
    2016 Prius v wagon
    Model:
    Two
  3. JimboPalmer

    JimboPalmer Tsar of all the Rushers

    Joined:
    Apr 14, 2009
    12,048
    6,315
    1
    Location:
    Greenwood MS USA
    Vehicle:
    2012 Prius v wagon
    Model:
    Three
    Odd, I find it very slow, but it always works. (Firefox)
     
  4. Mendel Leisk

    Mendel Leisk 'Orrible Oracle

    Joined:
    Oct 17, 2010
    38,198
    26,945
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    For quite a while Toyota Tech Info wouldn't come up when I used FireFox, it would complain about it's certificate. S'okay now though.
     
  5. jerrymildred

    jerrymildred Senior Member

    Joined:
    Oct 28, 2016
    7,155
    8,792
    0
    Location:
    Tampa, FL
    Vehicle:
    2017 Prius Prime
    Model:
    Prime Premium
    Most times, when I want to enter maintenance I've done, it takes at least two tries. Sometimes it won't work at all till the next day.

    I wonder if it's on a server that doesn't have enough bandwidth.
     
    Merkey and DLC82SV like this.
  6. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    86,162
    38,077
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    all of toyota's websites work about as well as entune.
     
    Shane Burns, m.wynn and DLC82SV like this.
  7. edthefox5

    edthefox5 Senior Member

    Joined:
    Jul 25, 2007
    7,679
    3,351
    0
    Location:
    Clearwater, Florida
    Vehicle:
    2007 Prius
    Model:
    Two
    Put it on Trusted Sites.
     
    DLC82SV and Mendel Leisk like this.
  8. Kenrico

    Kenrico Member

    Joined:
    Jan 12, 2016
    82
    50
    0
    Location:
    San Diego, CA
    Vehicle:
    2007 Prius
    Model:
    N/A
    I am currently locked out ...even tech support could not unlock my login .

    Kenny
     
    DLC82SV likes this.
  9. edthefox5

    edthefox5 Senior Member

    Joined:
    Jul 25, 2007
    7,679
    3,351
    0
    Location:
    Clearwater, Florida
    Vehicle:
    2007 Prius
    Model:
    Two
    I wentb there yesterday with no problem using chrome
    Firefox is seriously jacked up right now I gave up on it.
     
    DLC82SV likes this.
  10. padroo

    padroo Senior Member

    Joined:
    Jan 11, 2008
    2,762
    2,221
    13
    Location:
    Chesterton, Indiana Another third world country.
    Vehicle:
    2016 Prius
    Model:
    Four
    It's always best to have more than one browser on a desktop or laptop computer. We tend to get stuck on one browser.

    I have trouble uploading pictures to this site with Chrome but IE works, knowing that I just switch to IE but Chrome is still my favorite.
     
    DLC82SV likes this.
  11. bat4255

    bat4255 2016 Prius v #2 and 2008 Gen II #2

    Joined:
    Nov 8, 2007
    577
    196
    0
    Location:
    Dodge Co. Wisconsin
    Vehicle:
    2016 Prius v wagon
    Model:
    Two
    I use both, Firefox and Chrome, same issue with both.
     
    m.wynn, MilkyWay and DLC82SV like this.
  12. bat4255

    bat4255 2016 Prius v #2 and 2008 Gen II #2

    Joined:
    Nov 8, 2007
    577
    196
    0
    Location:
    Dodge Co. Wisconsin
    Vehicle:
    2016 Prius v wagon
    Model:
    Two
    Today it works, although slow. It's about average fo that site, a 20% success rate.
     
    DLC82SV and jerrymildred like this.
  13. chelvis

    chelvis Member

    Joined:
    Oct 27, 2011
    75
    45
    0
    Location:
    Long Valley, NJ
    Vehicle:
    2005 Prius
    Model:
    Five
    Agreed, it is a sketchy site. I do use it similar to what the OP was doing.
     
    DLC82SV likes this.
  14. m.wynn

    m.wynn Senior Member

    Joined:
    Oct 24, 2013
    673
    1,180
    0
    Location:
    Queensbury, NY
    Vehicle:
    2014 Prius
    Model:
    Three
    "Sorry, but the National Data feed appears
    to be offline. Please try again soon."

    Tried just now to access service records for our recently acquired '05 and got this typical gem. And so it goes with the T-Owners site:cool:... I actually think it's gotten steadily worse over the years.
     
    bisco, jerrymildred and Raytheeagle like this.
Loading...