Whole mess of codes after inverter pump failure

Discussion in 'Gen 2 Prius Technical Discussion' started by dirt657, Apr 8, 2019.

  1. dirt657

    dirt657 Member

    Joined:
    Dec 1, 2018
    152
    38
    0
    Location:
    Arroyo Grande, CA
    Vehicle:
    2010 Prius
    Model:
    N/A
    So I replaced the inverter pump about 3 weeks ago in this car. 130k on the clock. Has treated me well otherwise. Pinched the lines so I didn’t have to bleed the system. Drove it to Vegas and back. I noticed that area was starting to make a very weird and shrill whining noise. I drove down to Huntington Beach a few days ago to visit some family, and the red triangle and CEL came on and I scanned with tech stream and found the same inverter pump code. Drove a little further and my radar detector starting beeping like crazy like it does if it gets low voltage. Drive a little further and my AC isn’t working either. Drove a little further and lost my ABS. Finally limped it to my destination. The codes I have are:
    P0A93: inverter pump circuit failure
    C1310: Hybrid System malfunction
    C1241: Low Battery voltage positive terminal
    B1442: Air inlet damper control servomotor circuit
    B2775: Interior verification abnormal

    Did I fry my inverter that fast? My 12v is only a few months old
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    87,535
    38,965
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    is there movement in the fluid reservoir?
     
  3. dirt657

    dirt657 Member

    Joined:
    Dec 1, 2018
    152
    38
    0
    Location:
    Arroyo Grande, CA
    Vehicle:
    2010 Prius
    Model:
    N/A
    I checked it and there was NOTHING in there. Must’ve been a slow leak. I refilled it but this pump definitely fried
     
  4. Billy Bailey

    Billy Bailey New Member

    Joined:
    May 24, 2019
    3
    0
    0
    Location:
    Louisiana
    Vehicle:
    2008 Prius
    Model:
    Two
    Hi guys. I’m kinda having the same issue. I got the red triangle with check engine light along with abs light. I cleared the code and my wife drove it and the entire car died. Had to have it towed home. Can’t even roll the window up. Battery in the back measures 12 volts. I changed the inverter pump and still nothing. I haven’t bled it or anything and lost most of my coolant. I just wanted to start it to see if it worked and it did not. Is my next option an inverter change?
    Stats of car
    2008
    250,000ish miles
    Bought the car February 2018
     
  5. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    2,942
    3,465
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring
    Billy,

    When you say the entire car died, you mean the dash went black? If so, the cooling pump blew the AM2 fuse in the engine compartment fuse box. If you've already replaced the pump, just replace the fuse. It's a blue 15 amp. Should be second one down from the top on the right side.

    The best way to replace this pump is by removing the driver side headlight and using two medium sized coolant hose clamps to pinch off the hoses and prevent fluid leakage. You only lose about 4 ounces of fluid during the job. Then you just add a bit of fluid to the reservoir, install a small hose from the bleed port to the reservoir and then energize the pump. To energize the pump all you have to do is press the power button 2x with your foot NOT on the brake. Fluid will circulate through the system and through the small hose you installed. The small hose will flow fluid and any air bubbles into the reservoir.
     
    #5 TMR-JWAP, Jun 6, 2019
    Last edited: Jun 6, 2019
    Billy Bailey likes this.
  6. Billy Bailey

    Billy Bailey New Member

    Joined:
    May 24, 2019
    3
    0
    0
    Location:
    Louisiana
    Vehicle:
    2008 Prius
    Model:
    Two
    Yes the dash went black. Car will not start or anything. Interior lights work. I didn’t even think about a fuse. That would be a nice fix. I already replaced the pump and lost all my fluid. Should have pinched it off. Now I got to add some and bleed it. I will check the fuse when it’s daylight. Thanks so much.
     
  7. Billy Bailey

    Billy Bailey New Member

    Joined:
    May 24, 2019
    3
    0
    0
    Location:
    Louisiana
    Vehicle:
    2008 Prius
    Model:
    Two
    You were right on the money. Replaced the fuse and bleed the coolant system and she’s back on the road. Thank you so much. You sure do know your stuff.
     
Loading...