1. Offline

    Steve Goldenberg New Member

    Member Since:
    Dec 1, 2003
    Posts:
    126
    Likes Received:
    0
    Location:
    Aspen, CO
    Your Vehicle Year:
    2004 Prius
    While typing in my question about a broken latch for the lower glove box door on my 2004 Prius, the automatic thread search pointed me to a posting that told me to remove the moulding. That clue was all I needed. I removed the moulding (there were no screws visable) by pulling hard. I simply stretched the old spring and bent a new hook to make do until I can get a replacement from Toyota or something similar from my local hardware store. It works perfectly for now. If anyone else needs help I'll take some photos for you.
  2. Offline

    Ohm New Member

    Member Since:
    Dec 6, 2007
    Posts:
    1
    Likes Received:
    0
    Location:
    Madison, WI
    Thanks for posting this. My lower box just opened like normal today but will not latch back up.

    Was the molding you removed between the two boxes? I want make sure I pull on the right piece.
  3. Offline

    DarkPRIUS FAR EASTERN

    Member Since:
    Dec 23, 2007
    Posts:
    16
    Likes Received:
    1
    Location:
    Botosani,RO
    Your Vehicle Year:
    2004 Prius
    Hi, everyone!
    Steve, can you help me with this matter, and post those pictures? I have the same isue. Lower glove box door doesn't stay closed. I tried to push the spring but it don't wanna stay in place.
    Can you help me? Or somebody else? Please!
    Thx.
  4. Offline

    PA Prius Member

    Member Since:
    Feb 27, 2007
    Posts:
    441
    Likes Received:
    26
    Your Vehicle Year:
    2004 Prius
    Yes, pics would be great. It may help me with my upper glove box lid-- the spring is likely broken because the lid will not stay up on its own. The dealer quoted $185. to fix....

    PA P
  5. Offline

    DarkPRIUS FAR EASTERN

    Member Since:
    Dec 23, 2007
    Posts:
    16
    Likes Received:
    1
    Location:
    Botosani,RO
    Your Vehicle Year:
    2004 Prius
    Problem solved. I'll take some pictures and post them here. THX Steve!

Share This Page