Cruise Control Malfunctions - intermittent CRUISE light

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by tburnham316, Sep 2, 2010.

  1. tburnham316

    tburnham316
    Expand Collapse
    New Member

    Joined:
    May 22, 2010
    2
    0
    0
    Kansas
    Vehicle:
    2006 Prius
    Model:
    N/A
    I just returned from a 4K trip through 7 states and my cruise control will go batty and make you pull over and re-boot the car.

    Basically I am cruising down the interstate with cruise control on.
    When I come into a town I will either pull the cruise lever forward or step on the breaks to disengage it. The traffic comes to a stop or slows to a crawl for a short period of time. Once the traffic starts to move again and we are back to highway speeds I can no longer use the cruise control because it is intermittently flashing on the dash as a mal-function. The only time it doesn't do this is when I am slowing down if I turn the power off to the cruise control system. What a pain !

    Anyone have any ideas ?
    I stopped in the middle of my trip at two different dealers and there were no codes stored. One dealer charged me a diagnostic the second didn't after I showed him my receipt from the day prior from the other dealer but then he wanted to sell me a brand NEW MFD.
     
  2. krg03

    krg03
    Expand Collapse
    Not expert, just experienced

    Joined:
    Jul 27, 2010
    246
    29
    0
    so cal
    Vehicle:
    2007 Prius
    Model:
    II
    On my 07 I had to replace the brake switch which is a dual switch. One for cruise control and the other for the brake system. My cruise control would sometimes engage and sometimes not. Turns out the switch was thinking I was braking because that part of the switch was stuck (sometimes). Just a guess however doesn't answer your description exactly of not working in powering off. Dealer first option is always to replace the MFD (after they scratch themself).
     
  3. k9lvr

    k9lvr
    Expand Collapse
    New Member

    Joined:
    Aug 6, 2006
    2
    0
    0
    I am having this exact problem with my 2005 prius - and it's been an issue for over a year. It seems to be happening more frequently. I'd like to hear if anyone has any knowledge of this issue.

    Thanks.
     
  4. deliman31

    deliman31
    Expand Collapse
    New Member

    Joined:
    Jun 6, 2007
    6
    0
    0
    My 2007's cruise light did it for the first time traveling from NY to Virginia three weeks ago. When I left the interstate closer to home, I went through a fast food drive-thru lane and when I got to the payment window, in park, my ABS & red brake light came on and the rest of the dash (Speedo, fuel guage, everything else) shut off. I had to shut the car off, let it reboot and it was ok.

    After driving a 25 minute one way trip last night, after backing into the driveway, the cruise control light started flashing again, but no other indications.

    Arrgghh.. 3yr x36k mile warranty expired 30k miles ago.. It think this is going to hurt at the dealer.
     
  5. Scoreboard

    Scoreboard
    Expand Collapse
    Junior Member

    Joined:
    Apr 13, 2007
    7
    0
    0
    Anyone get this figured out? My '07 Prius has been doing it since 37K miles and it just passed 75K. It never happens when I'm anywhere close to a dealer. Same symptoms as others in thread... 100+ mile trip with cruise on then after braking or pulling the lever the cruise indicator flashes. Sometimes the cruise works after it flashes other times it does not. Only restarting the car clears the problem (at least until the next long trip). The deal won't even look at it unless it's doing it when I pull it in. I'm at my whits ends. I have almost 2 years of cell phone video showing it, but they still can't fix it.
     
  6. tomtomsf

    tomtomsf
    Expand Collapse
    Junior Member

    Joined:
    Oct 31, 2010
    36
    5
    0
    Half Moon Bay
    Vehicle:
    2010 Prius
    Model:
    III
    I had a Nissan that did this for 5 years. I would turn the car off at stop lights to "reset" the cruise. It did it about once a month or so. Since it was so intermittent, I never bothered to get it looked at.

    Tom G.
     
  7. kkeane

    kkeane
    Expand Collapse
    Junior Member

    Joined:
    Apr 21, 2015
    55
    6
    0
    San Diego
    Vehicle:
    2005 Prius
    Model:
    II
    I see that this thread is several years old, but because there doesn't seem to be a resolution, and not much else comes up in Google, I'll respond.

    I had the same symptoms: cruise control worked fine on the freeway, but would cut out and sometimes flash back on in stop-and-go traffic. However, my car guy did get a code out of the system, so I can't promise that it actually is the same problem. The code was, I believe, P0571.

    Stopping and restarting the car *seemed* to solve the problem, but I also noticed that if I turned off the cruise control for about ten minutes, and then turned it back on, cruise control would work normally again even without restarting the car.

    This code can have several different causes, so you have to go through several diagnostic steps to identify the root cause. In my case, as in krg03's, it was the brake switch. The cruise control simply sometimes thought that the brake pedal was pushed when it wasn't. My guess is that this switch sometimes comes "unstuck" on its own. Since restarting the car involves pushing the brake, it is not surprising that this would temporarily solve the problem.

    One more thing: if this problem occurs, immediately be sure to check if the brake lights are working. The same switch controls them, although I believe it is a different contact, so only the cruise control might be affected.
     
  8. goldfinger

    goldfinger
    Expand Collapse
    Member

    Joined:
    Mar 12, 2012
    307
    85
    0
    Buffalo
    Vehicle:
    2005 Prius
    It could be the steering wheel's clock spring cable.
     
  9. goldarrow

    goldarrow
    Expand Collapse
    New Member

    Joined:
    Jan 9, 2016
    22
    2
    0
    Los Angeles area
    Vehicle:
    2009 Prius
    Model:
    N/A
    P0571 code, blinking cruise control light, changed out brake lamp switch fixed the issue. Just did mine this morning