Welcome to PriusChat

We'd love to have you join our community and participate in the conversation! Sign up for FREE today.

Sign Up

Problem with Sirius radio on new Rosen OEM nav unit on 2011 Prius

Discussion in 'Gen III 2010+ Prius Audio and Electronics' started by cptdave, May 22, 2011.

Social Buttons

  1. cptdave

    cptdave New Member

    Joined:
    May 22, 2011
    Messages:
    4
    Likes Received:
    0
    Location:
    Rocklin, CA
    Your Vehicle Year:
    2011 Prius
    Model:
    Three
    Last week I had a Rosen OEM navigation unit installed in my new Prius with Sirius radio. The Sirius problem: When first turned on, the Sirius radio will not play until the Rosen is switched to FM radio mode and then back to Sirius. After switching back, it works okay, even if another radio mode is changed to another input and back, until the unit is turned off. When it is turned back on, the same thing happens. One caveat....if an Ipod is connected, the Sirius works okay even when first started.

    I was told to contact the installer (who was not the dealer) and they told me that it was a Sirius problem, and not a problem with the Rosen or their installation. I have another Sirius radio in my Dodge truck that works fine (does not have the delay problem), and I can find no evidence from the forums for either Prius or Sirius of this problem existing. I have a hard time believing their story that it is not a problem with their radio.

    Has anyone else had this problem? I would appreciate the inputs from anyone who has had this unit installed by a dealer, and whether or not you have experienced this problem.

    I will provide a review of my experience with this Rosen unit so far if and when I get this problem resolved. Thanks..
  2. Judgeless

    Judgeless Senior Member

    Joined:
    Jun 30, 2009
    Messages:
    1,826
    Likes Received:
    230
    Location:
    Cleveland, OH
    Your Vehicle Year:
    2010 Prius
    Model:
    IV
    That is not good. I would like to get a Rosen unit. A few thing need to be worked out like firmware upgrades.
  3. Ragz

    Ragz Member

    Joined:
    Sep 16, 2010
    Messages:
    212
    Likes Received:
    90
    Location:
    New York
    Your Vehicle Year:
    2010 Prius
    Model:
    III
    I just had a rosen installed a few weeks ago and they could not get the Sat to connect. IDK if this will work for you but I had to go into the installer settings and turn on Sat radio. Menu; Settingd: Kepad: 7253 Enter.
  4. cptdave

    cptdave New Member

    Joined:
    May 22, 2011
    Messages:
    4
    Likes Received:
    0
    Location:
    Rocklin, CA
    Your Vehicle Year:
    2011 Prius
    Model:
    Three
    Thanks, Ragz. I already tried the installer settings menu that you referenced, but that had no impact on my problem. My Sirius radio works okay (after the FM radio button has been selected first and then back to Sirius).

    I would really appreciate feedback from people who have the Rosen with Sirius installed, and if their system does or does not require a switch to FM first to make the Sirius work. That information would help me alot in trying to get the problem resolved. Thanks again.
  5. medvid

    medvid New Member

    Joined:
    May 25, 2011
    Messages:
    1
    Likes Received:
    0
    Location:
    Virginia
    Your Vehicle Year:
    Other Non-Hybrid
    Model:
    N/A
    cptdave,
    I have the Rosen navi with Sirius on my 2011 Rav4. It was fine until May 4, 2011 when Sirius and XM did a big channel switch to align the channels between them. From that day, I have had the same experience you have. The installer says that Rosen is aware of the problem and is developing a solution. They think it has to do with a cable with an in-line component that is not compatible with whatever Sirius did when changing their channels and anything else they did. The installer says that Rosen is suggesting a fix by mid-July but that's an estimate.

    Hope that helps.
  6. cptdave

    cptdave New Member

    Joined:
    May 22, 2011
    Messages:
    4
    Likes Received:
    0
    Location:
    Rocklin, CA
    Your Vehicle Year:
    2011 Prius
    Model:
    Three



    Thanks Medvid. Your input is invaluable to my effort to resolve this issue. The installer here told me it was a Sirius problem and not a problem with the Rosen unit itself. What your installer told you makes more sense since I haven't seen the problem on any other Sirius radios or it mentioned on any of the blogs for Sirius. Now I have some supporting information to go back to my dealer and ask them to have the installer fix my system once Rosen identifies the problem. I only hope that Rosen will fix the problem and not just let everyone live with it. I guess we will find out in coming weeks.

    Not sure how you like your Rosen system. I like some features, but others leave alot to be desired. I plan to give a more complete review of my experience with this when I get my problems resolved. Thanks again for your help.
  7. priuslt

    priuslt Junior Member

    Joined:
    May 25, 2011
    Messages:
    14
    Likes Received:
    0
    Location:
    il
    Your Vehicle Year:
    2011 Prius
    Model:
    III
    Hi, I have a question regarding rosen. Does it (FM radio) support even and odd numbers? E.g. 105.5; 105.6 etc.
    Thanks
  8. priuslt

    priuslt Junior Member

    Joined:
    May 25, 2011
    Messages:
    14
    Likes Received:
    0
    Location:
    il
    Your Vehicle Year:
    2011 Prius
    Model:
    III
Similar Threads: Problem Sirius
Forum Title Date
Gen II Prius Audio and Electronics Sirius Satellite Radio Installation Problems HELP!!! Nov 14, 2011
Gen II Prius Audio and Electronics Problem with sirius plug-n-play Dec 30, 2009
Gen II Prius Audio and Electronics Sirius (not serious) Problem Sep 17, 2008
Gen II Prius Audio and Electronics 08 Prius Sirius Questions/Problem Mar 1, 2008
Gen II Prius Audio and Electronics Problems with the Toyota Sirius Radio Kit... Feb 13, 2008