'05 HID into '07 that came with Halogens

Discussion in 'Gen 2 Prius Accessories & Modifications' started by Trukinbear, Jul 2, 2020.

  1. Trukinbear

    Trukinbear New Member

    Joined:
    Jun 17, 2020
    20
    3
    1
    Location:
    Klamath, CA
    Vehicle:
    2007 Prius
    Model:
    II
    Hi guys forgive me if this is a common question but I've searched and can't seem to find the answer for my exact situation. I see lots of guides about changing my HID's to Halogen or LED, that isn't what I'm trying to do - I want to do the opposite.

    Recently Lola (our '05) had after being hit and totaled four times (always while parked or stopped) was ready for retirement. I purchased Lana (an '07) with battery warnings, the triangle of death, etc, and 275,000 miles. Clean as a pin, well maintained. I've taken Lola's battery bank and put it into Lana after having to replace 4 blades last year, and all is well. My problem is, Lana didn't come with HID's and the PO installed horrid aftermarket LED's that I just can't stand no matter how I try to aim them. Lola just had both of her HID bulbs replaced in the last 2 years or so, they work flawlessly. I went to just swap out the housings, reflectors the whole deal from one car to the other, but I'll bet you guys already know what I found.

    My question, how do I do this, can I just swap the plugs out and manually aim them (I already do) or does the computer have to receive a go signal from the ride height sensor - I'm thinking it won't, but what else could I encounter?

    Thanks in advance,
    Trukinbear
    05 with HID, NAV, Stability, leather (from an 06) 255,900
    07 base 276994
     
  2. Trukinbear

    Trukinbear New Member

    Joined:
    Jun 17, 2020
    20
    3
    1
    Location:
    Klamath, CA
    Vehicle:
    2007 Prius
    Model:
    II
    Wow, I was hopeing someone might have some sort of information about what it takes to make my HID lights work... polarity? beam selection? anybody?

    Also why does this say I'm a newbie when I've been a member here for over a decade?
     
  3. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    5,873
    3,125
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    According to your profile, you joined Jun 18, 2020, have made 3 posts and post 1 photo, as of this writing.
     
  4. Leadfoot J. McCoalroller

    Leadfoot J. McCoalroller Senior Member

    Joined:
    May 12, 2018
    4,460
    4,404
    1
    Location:
    Pennsylvania
    Vehicle:
    2018 Prius c
    Model:
    Two
    The computer needs to see data from the ride height sensor, and it also needs to get data back from the individual headlight buckets to confirm that they were able to re-aim themselves based on the height sensor data. If a lamp cannot re-aim itself, it gets switched off until the next time you start the car to keep you from blinding anyone, as per federal regulation.

    Your car is missing a lot of what it would need to support the factory HID option. You could contemplate moving the body ECU and forward wiring harness over from your other car, but that's just a heap of work with little guarantee of success given slightly different years.

    You'll probably get a much better beam pattern by reverting back to halogen. Maybe not a great color, but at least it'll put the light where it is supposed to be.
     
  5. Trukinbear

    Trukinbear New Member

    Joined:
    Jun 17, 2020
    20
    3
    1
    Location:
    Klamath, CA
    Vehicle:
    2007 Prius
    Model:
    II
    Is there another big Prius forum?

    Here in #14 someone mentions my bright Yellow Prius.

    Orange Prius | PriusChat

    I tried searching for some of the write-ups I did in the day, back when I installed 3 custom boards in my (not yet) bright yellow 2005 Prius, or the write-up I did about tire size and speedometer error but I get too many results to find my stuff from over a decade back. Maybe the system updated somewhere along the line and everyone had to rejoin? If there IS another big Prius forum (though this is the one I have bookmarked) maybe I need to be there.

    As to the computer HID light issue. If I just run power to the lights they won't illuminate? If the car I put them in didn't have HID, or the connectors, how will it see them and turn them off if I simply hotwire them in?
     
  6. Trukinbear

    Trukinbear New Member

    Joined:
    Jun 17, 2020
    20
    3
    1
    Location:
    Klamath, CA
    Vehicle:
    2007 Prius
    Model:
    II
    I suppose I should have mentioned that by horrid LED conversion I mean they mangled the headlight buckets, I don't think a stock halogen will go back in there.

    I have a ride height sensor on the 05 that has been non-op since the 3rd rear end total accident, the HID's have still worked I've just had to aim them manually. They were aimed too high IMHO before, though that could have been from the ride height sensor being mangled over and over. Most cars on the road I wish I could pull over and show them how they are supposed to be aimed, boy do I miss auto inspections back when they checked the aim of your lights... and don't even get me started on the results from HID or LED in Halogen buckets. Sadly nobody polices blinding headlights but they'll pull you over for having one of your tag lamps out, go figure.

    Now my question is, do the units on the bottom of the buckets need to see ride hight info or they power off, or is that a function of one of the computers under the dash? Surely someone has tried to make Prius lights work in something else and knows the minimum needed for them to function?
     
Loading...