-06 head unit upgrade, disturbance noise over RCA

Discussion in 'Gen 2 Prius Audio and Electronics' started by MiRoXFin, Nov 7, 2021.

  1. MiRoXFin

    MiRoXFin New Member

    Joined:
    May 22, 2021
    8
    0
    0
    Location:
    Finland
    Vehicle:
    2006 Prius
    Model:
    N/A
    Hi! I installed an aftermarket head unit, ran 6-channel rca lines and speaker wires to the front doors. There is these annoying static distortion noises playing through the speakers when radio is on and amp is also on. Without rcas there isn't any noise. Is this common or is my wiring bad?
     
  2. mr_guy_mann

    mr_guy_mann Senior Member

    Joined:
    Sep 3, 2020
    1,206
    496
    0
    Location:
    NJ-USA
    Vehicle:
    2006 Prius
    Model:
    Four
    Sounds like you might have a ground loop problem between the head unit and amp. The "lazy" way to deal with that is to get RCA isolation transformers. People who know more / care more about audio gear probably have better solutions. (That ain't me.)

    Posted via the PriusChat mobile app.
     
  3. MiRoXFin

    MiRoXFin New Member

    Joined:
    May 22, 2021
    8
    0
    0
    Location:
    Finland
    Vehicle:
    2006 Prius
    Model:
    N/A
    Most of the noise was removed when i grounded the rca "minus" to the body of the car. There still is some but I can live with that. Next is going to be some sound deadening ;)
     
  4. Another

    Another Active Member

    Joined:
    Jun 22, 2021
    758
    182
    0
    Location:
    Naples, Florida
    Vehicle:
    2007 Prius
    Model:
    Touring
    RCA ground loop transformer US$10
    Amazon B077Y5DLBB

     
  5. MiRoXFin

    MiRoXFin New Member

    Joined:
    May 22, 2021
    8
    0
    0
    Location:
    Finland
    Vehicle:
    2006 Prius
    Model:
    N/A
    I've tried a "four connect" branded ground loop isolator and that didn't work..
     
    #5 MiRoXFin, Nov 16, 2021
    Last edited: Nov 16, 2021
  6. Another

    Another Active Member

    Joined:
    Jun 22, 2021
    758
    182
    0
    Location:
    Naples, Florida
    Vehicle:
    2007 Prius
    Model:
    Touring
    Maybe problem is in speaker cable
     
  7. MiRoXFin

    MiRoXFin New Member

    Joined:
    May 22, 2021
    8
    0
    0
    Location:
    Finland
    Vehicle:
    2006 Prius
    Model:
    N/A
    Yeah it must be.. Basicly everything else is done. I'll have to look into that at some point, thanks!
     
Loading...