2004 Intermittent NAV & Audio System... Help?

Discussion in 'Gen 2 Prius Audio and Electronics' started by plusaf, Apr 1, 2019.

  1. plusaf

    plusaf plusaf

    Joined:
    Feb 15, 2004
    322
    5
    0
    Location:
    Raleigh, NC
    Vehicle:
    2004 Prius
    Model:
    N/A
    A few months ago, my 2004 Prius was working fine, then suddenly, the "I Agree" automatic module didn't seem to work (Coastal Tech unit.)

    Audio became intermittent, with radio cutting in or out randomly, though sometimes power switch could turn it back on when it cut out. Occasionally, "Check The System" would appear in the middle of the screen and then just sit there.

    General characteristics seem to be VERY slow response to any inputs from dash buttons, steering wheel buttons or touch screen.

    Dealer couldn't find anything specific in their tests and estimated thousands of dollars for repair/replace.. much more than the Blue Book on the car... 2004 with just 80 k on the odometer.

    Help?! Where's the brains of that kind of malfunction located? Should I go a few hundred dollars for an after market unit? Everything else in the car works, and I don't want to replace it. I've converted all but a few lamps to LED and it runs and handles just fine, but without the NAV system, neither my wife nor I make it our first choice for most drives. Her 2012 Prius V is still just fine.

    Any suggestions would be appreciated. FYI, I'm also the guy who started the FB group for PriusTrailers, though I'm ready to sell the trailer now. No more long trips with big dogs for us! Happy Motoring, everyone!
     
  2. audiodave

    audiodave Active Member

    Joined:
    Feb 3, 2017
    643
    234
    0
    Location:
    US
    Vehicle:
    2004 Prius
    Model:
    Five
    I'd just change out the original stereo if that fixed that and deal with nav off my phone. If you can fix it yourself is one thing but paying someone else is another.

    Posted via the PriusChat mobile app.
     
    plusaf likes this.
  3. davecook89t

    davecook89t Active Member

    Joined:
    May 10, 2016
    586
    432
    0
    Location:
    Washington State, Florida
    Vehicle:
    2017 Prius
    Model:
    Four Touring
    It seems everyone on this forum always advises those of us who use the factory Nav system to just ignore it and use the Navigation on our phones when the one in the car acts up or gives bad information, but I (and I'm sure others on this site) like to have a large map right in front of me (or at least slightly to the side) and do not want to be fiddling with a phone while I'm driving. Even if I was able to mirror my phone on the MFD, I would prefer to use the one built into the car, if for no other reason than to avoid the data charges on the phone. Despite its limitations, many times I have found even the Nav on our Gen 2 (with its 12 year old maps) useful, if I really am lost and am not in a hurry to get somewhere.

    I believe we have the same Coastal Tech Lockpick system on our car as you do. (It was installed on the car before we bought it.) What I have noticed on a few occasions is that the voice on the Nav seems to be fainter than it should be. I can generally still hear it, but I know it is not at its normal volume. Then suddenly it will come back to normal. I never associated our volume issue with the Coastal Tech device that was wired into our system, but now that you mention Coast Tech, I believe that is what might be causing the slight malfunction with our Nav and the more serious one with your entire sound system. I think you would be well advised to take a look at the way the Lockpick was wired into your Nav system. That may be the root of your problems.
     
  4. plusaf

    plusaf plusaf

    Joined:
    Feb 15, 2004
    322
    5
    0
    Location:
    Raleigh, NC
    Vehicle:
    2004 Prius
    Model:
    N/A
    I thought the Coastal Tech 'I Agree Bypass' might have gone intermittent or temperature-sensitive, but removing it made no difference.

    NAV isn't the problem in my Prius since I put Google Maps on my Galaxy 6 from Samsung.

    Problem is: mpg, audio, and everything ELSE is intermittent!
    What's not clear is WHERE that is happening.... in the Display unit in the dash or in the DVD unit under the driver's seat!

    THAT can help me choose where to start replacing stuff. I've got the CD/Cassette/AM/FM option in the car. if that matters.
    Thanks, davecook89t!
     
  5. davecook89t

    davecook89t Active Member

    Joined:
    May 10, 2016
    586
    432
    0
    Location:
    Washington State, Florida
    Vehicle:
    2017 Prius
    Model:
    Four Touring
    Is Techstream reporting any problems? In particular, I wonder if the Body Electrical Tab might show something that would help you. Possibly you need to replace the Multi Function Display unit. You could source the 7 button unit online or from a wrecker.
     
    plusaf likes this.
  6. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    2,683
    3,164
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring
    Are you sayng that the MFD itself is flickering on/off? MFD failure is fairly common. Many times they'll start to randomly go black, then reboot. Anytime the MFD goes out, audio is also lost. The one in my 2007 did this for a couple months before going totally dark. Replaced it with an exact match that I happened to have in the shop (from a truckload of parts I purchased from a guy who disassembled an entire 2007) and all the problems went away.

    I actually gave my old MFD away about a month or so ago, to someone who needed a new screen. Pretty sure my failure was in the electronics section. Of course, now my son's car is having MFD screen problems, lol.
     
    #6 TMR-JWAP, Apr 2, 2019
    Last edited: Apr 2, 2019
    plusaf and davecook89t like this.
  7. plusaf

    plusaf plusaf

    Joined:
    Feb 15, 2004
    322
    5
    0
    Location:
    Raleigh, NC
    Vehicle:
    2004 Prius
    Model:
    N/A

    Thank you! After watching several of the MFD replacement videos on Youtube, I'm starting to conclude that the 'problem' is probably in the MFD and the CD/Tape player is not involved. For the prices I've seen on eBay, etc., I think I'll start looking for a replacement display. I've been into the dash several times, including installing a flasher unit to handle the LED directionals, so I feel confident in trying that.

    Thank you all for your suggestions!
    I'll report success or failure in the future, but "things don't happen fast around my house, so... :) "
     
    davecook89t likes this.
Loading...