2004 Prius ABS light on

Discussion in 'Gen 2 Prius Technical Discussion' started by dakao, May 16, 2011.

  1. dakao

    dakao New Member

    Joined:
    May 16, 2011
    16
    0
    0
    Location:
    texas
    Vehicle:
    2004 Prius
    Model:
    N/A
    Hello all,
    My 04 Prius ABS light came 8 months ago so I reset the computer by removed the 12V accessory battery terminal for 10 min. and put it back on to clear the ABS light and the car ran fine for 8 mos. but now it came back on again so I did the same thing and evrything is clear and running OK too.
    I just wonder if anyone has the same or seen this problem ??
    Thanx
     
  2. seilerts

    seilerts Battery Curmudgeon

    Joined:
    Mar 7, 2010
    3,326
    1,495
    38
    Location:
    Santa Fe, NM
    Vehicle:
    2005 Prius
    The fact that it will clear makes it sound like an intermittent sensor problem (wheel speed, yaw rate, etc.). This happens across all Toyotas, if not all cars in general. The next time it happens, pull the code and post it here. You can get the codes by jumpering the OBD connector and reading the flash codes for ABS, VSC, and brake ((!)).
     

    Attached Files:

    • abs2.gif
      abs2.gif
      File size:
      6.4 KB
      Views:
      1,792
  3. jdenenberg

    jdenenberg EE Professor

    Joined:
    Nov 21, 2005
    3,481
    1,542
    1
    Location:
    Trumbull, CT
    Vehicle:
    2020 Prius
    Model:
    LE AWD-e
    Do all your tires have the same circumference? If not that can cause an ABS flag.

    JeffD
     
  4. dakao

    dakao New Member

    Joined:
    May 16, 2011
    16
    0
    0
    Location:
    texas
    Vehicle:
    2004 Prius
    Model:
    N/A
    Yeah, You might be right about this. Because I think my front tires are 195-65-15 instead of 185-65-15. My rear tires are correct size that came with the car. I will buy new tires and see this problem come back.
    thanx
     
  5. dakao

    dakao New Member

    Joined:
    May 16, 2011
    16
    0
    0
    Location:
    texas
    Vehicle:
    2004 Prius
    Model:
    N/A
    Well it didn't last long this time, the ABS light came back on yesterday with beeping noise and now the battery removal trick no longer work either. Got the code C1252, C1253 and C1256. The brake pedal is hard and the car doesn't want to stop.
    I think the ABS pump is gone... huhuhuuhu
     
  6. seilerts

    seilerts Battery Curmudgeon

    Joined:
    Mar 7, 2010
    3,326
    1,495
    38
    Location:
    Santa Fe, NM
    Vehicle:
    2005 Prius
    Check the ABS MTR relays before surrendering :(
     
  7. vertex

    vertex Active Member

    Joined:
    Mar 27, 2009
    669
    138
    0
    Location:
    new york
    Vehicle:
    2018 Prius Prime
    Model:
    Prime Plus
    I had the same problem. There has been a lot of rain lately here. After a day, I cleared the codes, and the car works fine. This happened to me once before. I believe water is getting into the connetors on the brake controller.
     
Loading...