2007 knocking and battery not charging

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Dereko, Nov 8, 2019.

  1. Dereko

    Dereko Junior Member

    Joined:
    Aug 12, 2016
    17
    4
    0
    Location:
    Missouri
    Vehicle:
    2005 Prius
    Model:
    II
    Was driving the car it started knocking pretty bad and at the same time the hybrid battery won’t charge much unless your coasting
    Oil level is correct, I changed the spark plugs to see if it would help and it did not

    any ideas?
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    83,704
    36,622
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    no dash lights?

    how many miles on her?
     
  3. George W

    George W Active Member

    Joined:
    Mar 12, 2018
    442
    227
    1
    Location:
    San Antonio
    Vehicle:
    2008 Prius
    Model:
    Touring
    Do you use any code readers or scan tools?
     
  4. Dereko

    Dereko Junior Member

    Joined:
    Aug 12, 2016
    17
    4
    0
    Location:
    Missouri
    Vehicle:
    2005 Prius
    Model:
    II
    No dash lights

    I plugged in my scan tool and nothing is coming up
     
  5. Dereko

    Dereko Junior Member

    Joined:
    Aug 12, 2016
    17
    4
    0
    Location:
    Missouri
    Vehicle:
    2005 Prius
    Model:
    II
    255000 and no lights
     
  6. George W

    George W Active Member

    Joined:
    Mar 12, 2018
    442
    227
    1
    Location:
    San Antonio
    Vehicle:
    2008 Prius
    Model:
    Touring
    Could the car be starved of fluids on a cold morning? Last date of maintenance?
     
  7. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    83,704
    36,622
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    coolant level okay?
     
  8. Dereko

    Dereko Junior Member

    Joined:
    Aug 12, 2016
    17
    4
    0
    Location:
    Missouri
    Vehicle:
    2005 Prius
    Model:
    II
    I just changed the oil 1000 miles ago, even after warm up it’s not any better
     
  9. Dereko

    Dereko Junior Member

    Joined:
    Aug 12, 2016
    17
    4
    0
    Location:
    Missouri
    Vehicle:
    2005 Prius
    Model:
    II
    yes it’s good
     
  10. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    83,704
    36,622
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    maybe an engine bearing
     
  11. Landon51

    Landon51 Member

    Joined:
    Apr 18, 2018
    145
    51
    0
    Location:
    US
    Vehicle:
    2007 Prius
    Model:
    Two
    mine is doing the same thing down to the charging problem.

    i have changed spark plugs re-manufactured injectors and finally (later today), coild from Amazon that have many good reviews but aren't Denzo).

    I'll also be installing an oil catch can today or tomorrow. hopefully that will fix it.

    Posted via the PriusChat mobile app.
     
  12. George W

    George W Active Member

    Joined:
    Mar 12, 2018
    442
    227
    1
    Location:
    San Antonio
    Vehicle:
    2008 Prius
    Model:
    Touring
    If you're installing a catch can you need to also start with clean MAS and throttle-body
     
  13. Landon51

    Landon51 Member

    Joined:
    Apr 18, 2018
    145
    51
    0
    Location:
    US
    Vehicle:
    2007 Prius
    Model:
    Two
    This seemed to do it. I'll drive it a week and make sure, but it seems to be fixed. no more shaking or missing. i had to change the big three: Sparks, injectors and coils.

    Posted via the PriusChat mobile app.
     
  14. Landon51

    Landon51 Member

    Joined:
    Apr 18, 2018
    145
    51
    0
    Location:
    US
    Vehicle:
    2007 Prius
    Model:
    Two
    i cleaned my throttle body.

    Posted via the PriusChat mobile app.
     
Loading...