2007 Prius - That age-old HID issue...

Discussion in 'Gen 2 Prius Technical Discussion' started by cwoodr91, Jul 10, 2015.

  1. cwoodr91

    cwoodr91 Junior Member

    Joined:
    Jul 10, 2015
    7
    0
    0
    Location:
    Boston
    Vehicle:
    2007 Prius
    Model:
    N/A
    Hi there,
    I've got a 2007 Prius Touring and have been experiencing that well-documented issue with the HID. Namely, the driver side cuts out after a few minutes of being on. If I flip the lights off and on again it will come back, but will inevitably go out again.

    Last summer, I removed the assembly and dumped out about a half a cup of water, and drilled a small hole to create air circulation to dry it out completely. That didn't solve the problem so I did more research. I just replaced the ballast (which was corroded as hell), and that didn't solve the problem either (to my great disappointment). I found a salvage yard that has the whole assembly from a 2008, and I'm about to try that. If even that doesn't work, then I guess it has to be a shoddy power supply from the car, correct? And, in this situation, what can be done, if anything?

    Has anyone else had this issue to this extent? All I've been able to find are folks who replaced the ballast, or who fell into the extended warranty period that Toyota so graciously enacted back in 2011 (needless to say, my car does not meet their criteria anymore).

    Thanks!
    Chris
     
  2. Patrick Wong

    Patrick Wong DIY Enthusiast

    Joined:
    Mar 8, 2008
    17,111
    4,998
    0
    Location:
    Green Valley, AZ
    Vehicle:
    2015 Prius
    Model:
    Two
    I think that it is more likely that the HID bulb needs to be replaced.

    The ballast is the high voltage power source for the HID bulb.
     
  3. Bill Gibson

    Bill Gibson New Member

    Joined:
    Feb 18, 2018
    10
    1
    0
    Location:
    NORTH CAROLINA
    Vehicle:
    2007 Prius
    Model:
    Premium
     
  4. Bill Gibson

    Bill Gibson New Member

    Joined:
    Feb 18, 2018
    10
    1
    0
    Location:
    NORTH CAROLINA
    Vehicle:
    2007 Prius
    Model:
    Premium
    What did you find out? Did you fix this problem and what was the fix?
     
  5. srellim234

    srellim234 Senior Member

    Joined:
    Jun 26, 2015
    703
    704
    0
    Location:
    Alta Loma, California
    Vehicle:
    2008 Prius
    Model:
    Touring
    After having the first problem with the lights in January I discovered I had water issues as well. Fortunately there were no signs of corrosion or rust but I bit the bullet anyway and preventatively replaced the driver's side assembly, bulb AND ballast with OEM parts all at the same time. It's only been a few weeks but so far, so good. If it acts up again I'll take a serious look at an HID to LED conversion.

    Chris, if there was a lot of corrosion around the ballast is there an easily visible way to replace or splice wires around the ballast connections? The corrosion may have extended into the surrounding area.
     
    #5 srellim234, Feb 21, 2018
    Last edited: Feb 21, 2018
  6. Bill Gibson

    Bill Gibson New Member

    Joined:
    Feb 18, 2018
    10
    1
    0
    Location:
    NORTH CAROLINA
    Vehicle:
    2007 Prius
    Model:
    Premium
    I've seen so many issues with the fix for the 2007 Prius, and since I'm not very good as a fix-it guy, I went to Fred Anderson Toyota on Glenwood Ave. in Raleigh, NC and paid them $482.09 to change the two HID light bulbs. I did that on 3-08-18 and so far they're working fine.
     
    srellim234 likes this.
Loading...