1. Attachments are working again! Check out this thread for more details and to report any other bugs.

2008 Gen 2 triangle of death, engine turns off, battery and other symbols light up

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by Jon Good, Oct 27, 2022.

  1. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    i’m glad this website and forum exists, thanks to whoever maintains it and thank you for the answers in advance.

    my problem I have a 2008 Toyota Prius gen 2 with approximately 100K..

    last week I’ve had two instances of the triangle of death and multiple dashboard problem indicator lights.. i’ve included a picture I snapped as it happened the last time.

    I’ve checked the 12 V battery on standard ready and the voltage is around 12.. dips down to 10.5 on start up and then to 13.8 where it stays. I haven’t driven it in a few days and I’ve done this twice in the mornings.. The battery appears to be fine in the car starts up right away without any warning lights.. which having appeared for a few days.

    I checked the inverter coolant pump and it vibrates itself but I can’t feel a vibration in the hoses especially the one leading to the reservoir which I checked and barely see any movement maybe from the engine just being on .. no real discernible movement though.

    The hybrid battery doesn’t seem to be affected.. is charged.. discharges and holds a charge.

    I did drive it to O’Reillys and checked out their scanner tool and hooked it up and it couldn’t communicate with my car .. no warning lights were on at the time.

    not sure what’s going on -any theories?
    thanks in advance ..and I will post any fixes.
     

    Attached Files:

  2. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    9,134
    1,586
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    Wow that's interesting to see I have an '09 still a generation too and I've had every code in the book I've replaced the hybrid battery all that car runs perfectly but I have never seen that battery and that other icon over the top of my consumption meter and the green car which usually when anything is wrong that involves certain things that green car turns red but I've never seen icons over top of it interesting
     
  3. ChapmanF

    ChapmanF Senior Member

    Joined:
    Mar 30, 2008
    24,012
    15,614
    0
    Location:
    Indiana, USA
    Vehicle:
    2010 Prius
    Model:
    IV
    It's all icons over top of it.

    The "green car" is just part of the artwork of the usual MFD display pages, happens to be in the top left corner:

    [​IMG]

    When it "turns red", that's a red car icon that pops up over the top left corner of whatever page is showing:

    [​IMG]

    It's not the only icon that can show up there;

    [​IMG]
     
  4. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    9,134
    1,586
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    That's how I know there's something wrong with my 2009 but I have no idea what it is when I had all those codes and the ABS was messed up and blah blah blah my MFD never displayed any of that none of it The red car or the turtle has only been read when the inverter pump goes bad and that's it It might have gone red when the hybrid battery was down to nothing and we were driving the car to get a new one but my MFD has never showed anything The only warning I've ever gotten on the MFD is stop on the level surface usually because the door's open or something.
     
  5. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    Um.. so it might be the inverter pump or the hybrid battery or you don’t know?
     
  6. dolj

    dolj Senior Member

    Joined:
    May 14, 2012
    7,655
    3,867
    0
    Location:
    Wellington, New Zealand
    Vehicle:
    2007 Prius
    Model:
    N/A
    It's hard to know what Tom's posts are trying to say a lot of the time. LOL.

    As to your issues, the battery icon on your MFD is the Charging system warning light. The other one (the car one) is the Hybrid system warning light. This would seem consistent with your inverter coolant pump has either failed or is running but not pumping sufficient volume.

    If you want to check your pump without engine vibrations, the pump runs in IG-ON which you get to by pressing the power button twice with your foot off the brake pedal (from OFF). The movement should be quite obvious if the pump is pumping a sufficient volume.

    Of course, obtaining the codes would be good so that you can confirm your symptoms. I'd expect to see at least a P0A93 which is set when the inverter has cooling issues.

    I hope that helps.
     
  7. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    Thank you, you’ve given me a little peace of mind. I did order a Bluetooth OBD2 scanner tool, I have the Dr. Prius app on my phone and I’ve also ordered an inverter coolant pump. I’ll post next week and in the coming weeks.
     
    #7 Jon Good, Oct 28, 2022
    Last edited: Oct 28, 2022
  8. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    9,134
    1,586
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    That's correct because I have eliminated my standard inverter pump to a pump that may take a long time to fail so I may not see the turtle go red for a long long time I am not positive that that energy monitor green car or turtle turned red when the hybrid battery was in a complete crap state as in getting 37 mi to the gallon and the electric system basically not working at all as far as MG1 and 2 maybe regenerative braking and all was happening but it wasn't doing any good because the battery was shot it couldn't take the juice but I don't think the energy monitor was red All the lights were on on the dash and everything else was happening that's not supposed to but the turtle or green car remained green The only time I can remember seeing that turn red is when the inverter pump was failed not pumping and I was not overheating that inverter pump water yet it was still cool to the touch but because the pump wasn't running the light comes on the car turns red that's what I remember in my generation too this is all been very recently
     
  9. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    Thanks Tombukt2, I’ll check it out.
     
  10. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    I got the OB2 Bluetooth scanner today and it kept not wanting to connect after putting it into the port below the steering wheel.. but I finally jammed it in there really really good and it worked.

    I found no engine codes with the Dr. Prius app.. which is odd because I thought they would be stored in the vehicle somewhere especially since the vehicle turned off while driving with the dash lit up like a Christmas tree. Hmmm..

    I also did a battery analysis.

    i’ve uploaded some pictures.

    Does anybody see anything interesting or have theories?
     

    Attached Files:

  11. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    Also I forgot to add I’ve been driving the car around for the last week and the triangle of death has yet to reappear.
    I’m going to get the new inverter coolant pump in the next few days and install it.
     
  12. mr_guy_mann

    mr_guy_mann Senior Member

    Joined:
    Sep 3, 2020
    3,470
    1,514
    0
    Location:
    NJ-USA
    Vehicle:
    2006 Prius
    Model:
    Four
    Did you "check battery codes"? Most faults with the hybrid system would set codes in the Hybrid Control ecu or the High Voltage Battery ecu. Dr Prius is nice for what it does (viewing HV battery voltages), but is limited. It can read and clear engine & (mostly) HC/HVB codes. Dr Prius sort of treats HC & HVB as a single system and sometimes doesn't see alcodes correctly.

    You would need a more capable scantool if you need to do more (or to work on other systems on your Prius)

    Posted via the PriusChat mobile app.
     
  13. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    Thanks I will check on that.. what’s a more capable scan tool for a 2nd gen Prius?
     
  14. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    9,134
    1,586
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    I've noticed my Innova w ABS button . Reads all my P codes and my abs codes . I have tec stream but I've been using my Innova Alot no computer needed .
     
  15. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    This scanner?
     

    Attached Files:

  16. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    9,134
    1,586
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    Yes that's better than mine so should do well .
     
  17. Tombukt2

    Tombukt2 Senior Member

    Joined:
    Nov 29, 2020
    9,134
    1,586
    0
    Location:
    Durham NC
    Vehicle:
    2009 Prius
    Model:
    Base
    I don't see the ABS button on this model. My lesser model has its red button . But this is same company . Mines a few years old
     
  18. mr_guy_mann

    mr_guy_mann Senior Member

    Joined:
    Sep 3, 2020
    3,470
    1,514
    0
    Location:
    NJ-USA
    Vehicle:
    2006 Prius
    Model:
    Four
    https://priuschat.com/index.php?posts/3290690

    Here's a thread reviewing several scantool apps and OBD devices. The 4 at the bottom of the list will scan all systems on a Gen2 Prius for codes and data.


    Posted via the PriusChat mobile app.
     
  19. mr_guy_mann

    mr_guy_mann Senior Member

    Joined:
    Sep 3, 2020
    3,470
    1,514
    0
    Location:
    NJ-USA
    Vehicle:
    2006 Prius
    Model:
    Four
    Another option is getting TechStream, the dealer's pc based diagnostic software + a Vehicle Communication Interface
    cable. The legit way is to get a cable (can be several $ hundred) then buy a subscription ($60 for 3 days?) & download the TS software from Toyota and install it on a windows laptop.

    There are bootleg copies of TS on amazon and ebay that come with a clone of a clone VCI cable. Can be sketchy to install and get working. All are hacked somehow to bypass the TS activation key.

    You can search the Technical Discussion forum for "Techstream" & "VM" for a thread about downloading a virtual machine image file that has TS installed in it. Get a VCI cable, put Oracle VirtualBox on your laptop or macbook, and load the image file.

    Posted via the PriusChat mobile app.
     
  20. Jon Good

    Jon Good New Member

    Joined:
    Oct 27, 2022
    20
    3
    0
    Location:
    Seattle
    Vehicle:
    2008 Prius
    Model:
    Two
    Ok thanks I’ll check it out. I’m eager to eventually, hopefully become better at maintaining this gen 2 Prius of mine. I’ve got much to learn.