2009 check engine , hybrid battery lights came and gone 2 weeks

Discussion in 'Gen 2 Prius Care, Maintenance and Troubleshooting' started by vasu, Feb 1, 2019.

  1. vasu

    vasu New Member

    Joined:
    Feb 1, 2019
    1
    0
    0
    Location:
    irvine
    Vehicle:
    2009 Prius
    Model:
    III


    i have a 2009 Toyota Prius 173K miles.

    got check engine , hybrid battery lights came and gone after 2 weeks .

    got the code
    Prius p0a80 code "Replace Hybrid Battery"
    tested 12v is good.

    car runs fine.
    mileage and dashboard show battery capacity are same as before 46-48 mpg.

    After 2 weeks suddenly, all the warning lights gone

    I am happy but why and how this happens. should i be concerned.
     
  2. edthefox5

    edthefox5 Senior Member

    Joined:
    Jul 25, 2007
    8,548
    3,915
    0
    Location:
    Clearwater, Florida
    Vehicle:
    2007 Prius
    Model:
    Two
    Yes be concerned. It does not throw that code for nothing. There's probably alot of corrosion on the internal battery system interconnect and we are seeing reports of corrosion on the ecu plug socket also.

    So start thinking about getting that battery serviced or at the very least take the cover off it and see how bad its corroded.
     
    Raytheeagle and SFO like this.
  3. JC91006

    JC91006 Senior Member

    Joined:
    Nov 10, 2013
    14,395
    7,166
    0
    Location:
    Los Angeles, CA
    Vehicle:
    2010 Prius
    Model:
    V
    I just had a hv battery fail and coded p0a80. This is a 2010 battery from my 2005 car. I removed the battery and noticed a very slight voltage difference in the failing block module (module in block 10). Although the voltage still shows the module as being good, when it's in the car, the car will pick up the voltage difference from the weaker module and throw a failing code.

    The car still would work with this module and occasionally throw the triangle, but I would rather switch it out as it will eventually fail completely
     
Loading...