2010 Acceleration delay with knockback

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by dulguun t, Dec 4, 2019.

  1. dulguun t

    dulguun t New Member

    Joined:
    Dec 4, 2019
    3
    1
    0
    Location:
    seattle
    Vehicle:
    2010 Prius
    Model:
    Three Touring
    Hello, this is my first time posting here.
    So, I have 2010 prius and when I accelerate at low speeds, like below 40mph, I get this strange acceleration delay (no power for 1-2 seconds) and car gets little knockback that I can feel every time it happens. This doesn't happen everytime, but often. Accelerating from dead stop on uphill is best trigger for this problem. Highway speed, it rarely happens. There is NO check engine light and hybrid battery is fine. Any tips and advice? Thank you
    Things I tried to fix this problem: Unclogged and cleaned EGR valve sensor and cleaned mass airflow sensor with mass airflow sensor cleaner.
    240k miles
     
  2. tankyuong

    tankyuong Senior Member

    Joined:
    Nov 9, 2012
    1,123
    460
    0
    Location:
    Central MO
    Vehicle:
    2010 Prius
    Model:
    III
    Did you take the egr cooler out to clean?
     
  3. dulguun t

    dulguun t New Member

    Joined:
    Dec 4, 2019
    3
    1
    0
    Location:
    seattle
    Vehicle:
    2010 Prius
    Model:
    Three Touring
    Yes, I stabbed every hole in mesh with long thin iron rod and washed it.
     
  4. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    84,646
    37,231
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    welcome!
    whats the history and regular maintenance?
     
  5. dulguun t

    dulguun t New Member

    Joined:
    Dec 4, 2019
    3
    1
    0
    Location:
    seattle
    Vehicle:
    2010 Prius
    Model:
    Three Touring
    thanks for reading. I recently acquired this car, and I don't know about maintenance history. I know this car has been used for uber.
    All I did was unclog EGR cooler and clean mass airflow sensor.
     
    bisco likes this.
  6. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    84,646
    37,231
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    i'm amazed there are no dash lights. i would review the egr cleaning threads, check @NutzAboutBolts youtube and see if you did eevrything properly.

    what about filters/plugs/coils/injectors/ etc.?
     
    NutzAboutBolts likes this.
  7. NutzAboutBolts

    NutzAboutBolts Senior Member

    Joined:
    Mar 5, 2013
    1,429
    1,428
    0
    Location:
    Bay Area
    Vehicle:
    2012 Prius
    Model:
    Four
    I’d clean the throttle body too, a sticky throttle body can cause a delay in acceleration, knock back can be other issues. I’d do all the cleaning maintenance and see if it’ll help.
     
Loading...