2010 prius cruise control causing stall

Discussion in 'Gen 3 Prius Technical Discussion' started by orangekoala, May 27, 2019.

  1. orangekoala

    orangekoala New Member

    Joined:
    May 27, 2019
    2
    0
    0
    Location:
    Ontario
    Vehicle:
    2010 Prius
    Model:
    Touring
    I noticed during cruise control, every now and then there would be this small stall, or sudden short brake.

    Yesterday it did the same thing on the high way except the stall/brake felt stronger and the cruise control shuts off and the entire dash warning lights turns on, it made 2 beep noises that sounded like when I started the car into ready mode. 2 seconds later while it coasted on the highway, everything went back normal. These little stalls don't seem to happen when CC is off. It happened about 50km with cc on, and I was able to drive the rest of the 350km with CC off like normal.

    It currently has 160600 KM on it, last thing I had done it was the recall software update for the High Voltage and replacement of the rear-left speed sensor + hub and bearing, the sensor failed last month and cause the hybrid system to shut down.

    Can these problems be used has an excuse to buy the new rav4 hybrid? :x
     
  2. Mendel Leisk

    Mendel Leisk Senior Member

    Joined:
    Oct 17, 2010
    39,293
    27,961
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    I've got the same year, Touring package also, fwiw. Haven't noticed anything, about 1/2 the KM's as yours. I took a quick look through this attachment, couldn't find the word "stall", but have a read; you might find something.
     

    Attached Files:

  3. Maarten28

    Maarten28 Active Member

    Joined:
    Jul 13, 2014
    360
    176
    1
    Location:
    Netherlands
    Vehicle:
    2011 Prius
    Model:
    Three
    If all warning light go on it looks like the car shuts of momentarily. I would suspect the on/off switch then.
    My initial thought was that it could be caused bij the adaptive cruise control. It sometimes happens that it thinks it detects something that is not there and wil start decellerating or braking or it will throw the anchors out and display a message on the screen.
    But if you don't have ACC that can not be it and it certainly does not light up any of the orange or red warning lights.
     
  4. orangekoala

    orangekoala New Member

    Joined:
    May 27, 2019
    2
    0
    0
    Location:
    Ontario
    Vehicle:
    2010 Prius
    Model:
    Touring
    Could it be the 12volt? It would be 9 years old soon, but everything starts up fine. The low beam light is dim, I'll replace them. One of them suddenly stopped working, but I slapped it and it turned back on.
     
  5. Mendel Leisk

    Mendel Leisk Senior Member

    Joined:
    Oct 17, 2010
    39,293
    27,961
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    It's very likely OP's cruise is the simple, traditional cruise, not adaptive radar cruise. We both are 2010 CDN Touring level, and mine is thus. The Tech level has adaptive cruise, fwiw.
     
  6. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    87,484
    38,941
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    you should install a new 12v anyway, then go from there.

    when it happens again, read the trouble codes with tech stream
     
    Mendel Leisk likes this.
  7. Mendel Leisk

    Mendel Leisk Senior Member

    Joined:
    Oct 17, 2010
    39,293
    27,961
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    Oh wait a sec: it's the original 12 volt? Yeah, time to turf that. Unless the RAV4 siren call becomes too loud...
     
Loading...