2010 Prius Rattle/Knock Help

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by Vince R., Jun 26, 2018.

  1. Vince R.

    Vince R. New Member

    Joined:
    Jun 25, 2018
    5
    0
    0
    Location:
    SoCal
    Vehicle:
    2010 Prius
    Model:
    IV
    My 2010 Prius with 165k miles started to rattle/knock when accelerating about a month ago. Since then, every time the ICE starts it rattles. I have no CEL but have had pending codes of P0302. The engine does not use oil (changed every 7500mi or less), nor does it loose coolant. I have cleaned the MAF, EGR valve, tube, cooler, intake manifold, and throttle body. I have replaced the plugs and PCV valve. Conducted spark test (good), compression test (good), Tested the EGR (20.8 ohm), MAF (1.76KOhm @ 85 degrees F), Injectors (13.3 to 13.5 ohm at 90 degrees F), Coil voltage is good. Swapped coil 2 with coil 4 and no pending codes to tell if the problem followed coil 2.

    Any help diagnosing my problem would be greatly appreciated.

    Thank You!!!


    BTW - I posted this in another thread and it got lost in the shuffle.
     
  2. cnc97

    cnc97 Senior Member

    Joined:
    Mar 13, 2018
    1,081
    1,242
    28
    Location:
    Evansville, IN
    Vehicle:
    2010 Prius
    Model:
    Three
    This is likely the same knock that plagues the 2010 MY. PCV hose has filled manifold below throttle body with the PCV vapors. They cool and turn to liquid. On ICE start, they get sucked into engine. Resulting in a knock for a few seconds. Clean out manifold. Add catch can to PCV hose. The knock will go away. Mine has been silent for 3300 miles. My Prius has 213k on it.
     
    mjoo likes this.
  3. cnc97

    cnc97 Senior Member

    Joined:
    Mar 13, 2018
    1,081
    1,242
    28
    Location:
    Evansville, IN
    Vehicle:
    2010 Prius
    Model:
    Three
    Also, if available buy ethanol free gasoline. I am getting consistent 60 mpg in town since my change to E0.
     
  4. Vince R.

    Vince R. New Member

    Joined:
    Jun 25, 2018
    5
    0
    0
    Location:
    SoCal
    Vehicle:
    2010 Prius
    Model:
    IV
    Thank You for the info....looks like a catch can is in my future.
     
  5. Vince R.

    Vince R. New Member

    Joined:
    Jun 25, 2018
    5
    0
    0
    Location:
    SoCal
    Vehicle:
    2010 Prius
    Model:
    IV
    Thank You, I didn’t think of non-ethanol gas. I will search for that in my area. I am in So-Cal so it may be difficult. Thanks again!!
     
  6. Arnel Santiago

    Arnel Santiago New Member

    Joined:
    Jul 9, 2018
    6
    7
    0
    Location:
    Daly City
    Vehicle:
    2010 Prius
    Model:
    Three
    You did a lot of troubleshooting prior. Did the oil catch can work? Looks like replacing the PCV is not enough.
     
  7. Tcortez

    Tcortez Junior Member

    Joined:
    Jan 1, 2016
    25
    42
    0
    Location:
    Lancaster
    Vehicle:
    2010 Prius
    Model:
    IV
    Did you ever fix the car
     
  8. Tcortez

    Tcortez Junior Member

    Joined:
    Jan 1, 2016
    25
    42
    0
    Location:
    Lancaster
    Vehicle:
    2010 Prius
    Model:
    IV
    Did you ever get the car fixed , I’m having the same issues.
     
  9. Tcortez

    Tcortez Junior Member

    Joined:
    Jan 1, 2016
    25
    42
    0
    Location:
    Lancaster
    Vehicle:
    2010 Prius
    Model:
    IV
    0B5B9F76-584A-47C5-A2CF-EE9064E0B21E.jpeg I found my issue , I bought a cheap iPhone boroscope and found cylinder #2 has coolant in it. I guess I have a blown head gasket, the car has 220,000 miles , I went to Autozone and bought some K seal, the car runs great when running , I’ve been losing a little bit of coolant every night. Time to sell this car.
     
    mikey_t likes this.
  10. wheezyglider

    wheezyglider Active Member

    Joined:
    Mar 12, 2011
    130
    105
    0
    Location:
    SF Bay Area
    Vehicle:
    2010 Prius
    Model:
    Five
    Ouch that hurts. Clear diagnosis though - thanks for posting that picture. I also scoped mine and they look waaaay dirtier at 135,000 miles. No coolant for me, just carbon. If you get it rebuilt let us know the cost and results. But I wouldn't blame you for moving on.
     
  11. FnRedPrius

    FnRedPrius Member

    Joined:
    Jan 10, 2019
    91
    113
    0
    Location:
    Pilot, NC
    Vehicle:
    2010 Prius
    Model:
    III
    The Kseal will migrate to the cat converter and screw that up (I've heard). I've seen bunches of Gen 4 engines on FleaBay and help is everywhere.
     
  12. Tcortez

    Tcortez Junior Member

    Joined:
    Jan 1, 2016
    25
    42
    0
    Location:
    Lancaster
    Vehicle:
    2010 Prius
    Model:
    IV
    So far no start up knocking since pouring in K Seal in the coolant container. I’ll keep you guys posted , I’ve been monitoring my coolant temps and it looks good with a scanner , temp around 196 f going up the freeway, My car doesn’t over heat and not losing coolant anymore. Since I bought the car 4 years ago used it’s been a good car and has never left me stranded , the only change I have done is replace the 12 volt battery. Since pouring in the k seal I have no white smoke coming out during start up. I have also installed a oil catch can. I’m actually thinking of replacing the head gasket , I see a diy head gasket replacement on YouTube.
     
    Raytheeagle and The Critic like this.
  13. The Critic

    The Critic Resident Critic

    Joined:
    Oct 28, 2005
    3,007
    2,009
    0
    Location:
    CA
    Vehicle:
    2011 Prius
    Model:
    Three
    Can you post a link to the boroscope that you used? The photo quality looks awesome compared to the one I have on my Autel.
     
    Raytheeagle likes this.
  14. Tcortez

    Tcortez Junior Member

    Joined:
    Jan 1, 2016
    25
    42
    0
    Location:
    Lancaster
    Vehicle:
    2010 Prius
    Model:
    IV
    This is The boroscope I used

     
    RMB, Raytheeagle and The Critic like this.
  15. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    9,817
    13,357
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    That’s what I have:).

    Compliments of @Pedal Logic ;).

    Works great(y).
     
    RMB likes this.
  16. cnc97

    cnc97 Senior Member

    Joined:
    Mar 13, 2018
    1,081
    1,242
    28
    Location:
    Evansville, IN
    Vehicle:
    2010 Prius
    Model:
    Three
    I can’t see the link to the borescope. WAAAA! LoL
     
  17. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    9,817
    13,357
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    It’s a Depstech:).
     
    The Critic likes this.
  18. cnc97

    cnc97 Senior Member

    Joined:
    Mar 13, 2018
    1,081
    1,242
    28
    Location:
    Evansville, IN
    Vehicle:
    2010 Prius
    Model:
    Three
    I need that. There’s my next impulse buy!
     
    Raytheeagle likes this.
  19. spiralhelix

    spiralhelix Active Member

    Joined:
    Mar 15, 2019
    238
    193
    0
    Location:
    Illinois
    Vehicle:
    2011 Prius
    Model:
    Three
    Ha, I got that same one last year to see drain clogs! Unfortunately it’s not great for drains :(. I was thinking I need a 3D printed device to keep it out of the liquid and help with pipe bends. Sorry, /endofthreadjacking


    -Spiral
     
  20. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    9,817
    13,357
    0
    Location:
    Bay Area, California
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    I’ve used it a handful of times and it’s great :).

    Pairs well with an iPhone ;).

    Nice addition to the tool box(y).
     
Loading...