1. Attachments are working again! Check out this thread for more details and to report any other bugs.

2012 Prius C running lean issue

Discussion in 'Prius c Care, Maintenance and Troubleshooting' started by AlHepburn, Dec 2, 2023.

  1. AlHepburn

    AlHepburn New Member

    Joined:
    Dec 2, 2023
    2
    1
    0
    Location:
    British Columbia
    Vehicle:
    2012 Prius c
    Model:
    Three
    Hi there,
    I've been having issues with my 2012 Prius C shuddering and not accelerating well in the 30-40km/hr range. I wasn't experiencing this when the check engine light originally came on. I took it to my local shop when the light came on and they scanned it and the code came up saying it was an O2 sensor or the mass air flow sensor. We changed the mass air flow sensor, but the check engine light came back on and that was when the shuddering started. My local shop couldn't figure it out so I've now taken it to a shop that has more hybrid experience. They did a lot of investigating and everything was pointing to an issue with carbon build up in the exhaust recirculation system. They cleaned it out, but the check engine light came back on. They enlisted the help of the local Toyota service centre and have discovered that cylinders 3 and 4 are not operating correctly and there is likely a leak with the head gasket or intake manifold, but they will have to do more investigating to find exactly where the issue is, and then there will be the cost of fixing the issue once they figure out what it is. They've left me to decide what I want to do over the weekend as they are saying the cost of diagnosing the issue and fixing it is starting to add up and it may not be worth it to fix given the age of the vehicle. I have 233,000 km on it. I have never had any issue with the vehicle previously other than having to replace the 12V battery 3 years ago. I have been pretty diligent about all regular maintenance and oil changes.
    Has anyone else been through this type of issue with the Prius C? Were you able to figure out the problem and fix it? Do you think it was worth the effort and expense? TIA.
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    107,703
    48,947
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    i haven't been through it with the c, but when my gen 3 started exhibiting similar symptoms, i traded it in.
    unfortunately, a lot of toyotas don't go as far as they used to without expensive repairs
     
  3. AlHepburn

    AlHepburn New Member

    Joined:
    Dec 2, 2023
    2
    1
    0
    Location:
    British Columbia
    Vehicle:
    2012 Prius c
    Model:
    Three
    Thanks. It turned out to be the fuel injector seals that were causing the problem. Had them replaced and now it's running well again.
     
    bisco likes this.