2012 Prius Jbl no bass

Discussion in 'Gen 3 Prius Main Forum' started by Isti, May 4, 2021.

  1. Isti

    Isti New Member

    Joined:
    Apr 28, 2021
    4
    0
    0
    Location:
    London
    Vehicle:
    2012 Prius
    Model:
    N/A
    Anyone can help why no bass? Seems everything is good. I tried in the menu but nothing. Any idea? JBL
     
  2. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    5,687
    2,308
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    If all else fails disconnect the 12v for a few minutes. This will revert your stereo back to original settings... If that doesn't work, it's time to test your speakers and if they're good, it's time to replace your deck or amp if there's no loose connections.
     
  3. Isti

    Isti New Member

    Joined:
    Apr 28, 2021
    4
    0
    0
    Location:
    London
    Vehicle:
    2012 Prius
    Model:
    N/A
    Thanks ur help. The amp is good is new. I try to test the speakers. How u mean deck? What is that?
     
  4. Isti

    Isti New Member

    Joined:
    Apr 28, 2021
    4
    0
    0
    Location:
    London
    Vehicle:
    2012 Prius
    Model:
    N/A
    I checked the headunit, amp and speakers and all good. Maybe some wireing?
     
  5. PriusCamper

    PriusCamper Senior Member

    Joined:
    Mar 3, 2012
    5,687
    2,308
    0
    Location:
    Pacific Northwest, USA
    Vehicle:
    2007 Prius
    Model:
    Two
    Deck also means head unit, which also means the thing that the touch screen and knobs are attached to.
     
Loading...