2012 Prius v3 Bluetooth and USB Not Working Anymore

Discussion in 'Prius v Audio and Electronics' started by h-dogg, Sep 6, 2021.

  1. h-dogg

    h-dogg Junior Member

    Joined:
    Oct 12, 2004
    37
    5
    0
    Location:
    South Bay
    Vehicle:
    2012 Prius v wagon
    Model:
    Three


    My wife's 2012 Prius v3's Bluetooth and USB stopped working on Sept. 1. It was working okay before that and suddenly stopped. My wife suspects b/c it's almost 10 years and Toyota wants us to upgrade to a new one..haha..

    We tried to connect the Bluetooth by going into Settings, but you can't even click it to turn off/on.

    For the USB, I tried a different USB stick and it's grayed out in the Audio home. When I tried to go into the special Service Menu to check the ports, it says everything is all working.

    Anybody experienced this issue before?

    Thanks!
     
  2. rjparker

    rjparker Senior Member

    Joined:
    Jun 6, 2008
    3,878
    2,001
    2
    Location:
    Texas Hill Country
    Vehicle:
    2012 Prius v wagon
    Model:
    Three
  3. jzchen

    jzchen Senior Member

    Joined:
    Apr 9, 2012
    2,502
    769
    0
    Location:
    Arcadia, CA
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    I'm afraid I have not experienced this on our '12 v FIVE w/ATP.

    1st thing I would personally try, if you have not already, is disconnect the negative battery connection, wait some minutes, then reconnect and try again.

    2nd would be to try to check the wiring....
     
  4. h-dogg

    h-dogg Junior Member

    Joined:
    Oct 12, 2004
    37
    5
    0
    Location:
    South Bay
    Vehicle:
    2012 Prius v wagon
    Model:
    Three
    Thanks, I'll give the battery disconnect a try and read up on the extension module thread.

    Update: No luck with the battery disconnect. Still can't recognize the USB and the BT can't be set up.
     
    #4 h-dogg, Sep 6, 2021
    Last edited: Sep 6, 2021
  5. h-dogg

    h-dogg Junior Member

    Joined:
    Oct 12, 2004
    37
    5
    0
    Location:
    South Bay
    Vehicle:
    2012 Prius v wagon
    Model:
    Three


    Looks like I got it fixed by finding an update for the system. Apparently, I was running the old v1.2.? version and not v5.1. That seems to fix the issues. Never got the email or letters..lol
    I got the updates here: Download
     
    csole, burrito and jzchen like this.
  6. csole

    csole New Member

    Joined:
    Sep 29, 2021
    9
    0
    0
    Location:
    Fl
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    Mine is doing the same thing. A few days ago, can’t connect via usb or Bluetooth!
     
  7. csole

    csole New Member

    Joined:
    Sep 29, 2021
    9
    0
    0
    Location:
    Fl
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    My 2012 Prius V audio is out. I have radio only. When I press the App button it says system not installed. If I reset everything I can pair it but audio shuts off in 10 minutes or so. Tried following H dogg’e suggestion of going to the software update, but it says there is no available update for my Prius which does not have navigation. Any ideas?
     
  8. gromittoo

    gromittoo Active Member

    Joined:
    Mar 9, 2017
    507
    167
    0
    Location:
    philadelphia
    Vehicle:
    2012 Prius v wagon
    Model:
    Two
    I am confused. There are are 3 different units for the 2012 Prius V (Numbers seen on the faceplate).
    57010: Basic radio, CD and IIRC Bluetooth audio only. Standard on the "two" trim level. NOTE: No "APPS" Button!
    57011: HD-Radio, CD, Bluetooth, Navigation, and Sirius XM capable. Standard on the "three" and many "fives". Has an "APPS" button!
    57012: IIRC: HD-Radio, CD, Bluetooth, Navigation, and Sirius XM capable. JBL unit with external amp better speakers. Available as an optional package on fives.

    So when you state: "When I press the App button it says system not installed.", you definitely have Navigation. You might not use it, but you have it. Try the update that says "With Navigation". IIRC the current version is 5.2.1. I had to upgrade my 57011 when I got it. It had a really old version. Update the Gracenote database is optional.

    I upgraded the 57010 in my 2013 Prius V two, so I could get HD radio, and Maps. The eBay seller did not include the cable that connects the Panasonic main unit, to the expansion / extension box made by Harmon. Until I was able to purchase the missing cable, I would see "system not installed" when I hit the apps button.

    I suspect that you have pressed the APPS button before, and gotten a different response. So I assume you have the cable installed. The more likely scenario is you have a completely dead / dying Harmon box. Bluetooth (and anything accessed via the APPS button) is handled by the Harmon box. The Harmon boxes frequently go bad. Software upgrade is worth trying, as it costs nothing.

    Replacing the whole 57011 unit is the simplest solution, if the eBay seller includes a working Harmon box. You could buy the Harmon box by itself, but there are a lot of part numbers. You might buy one from a different Toyota model only to find that it is not compatible with your 57011.
     
    #8 gromittoo, Sep 30, 2021
    Last edited: Sep 30, 2021
  9. gromittoo

    gromittoo Active Member

    Joined:
    Mar 9, 2017
    507
    167
    0
    Location:
    philadelphia
    Vehicle:
    2012 Prius v wagon
    Model:
    Two
    Try the software Update first.

    If you still have issues, I have a 57011 with a known working Harmon box I might be willing to sell. I upgraded a second time to a "Facelift" 510057 Unit out of a 2016. The upgrade is worth it, and units are selling for about $250. If you "watch" one the listings, you will probably get an offer from the seller at a lower price. Be careful that you get all the cables and the expansion box!

    There is a thread in this forum dedicated to the "Facelift" upgrade.
     
    #9 gromittoo, Sep 30, 2021
    Last edited: Sep 30, 2021
  10. csole

    csole New Member

    Joined:
    Sep 29, 2021
    9
    0
    0
    Location:
    Fl
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    Thank you! Still working on it and will check ebay now. really appreciate the info.
     
  11. csole

    csole New Member

    Joined:
    Sep 29, 2021
    9
    0
    0
    Location:
    Fl
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    So i just took my 57011 out and unplugged the Bluetooth module and it is working fine. Any idea what that is about??? Seriously, i unplugged the Bluetooth and it is working with Bluetooth.
     
  12. csole

    csole New Member

    Joined:
    Sep 29, 2021
    9
    0
    0
    Location:
    Fl
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    Hi. I took the unit out this morning, and unplugged the harness from the Bluetooth part on the bottom. Just the wide multi wired connection, left the 2 small ones intact. And viola! My phone works perfectly via Bluetooth. Any feedback on why i would need to replace the Bluetooth module at this point?
     
  13. gromittoo

    gromittoo Active Member

    Joined:
    Mar 9, 2017
    507
    167
    0
    Location:
    philadelphia
    Vehicle:
    2012 Prius v wagon
    Model:
    Two
    attachThumb217230
    Interesting. It seems you have found a way to reset the box by disconnecting the main connector. I assume the you reconnected the wide connector. Let's see if the BT problem stays away.

    The small connector on the bottom left corner is the GPS antenna. I am not sure, but the small connector next to the GPS antenna might be the signal that tells the GPS how fast the car is moving, and if the car has made a turn. Neither of those would have any effect on Bluetooth.

    I found some photos I took of a Diagnostic screen for the whole 57011 unit, including the Harman Becker box:
     
    #13 gromittoo, Oct 5, 2021
    Last edited: Oct 5, 2021
  14. gromittoo

    gromittoo Active Member

    Joined:
    Mar 9, 2017
    507
    167
    0
    Location:
    philadelphia
    Vehicle:
    2012 Prius v wagon
    Model:
    Two
    IIRC: To get this menu to appear requires you to hold the "SETUP" button or maybe the "APPS" button while turning the parking lights on and off 4 times in 10 seconds. I don't have the 57011 installed to check.

    I suspect what you are interested in is in the "Failure Diagnostics" button. I am guessing there is a way to reset the Bluetooth radio in that menu.

    I noticed that there is a field labeled BT in the Panasonic information that says "No Information". I think that is correct, since the 57010 model Panasonic box has a Bluetooth radio, and no expansion box. The 57011 has the expansion box to do the Bluetooth, but I suspect that the software for the Panasonic 57010 and 57011 have common software. That explains the BT "No Information"

    Opps.. Pictures:
    Top_Menu.jpg
    Version_For_EXT_BOX.jpg
    Version_For_DA.jpg

    Service_Information.jpg

    Version_Information.jpg
     
    #14 gromittoo, Oct 5, 2021
    Last edited: Oct 5, 2021
  15. csole

    csole New Member

    Joined:
    Sep 29, 2021
    9
    0
    0
    Location:
    Fl
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
     

    Attached Files:

  16. csole

    csole New Member

    Joined:
    Sep 29, 2021
    9
    0
    0
    Location:
    Fl
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    Actually, I left the harness unplugged and I’ve had Bluetooth phone and music for 3 days now! I have no idea why, but disconnecting the Bluetooth module gave me my Bluetooth back!
     
  17. gromittoo

    gromittoo Active Member

    Joined:
    Mar 9, 2017
    507
    167
    0
    Location:
    philadelphia
    Vehicle:
    2012 Prius v wagon
    Model:
    Two
    The main unit of the 57011, made by Panasonic looks very similar in appearance to the main unit of the 57010, also made by Panasonic. My Prius V two came with a 57010, which did support Bluetooth but did not have the expansion box. IIRC, it did not display anything but Artist name and song title when using Bluetooth. My theory is that the Bluetooth hardware exists in the 57011 in the main unit, but uses the Bluetooth hardware in the expansion box if found.

    You might ask why would they put Bluetooth hardware in the expansion box, when the main box already has it? I could be wrong about this, but the "Gracenote database" lives in the expansion box. My understanding is that the "Gracenote database" provides the poster art for the artist / song that is currently playing. In my 2017, that poster art appears whether it is coming from Bluetooth, HD-radio, or SXM radio. My theory is that by using the Bluetooth in the expansion box, it gave access to the poster art.

    To confirm my theory, do you still see artist specific poster art when you play using Bluetooth, and the cable disconnected? If you were seeing it when it worked with the cable connected, and are now not seeing it with the cable disconnected, that would suggest that the 57011 main unit switched to using its internal Bluetooth radio.

    Of course the GPS definitely would not work without the expansion box.
     
  18. csole

    csole New Member

    Joined:
    Sep 29, 2021
    9
    0
    0
    Location:
    Fl
    Vehicle:
    2012 Prius v wagon
    Model:
    Five
    Yep, that explains it then. The whole audio system seemed to go bad when i updated my phone to to IOS 15, could be coincidence, but uncanny timing. And no, i dont have album art, but no big deal for me as i mostly stream stuff like podcasts, and have never used the Prius built in navigation but prefer to use my google maps in my phone.
    Thanks so much! I’ll just keep using it as is till the 57011 conks out!
     
  19. gromittoo

    gromittoo Active Member

    Joined:
    Mar 9, 2017
    507
    167
    0
    Location:
    philadelphia
    Vehicle:
    2012 Prius v wagon
    Model:
    Two
    I originally upgraded from the 57010 to the 57011 to get the GPS, but not for navigating. As an Uber driver, I find that a phone's "location Services" is too unreliable. Often when center city Philadelphia, the tall buildings would have me my location suddenly jump to another street, and would start recalculating my route. This is because phone use cell towers for location, and those signals cause echos that confuse the phone. I needed the car GPS so I know the name of the street I am actually on, and the direction I am heading.

    The 57011 uses pretty old Bluetooth technology, so the IOS upgrade makes sense. I find that the limit of 4 Paired devices just not acceptable. The complicated way to get a new passenger to pair their phone to the audio system is overly cumbersome. And that it must be done while the car is stopped makes it pretty much useless, so I just told them the Bluetooth was broken.
     
Loading...