2013 MFD malfunction or about to die?

Discussion in 'Gen 3 Prius Audio and Electronics' started by Bailey550, Aug 7, 2018.

  1. Bailey550

    Bailey550 New Member

    Joined:
    Aug 6, 2018
    1
    0
    0
    Location:
    Florida
    Vehicle:
    2013 Prius
    Model:
    Two
    Purchased new in 2013; currently 36K miles, so out of warranty and no extended warranty. Here's the issue:

    About a month ago, on start-up, the MFD display would have a white background--I guess that's the daylight option. After 2-3 minutes, it would go back to the usual dark background. All buttons function. This happened intermittently, but only on initial start-up of the day. Car is not garaged, but under carport in Florida. It started to happen more often, but not every day, and when I took it to the dealer for routine maintenance, I told them about the problem with the MFD. They could not replicate the problem and sent me on my way, altho told me it could be a $1000 fix since the car was out of warranty. I started googling, and my worry is that this is the precursor to MFD going completely dead and then I won't be able to use the radio or other functions controlled by the screen. Problem is happening more often and also happens when car is parked in sunlight. I'd like to know what the end result is likely to be--I might just try to get some help from dealer or Toyota now since the car has so few miles on it, but if it's not going to be a big deal, well, the plan was to give the car to my daughter in a couple of years and get me a new car.
    Prius1.jpg PriusNormal.jpg
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    68,568
    26,843
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    welcome!

    does seem odd, call corporate and see what they say. if you need one in the end, look for used and a local mechanic to install.
     
Loading...