2013 Prius C Apps/Source/Bluetooth/Aux not working

Discussion in 'Prius c Audio and Electronics' started by ThingsofDesire, Aug 5, 2019.

  1. ThingsofDesire

    ThingsofDesire New Member

    Joined:
    Aug 5, 2019
    1
    0
    0
    Location:
    Saint John, NB
    Vehicle:
    2013 Prius c
    Model:
    Technology
    The touch-screen "source" button stopped working, along with the USB and Aux plug-ins, and the Apps button. Radio works fine, and CD can be accessed by inserting disc. The setup button works, bringing up icons for general, bluetooth, etc. But the phone, bluetooth and other extension box related functions don't trigger when touched. The display also does this other funny thing quite often, where the stereo goes silent and then returns with the "Source" icon changed by having three squares next to the word. Oddly, this new "source" button works, but then the stereo, about a minute later goes silent again and comes back to life with the old "source" icon again.
    From other posts, it looks like I have a problem with the Bluetooth extension to the stereo. Seems like a common design flaw. Dealership, of course, as others have complained, suggested just replacing the whole stereo. No thanks.
    The problem I'm having is although I've read about similar problems, I haven't seen a scenario quite like I have.
     
  2. Leadfoot J. McCoalroller

    Leadfoot J. McCoalroller Senior Member

    Joined:
    May 12, 2018
    2,138
    2,004
    1
    Location:
    Pennsylvania
    Vehicle:
    2018 Prius c
    Model:
    Two
    If you’re facing a replacement of the head unit, just get an aftermarket one and enjoy some 2019 features instead. Much cheaper than a replacement factory stereo. It’s very easy/inexpensive in the c model.
     
  3. icspots

    icspots Junior Member

    Joined:
    Nov 8, 2013
    25
    20
    0
    Vehicle:
    2012 Prius c
    Model:
    Four
    Just had this exact problem with our 2012 Pc4. It’s been a little frizty for a couple of months, menus not always showing, power not cycling fully off when turned off, etc. I noticed whenever I drove it I had a bitch of a time getting it to pair with my phone (wants to pair to my wife’s phone, and does so automatically) even though it was already in the device list. Then just last week all of the BT crapped out, half the menus/buttons stopped working just like you described.

    We went ahead and just ordered a replacement aftermarket Pioneer stereo. Pretty basic HD touchscreen unit (AVH501EX) without NAV, CarPlay, AA, etc. With the add on iData maestro kit the only function we lost is the mileage/regenerative token display, and the power flow diagram..... both are available on the dashboard. The maestro provides control for all of the light and door locking functions, plus gives on screen TPMS, and acts as a OBDII scanner. It maintains the factory USB plug on the dash, and if you have it the factory backup camera. With all the extras and install kit it was only like $400 from Crutchfield.
     
  4. Rondy Monnaie

    Rondy Monnaie New Member

    Joined:
    Jun 26, 2019
    9
    1
    0
    Location:
    Seychelles
    Vehicle:
    2017 Aqua
    Model:
    N/A
    I would recommend the ATOTO aftermarket stereo. I have had it installed for a few months now and it is absolutely fabulous. The harness is basically plug and play with only a few wires that need to be spiced for steering wheel control and reverse camera.
     
Loading...