2014 Prius 19k miles P0A0F P3190 P0401

Discussion in 'Gen 3 Prius Main Forum' started by Sharnold, Sep 12, 2019.

  1. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Upon inspection with techstream hybrid battery is ok as so is the map mass and throttle body they all are spotless no oil in the intake or on any components so I'm leaning more on the P0401. When you crank the car idles up then back down rattles out then dies. You can however put the car in drive and take it up the road with no loss of power or any issues. This is only at start up and shutdown. Any ideas? Also the car was wrecked in the front end so has a rebuilt title.......

    Posted via the PriusChat mobile app.
     
    #1 Sharnold, Sep 12, 2019
    Last edited: Sep 12, 2019
  2. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Heres the current DTC issues any diagnostics needed I can take a picture and send. Sorry my camera had oil on it 20190912_063121.jpeg

    Posted via the PriusChat mobile app.
     
  3. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    I had a couple of cylinder misfires also I'm beginning to lean towards the EGR code is causing the P3190

    Posted via the PriusChat mobile app.
     
  4. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Vsv line was off on the intake after putting it back on and clearing the dtc same issue. Must the ecu be recalibrated or do I need to proceed to egr and intake cleaning?

    Posted via the PriusChat mobile app.
     
  5. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    82,237
    35,720
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    how do you get so many newer cars with problems? i think you get more than we see across this entire board.
     
    Sharnold likes this.
  6. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Lol other than the dealerships I'm the only person in a very large area that works on them. Alot of mine are rebuilt title cars. I've also got two wrecked Gen 2 Prius at my shop being painted and repaired that we bought totalled with low miles. The only things the other shops will do is standard maintenance or change out a battery. I also go to other shops if they have any issues. I repair diesels and other vehicles as well. This is also not my full time job. 20190912_112319.jpeg

    Posted via the PriusChat mobile app.
     
    RMB, davecook89t and bisco like this.
  7. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Heres the conundrum after cleaning the egr pipe and checking the egr valve that by the way works flawlessly I cleared the dtc codes drove the car 10 miles no issues no dash lights. As soon as I pull it into the garage to park it engine starts rattling and bucking violently. Only has one dtc P0101 mass air flow sensor any ideas considering its brand new

    Posted via the PriusChat mobile app.
     
  8. Raytheeagle

    Raytheeagle Senior Member

    Joined:
    Jul 1, 2016
    9,045
    12,194
    0
    Location:
    Bay Area, CA
    Vehicle:
    2019 Prius Prime
    Model:
    Prime Plus
    Connection is secure and seated?
     
    Sharnold likes this.
  9. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Yes its completely seated and clean with an accompanying P0171. The problem that bothers me was the intense bucking and rattling of the engine

    Posted via the PriusChat mobile app.
     
  10. ASRDogman

    ASRDogman Senior Member

    Joined:
    May 29, 2018
    1,201
    760
    0
    Location:
    Indian River County, Florida
    Vehicle:
    2010 Prius
    Model:
    Two
    Maybe double check every connection, and vacuum connections.
    Maybe a vacuum hose is loose, or cracked?
     
    mjoo likes this.
  11. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    2,245
    2,741
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring
    Definitely sounds like something is messing up the idle vacuum. Air is coming from somewhere. Or fuel isn't.
     
  12. Mendel Leisk

    Mendel Leisk Obtuse Angler

    Joined:
    Oct 17, 2010
    35,128
    24,018
    80
    Location:
    Greater Vancouver, British Columbia, Canada
    Vehicle:
    2010 Prius
    Model:
    Touring
    You said everything was fine until you got back to your garage? Why would that be: no stop-and-idle on your test drive, or maybe everything fine until it's warmed up??
     
  13. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    No idling issues at any stop signs or turns or misfiring or rough jerking while driving only after I pulled it into the garage and hit the park button did it start and throw the maintenance needed and started rattling. Map was at 13psi last test. No misfires recorded

    Posted via the PriusChat mobile app.
     
    #13 Sharnold, Sep 12, 2019
    Last edited: Sep 12, 2019
    Mendel Leisk likes this.
  14. TMR-JWAP

    TMR-JWAP Senior Member

    Joined:
    Aug 12, 2016
    2,245
    2,741
    0
    Location:
    Columbia, SC
    Vehicle:
    2007 Prius
    Model:
    Touring
    Does it clear up again if you go back to D or R?

    This is an interesting one.
     
  15. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    No actually it rattles just as bad and dies out in D of course R just cuts it off and puts it on the HV battery..... but if you take off in the car it clears up and will run fine till you return it to park lol like I said a conundrum

    Posted via the PriusChat mobile app.
     
  16. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Best bet I'll change the mass sensor out if it doesn't work I'll put the car in maintenance mode to keep the engine running and spray starter fluid to check for air leaks

    Posted via the PriusChat mobile app.
     
    mjoo likes this.
  17. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    New fun..... changed the mass sensor got 3 new codes I havnt had
    P0102
    P0113
    P0171
    All referring back to the mass sensor...
    Shoot me for fixing rebuilt title cars I'll take a bone if someone wants to throw one too me. Yes the plug is seated Yes the plug is clean Yes the wires are all good on the harness and voltage is correct

    Posted via the PriusChat mobile app.
     
    #17 Sharnold, Sep 13, 2019
    Last edited: Sep 13, 2019
  18. ASRDogman

    ASRDogman Senior Member

    Joined:
    May 29, 2018
    1,201
    760
    0
    Location:
    Indian River County, Florida
    Vehicle:
    2010 Prius
    Model:
    Two
    This might seem silly, but are you sure you got the correct one?
    Did you check for vacuum leaks?
     
  19. Sharnold

    Sharnold Member

    Joined:
    Jan 16, 2019
    261
    86
    0
    Location:
    Alabama
    Vehicle:
    Other Non-Hybrid
    Model:
    N/A
    Yes it's the correct one matching numbers just like the factory denso one. No vacumn leaks ran the car in maintenance mode sprayed nothing.
    Posted via the PriusChat mobile app.
     
  20. ASRDogman

    ASRDogman Senior Member

    Joined:
    May 29, 2018
    1,201
    760
    0
    Location:
    Indian River County, Florida
    Vehicle:
    2010 Prius
    Model:
    Two
    Maybe the pcv valve or egr valve or both are sticking?
     
Loading...