Audio Display disappears

Discussion in 'Gen 3 Prius Care, Maintenance & Troubleshooting' started by mikey_t, Feb 8, 2019.

  1. mikey_t

    mikey_t Member

    Joined:
    Feb 5, 2019
    167
    185
    0
    Location:
    Los Angeles
    Vehicle:
    2010 Prius
    Model:
    Two
    My 2010 gen II started having a strange issue with the audio display. The info disappears, and if I push one of the preset radio buttons (1,2,3, etc.) it turns off. If I push one of the buttons again it comes back but stays on whichever station it was already on and the screen stays blank.

    Anyone else have this? Any way to fix?
     
  2. tweedle99

    tweedle99 Member

    Joined:
    Feb 7, 2012
    67
    37
    0
    Location:
    Round Rock, TX
    Vehicle:
    2010 Prius
    Model:
    III
    Defective display. Dealer just replaced the radio when mine had the same issue.
     
  3. mikey_t

    mikey_t Member

    Joined:
    Feb 5, 2019
    167
    185
    0
    Location:
    Los Angeles
    Vehicle:
    2010 Prius
    Model:
    Two
    Ah, thank you.

     
  4. alanwagen

    alanwagen Member

    Joined:
    Dec 15, 2008
    103
    66
    0
    Location:
    FORT WORTH
    Vehicle:
    2010 Prius
    Model:
    Two
    Mine does some of the same crap. So random and weird. It comes back, when I restart the car. I think it is a common problem but I'm to cheap to upgrade or replace.
     
    mikey_t likes this.
  5. mikey_t

    mikey_t Member

    Joined:
    Feb 5, 2019
    167
    185
    0
    Location:
    Los Angeles
    Vehicle:
    2010 Prius
    Model:
    Two
    Yeah, I'm in the same boat. I'm not sure how much it would cost to replace but it's sort of an annoying thing to have to deal with.
     
Loading...