B1504 Lost Communication with Steering SW

Discussion in 'Newbie Forum' started by xamza, Jul 19, 2019.

Tags:
  1. xamza

    xamza New Member

    Joined:
    Apr 7, 2019
    16
    1
    0
    Location:
    lahore
    Vehicle:
    2012 Prius
    Model:
    N/A
    Problem: Prius III - Trip / Disp buttons on the steering wheel are not working. All other buttons work fine. Is there a way to change from ODO to Trip A/B via OBD ? Techsteam reports error "B1504 Lost Communication with Steering SW". what i can do? i try changing the spiral cable, button but no things works.
     
  2. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    80,822
    34,790
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    did you use a new oem cable?
     
    xamza likes this.
  3. xamza

    xamza New Member

    Joined:
    Apr 7, 2019
    16
    1
    0
    Location:
    lahore
    Vehicle:
    2012 Prius
    Model:
    N/A
    I do not know about this cable could you please show me picture of that. I try changing spiral cable, control buttons even also change the whole meter but trip/disp buttons not works.
     
  4. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    80,822
    34,790
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    sorry, i meant the spiral cable. was it toyota or aftermarket. many aftermarket cables have been defective out of the box
     
  5. xamza

    xamza New Member

    Joined:
    Apr 7, 2019
    16
    1
    0
    Location:
    lahore
    Vehicle:
    2012 Prius
    Model:
    N/A
    Its of toyota genuine one.
     
    bisco likes this.
  6. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    80,822
    34,790
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    i don't know what else it can be, if it was installed properly.

    if anything could change trip meter, it would be tech stream
     
  7. xamza

    xamza New Member

    Joined:
    Apr 7, 2019
    16
    1
    0
    Location:
    lahore
    Vehicle:
    2012 Prius
    Model:
    N/A
    I checked the wires coming from the meter and going inside the spiral cable there are 1 wire with no pulse. is there any issue in that wire ? possible?
     
  8. bisco

    bisco cookie crumbler

    Joined:
    May 11, 2005
    80,822
    34,790
    0
    Location:
    boston
    Vehicle:
    2012 Prius Plug-in
    Model:
    Plug-in Base
    anything is possible. i would suggest a subscription to the service manual at techinfo.toyota.com
     
Loading...